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Preface

The Sun StorEdge 3310 SCSI Configuration Service Version 1.0 User Guide explains how
to install and use Configuration Service to configure, monitor, and manage the Sun
StorEdge™ array. It also explains how to install and configure Diagnostic Reporter, a
companion utility of Configuration Service for sending and receiving system
messages from the hosts and arrays.

This manual is written for experienced system administrators who are already
familiar with Sun’s hardware and software products.

How This Book Is Organized
This book contains the following topics:

Chapter 1 introduces Sun StorEdge Configuration Service features.

Chapter 2 lists steps to follow to ensure that the Sun StorEdge array has been
configured properly before installing and using Configuration Service.

Chapter 3 provides system requirements and installation procedures for
Configuration Service Consoles and Agents on systems running the Solaris™
operating environment.

Chapter 4 provides system requirements and installation procedures for
Configuration Service Consoles and Agents on Microsoft Windows NT/2000
systems.

Chapter 5 contains procedures for setting up Configuration Service.

Chapter 6 provides instructions for configuring the Sun StorEdge array.

Chapter 7 explains how to monitor the Sun StorEdge array.
xvii



Chapter 8 describes how to maintain the integrity of the Sun StorEdge array.

Chapter 9 explains how to change or add to the current Sun StorEdge array
configuration.

Chapter 10 provides instructions on how to install, set up, and use Diagnostic
Reporter.

Appendix A provides basic RAID information.

Appendix B explains how to monitor and download firmware to a standalone JBOD.

Appendix C provides information about setting up a cluster configuration.

Appendix D explains how to set up Configuration Service’s full event monitoring
and email notification capabilities.

Appendix E provides troubleshooting suggestions for a list of symptoms.

Appendix F contains a list of Configuration Service error codes and messages.

The Glossary contains a list of acronyms and terminology relating to Configuration
Service and used in this user guide.

Using UNIX Commands
This document might not contain information on basic UNIX® commands and
procedures such as shutting down the system, booting the system, and configuring
devices.

See one or more of the following for this information:

■ Solaris Handbook for Sun Peripherals
■ AnswerBook2™ online documentation for the Solaris™ operating system
■ Other software documentation that you received with your system
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Typographic Conventions

Shell Prompts

Typeface*

* The settings on your browser might differ from these settings.

Meaning Examples

AaBbCc123 The names of commands, files,
and directories; on-screen
computer output

Edit your.login file.
Use ls -a to list all files.
% You have mail.

AaBbCc123 What you type, when contrasted
with on-screen computer output

% su

Password:

AaBbCc123 Book titles, new words or terms,
words to be emphasized.
Replace command-line variables
with real names or values.

Read Chapter 6 in the User’s Guide.
These are called class options.
You must be superuser to do this.
To delete a file, type rm filename.

Shell Prompt

C shell machine-name%

C shell superuser machine-name#

Bourne shell and Korn shell $

Bourne shell and Korn shell superuser #
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Related Documentation

Technical Support
For late-breaking news and troubleshooting tips, review the Sun StorEdge 3310 SCSI
Array Release Notes located at:

http://www.sun.com/products-n-solutions/
hardware/docs/Network_Storage_Solutions/Workgroup/3310

For 24x7 access to web-based support solutions, visit the Online Support Center at:

http://www.sun.com/service/online

To initiate or check on a USA-only service request, contact Sun support at:

1-800-USA4SUN

To obtain international technical support, contact the sales office of a specific country
at:

http://www.sun.com/service/contacting/sales.html

Application Title Part Number

Late-breaking news Sun StorEdge 3310 SCSI Array Release Notes 816-7292

Installation and service Sun StorEdge 3310 SCSI Array Installation, Operation,
and Service Manual

816-7290

Best practices Sun StorEdge 3310 SCSI Array Best Practices Manual 816-7293

Safety and compliance Sun StorEdge 3310 SCSI Array Safety, Regulatory, and
Compliance Manual

816-7291

Firmware Sun StorEdge 3310 SCSI RAID Firmware Guide 816-7296

Reporting software Sun StorEdge 3310 SCSI Diagnostic Reporter User
Guide

816-7722

Command line interface tools Sun StorEdge 3310 SCSI CLI Version 1.0 User Guide 816-7297
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Accessing Sun Documentation Online
All Sun StorEdge 3310 SCSI Array online documentation is located at:

http://www.sun.com/products-n-solutions/
hardware/docs/Network_Storage_Solutions/Workgroup/3310

You can order printed copies of the Sun StorEdge 3310 SCSI array manuals at:

http://corppub.iuniverse.com/marketplace/sun

You can view, print, or purchase a broad selection of Sun documentation, including
localized versions, at:

http://www.sun.com/documentation

Sun Welcomes Your Comments
Sun is interested in improving its documentation and welcomes your comments and
suggestions. You can email your comments to Sun at:

docfeedback@sun.com

Please include the part number (816-7298-11) of your document in the subject line of
your email.
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CHAPTER 1

Introduction

This section provides a brief overview of Sun StorEdge Configuration Service
features.

Note – Throughout the remainder of this guide, Sun StorEdge Configuration Service is
referred to as Configuration Service or the program.

Configuration Service Features
Configuration Service is a sophisticated program based on the Java™ programming
language, which brings together storage configuration, maintenance, and monitoring
tools into one application for centralized administration of the Sun StorEdge array.

From a single console located on a network, system administrators can initialize
network storage, change configurations, monitor status, and schedule routine
maintenance with an intuitive graphical user interface (GUI).

Administrators can also dynamically allocate, reallocate, or expand capacity as
storage requirements continually change with evolving network-wide storage
demands.

In the event of a change in status, Configuration Service sends alerts by console
display, email, or alphanumeric pager. Configuration Service can also send alerts to
any Simple Network Management Protocol (SNMP) enterprise manager, for example
HP OpenView®.
1



Configuration Service consists of two components:

■ Configuration Service Agent – Solaris 8 and Solaris 9 operating environments, and
Microsoft® Windows NT® and Windows® 2000.

The agent monitors attached disk storage devices and reports their status to the
console about these devices. The agent software needs to be installed on each
individual server in the network that is part of Configuration Service. The
installation can be done remotely from a single workstation on the network.

■ Configuration Service Console – Solaris 8 and Solaris 9 operating environments, and
Microsoft Windows NT and Windows 2000.

The console contains the GUI portion of Configuration Service and displays the
information reported by the agents. The console also provides remote
configuration and management of the devices from a single workstation. The
Configuration Service Console needs to be installed on a computer that manages
the servers on your network.
2 Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



CHAPTER 2

Before You Begin

Before you install Configuration Service, you need to ensure that the Sun StorEdge
array has been configured properly. This chapter contains important information
you need to be aware of before you install and use Configuration Service. Topics
covered in this chapter include:

■ “Solaris Operating Environment” on page 3
■ “Microsoft Windows NT/2000 Operating System” on page 4
■ “Logical Volumes” on page 5
■ “Superuser/Administrator Privileges” on page 5

Solaris Operating Environment
Before you install Configuration Service on systems running the Solaris operating
environment:

■ Make sure the host server that the Configuration Service Agent is installed on is
connected to a channel with a primary ID assigned. Refer to the Sun StorEdge 3310
SCSI Array Installation, Operation, and Service Manual for controller defaults and
initial configuration information.

■ Make sure the operating environment can recognize multiple LUNs under the
same ID. You might need to modify /kernel/drv/sd.conf for additional host
LUN assignments.

As shown in the following example, separate entries are required for each target
ID and LUN defined in the Sun StorEdge array configuration. Avoid adding
entries that are not used as this will increase host startup times.
3



If you make any changes to the sd.conf file, you will need to reboot the
workstation for the modifications to take effect.

Microsoft Windows NT/2000 Operating
System
Before you install Configuration Service on Microsoft Windows operating systems:

■ Make sure the host server that the Configuration Service Agent is installed on is
connected to a channel with a primary ID assigned. Refer to the Sun StorEdge 3310
SCSI Array Installation, Operation, and Service Manual for controller defaults and
initial configuration information

■ Make sure the server is connected to the operating system and the server
recognizes the storage.
4 Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



Logical Volumes

Caution – Configuration Service does not support Logical Volumes.

Superuser/Administrator Privileges
You must have superuser/administrator privileges to install Configuration Service
and run the Configuration Service Console.
Chapter 2 Before You Begin 5
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CHAPTER 3

Installing Configuration Service on
Systems Running the Solaris
Operating Environment

This chapter provides procedures for installing Configuration Service Consoles and
Agents on systems running the Solaris operating environment. Topics covered in this
chapter are as follows:

■ “System Requirements” on page 7
■ “Prior to Installing Configuration Service” on page 8
■ “Installing Software” on page 9
■ “Users and Passwords” on page 13
■ “Uninstalling Configuration Service” on page 15

System Requirements
■ Netscape™ 4.0 – To view online help.

■ TCP/IP compliant network interface for Console – Each Configuration Service
Console must have a TCP/IP compliant network interface (such as an Ethernet or
Token Ring network card, or a serial line with a modem).

■ The Configuration Service Console is best viewed with a monitor resolution of
800 x 600 pixels with 256 colors. For other console requirements, see the following
table.
7



■ TCP/IP compliant network interface for Agent – Each Configuration Service
Agent must have a TCP/IP capable network card interface and driver set
(included with the operating environment). For other agent requirements, see the
following table.

Prior to Installing Configuration Service
Note the following required procedures and additional options prior to installing
Configuration Service and its related software components.

■ Be sure to read the Sun StorEdge 3310 SCSI Array Release Notes.

■ Install operating environment updates. To run Configuration Service on the
Solaris operating environment, you need to install the most current Sun
recommended operating environment patches and Java patches for Solaris 8 and
Solaris 9 operating environments. For a list of Sun recommended patches, refer to
the Sun StorEdge 3310 SCSI Array Release Notes.

■ If your operating environment contains an enterprise management console, you
can optionally configure Configuration Service Agents to send trapped events to
the console using the SNMP service. The SNMP service is included with the
operating environment and is installed after installing the TCP/IP protocol stack.

TABLE 3-1 Console System Requirements

Solaris Operating Environment
Version Memory Disk Space

Solaris 8 and Solaris 9 with
Sun recommended patches.
(For a list of Sun
recommended patches,
refer to the Sun StorEdge
3310 SCSI Array Release
Notes

64 MB recommended 16 MB free disk space minimum

TABLE 3-2 Agent System Requirements

Solaris Operating Environment
Version Memory Disk Space

Solaris 8 and Solaris 9 128 MB minimum 1 MB free disk space
minimum
8 Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



■ If you want the Configuration Service servers on your network to send SNMP
traps to the enterprise management console, see “Email and SNMP” on page 199.

■ Optional. To install and use Sun StorEdge Diagnostic Reporter, a companion
utility of Configuration Service that reports your storage system events to
specified email addresses, see “Installing and Using Diagnostic Reporter” on
page 163.

Note – You must be a superuser to install Configuration Service and run the
Configuration Service Console.

Installing Software
Configuration Service software comprises the following components:

■ Configuration Service Agent

■ Configuration Service Console

■ Diagnostic Reporter (optional utility – for installation and operation details, see
“Installing and Using Diagnostic Reporter” on page 163)

Configuration Service Installation Packages
The Configuration Service installation packages are contained on the Sun StorEdge
Professional Storage Manager CD, and include the following files:

■ SUNWscsu – Configuration Service Console
■ SUNWscsd – Configuration Service Agent
■ SUNWscsa – Diagnostic Reporter Agent
■ SUNWscui – Diagnostic Reporter Config Tool (UI)
■ SUNWsccli – Configuration Service CLI
Chapter 3 Installing Configuration Service on Systems Running the Solaris Operating Environment 9



▼ To Install the Configuration Service Agent and
Console
Install the agent on each of the servers that is part of Configuration Service. Install
the console on the computer or workstation you plan to use for managing and
maintaining the storage system.

The Configuration Service management console package, SUNWscsu, can be
installed on the server or on any client system. The Configuration Service Agent
package, SUNWscsd, must be installed on the server to which the storage is attached.

Complete the following steps to install the agent, console, or both. You must install
at least one agent and one console for Configuration Service to run.

Note – Make sure Java runtime environment 1.2 or higher is installed on the
computer or workstation on which you are installing Configuration Service.

1. Insert the Sun StorEdge Professional Storage Manager CD and type

2. Install the packages in one of the following ways:

a. To install the agent only, type

b. To install the console only, type

c. To install all packages, type

d. To select which packages to install from a menu, type

# cd /cdrom/cdrom0/product/solaris

# pkgadd -d SUNWscsd

# pkgadd -d SUNWscsu

# pkgadd -d . all

# pkgadd -d .
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e. To install the daemons only, type

3. Provide appropriate responses to each of the standard installation prompts.

Most of the installation prompts are standard pkgadd -d prompts regarding which
packages to install and how to process scripts (with superuser privileges).

a. At the Select packages prompt, type the appropriate response depending on
the install method. For example, if you chose 2a or 2b, type 1 and press Return.

b. To continue with the installation, type y and press Return.

c. If installing the console, answer whether Java runtime environment version,
1.2.2, 1.3, or 1.4 has been installed. (If installing the agent, you receive a
warning that Java runtime environment 1.2, 1.3, or 1.4 needs to be installed.)

To determine the Java runtime environment version that is currently installed,
type

If the command returns a pre 1.2.2 Java runtime environment version, for
example, 1.1.7, but you know that Java runtime environment 1.2.2, 1.3, or 1.4 has
been installed, check the /usr directory to confirm there is a link from Java to the
latest version instead of Java 1.1. For instructions on creating the link, see
“Troubleshooting” on page 211.

d. If the answer is yes, type y and press Return to continue.

If the answer is no, download the required Java runtime environment from
www.sun.com.

# pkgadd -d . SUNWscsd SUNWscsa

Select package(s) you wish to process (or ‘all’ to process all
packages). (default:all) [?,??,q]: 1

Do you want to continue with the installation [y,n,?] y

# java -version

is JRE 1.2.2, 1.3, or 1.4 installed? [y,n,?] y
Chapter 3 Installing Configuration Service on Systems Running the Solaris Operating Environment 11



Configuration Service Agent and Console are installed in the following directory:
/opt/SUNWsscs/sscsconsole.

e. To configure Configuration Service to use a browser that was not provided
during install, or to change to a different browser, edit the file
browser.default found in the installation directory
/opt/SUNWsscs/sscsconsole.

Replace the existing line of text with the absolute path name of the browser. If the
Configuration Service Console is running, you must exit and restart it to read the
default browser information.

4. Before rebooting, edit the SCSI driver configuration file if:

■ Third-party HBAs with multiple drives and multiple LUNs are used
■ Fibre devices are used
■ All LUNs have the same ID

Edit the file /kernel/drv/sd.conf, adding lines for Logical Unit Numbers as
appropriate for your configuration. LUNs can be numbered from 0-31. Generally,
do not add more LUN definitions than you actually plan to have since doing this
increases the time needed to scan each SCSI bus, whether or not it has storage
connected. For an example sd.conf file, see “Solaris Operating Environment”
on page 3.

5. When the installation procedure is complete, reboot to activate the server
daemons.

On reboot, the daemon kernel starts automatically restoring volume management to
the state it was in before this process was begun.

Note – Except for online HTML files, no other documentation is installed.

▼ To Start or Stop the Configuration Service Agent
To start the Configuration Service Agent software on the server, you must reboot the
server. If you did not reboot the server after completing the installation procedure,
be sure to edit the /kernel/drv/sd.conf file and reboot.

Configuration Service daemons can be stopped and started manually by using the
run commands script in /etc/rc2.d called S81ssagent.

1. To start the daemons, type

# /etc/rc2.d/S81ssagent start
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Note – To start the daemons, you must have superuser privileges and you must be
using the Bourne shell.

If start is used without having used stop first, the script restarts any daemons
that have stopped. If all the daemons have stopped (as with a stop option) the
script reconfigures the runtime environment before restarting the daemons.

2. To stop the daemons, type

3. To determine if daemons are running, type

Both ssmon and ssserver are displayed in the output. If you have enabled SNMP
trap generation, you also see the name sstrapd.

4. If the storage system is not being displayed after initial boot, stop the
Configuration Service Agent daemons, and at the command prompt, run

5. Label the desired disks, and then restart the Configuration Service daemons.

Users and Passwords

Administrative (User) Security Levels and
Guidelines
If you are running the Configuration Service application within a system using the
Solaris operating environment, administrator security levels are automatically created
during the installation process. You only need to set passwords and assign users
according to the desired permission level.

# /etc/rc2.d/S81ssagent stop

# ps -e | grep ss

# format
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Configuration Service administrative functions require access logins and passwords
to prevent the possibility of one administrator reallocating or removing storage
resources belonging to other clients and hosts without authorization.

You assign separate passwords for the three levels of security for the Configuration
Service program. You do this by setting up three users on the agents that have
storage devices that are managed by Configuration Service. These three users are
automatically added during the installation of the Configuration Service Agent.

The Configuration Service security levels must have these exact names:

■ ssmon

Represents the monitoring level of the software.

■ ssadmin

Represents the administration level of the software and provides access to the
Rebuild, Parity Check, and Schedule Parity Check functions, as well as
monitoring.

■ ssconfig

Represents the configuration level of the software and gives the installer direct
access to the configuration functions and all other related aspects of the program.

These names are required for the three security levels. After installation, you must
assign a password to each security name.

ssmon, ssadmin, and ssconfig are logins that correspond only to security levels
within Configuration Service. For UNIX operating environments (Solaris OE), the
default shell for these accounts is assigned to /bin/false. This results in
immediate logout whenever someone logs into one of these user names.

Configuration Service can be set up so that monitoring does not require users to type
the ssmon password. This is done by selecting the Auto Discovery option when the
servers are added to the Managed Servers list at the Configuration Service Console.
You can set up these three logins and passwords locally on each server. (The
accounts can have different passwords on each server, if desired.)

Once you have set up these three logins on the agents to be managed, the system
administrator typically provides user access to Configuration Service by assigning
employees appropriate passwords, which are based on the level of security required
to complete tasks. For example, everyone who has administration privileges on a
particular server is assigned the same password that was established for the user
ssadmin.

Note – To add servers to the Managed Servers List see “To Add Servers” on
page 30.
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▼ To Create Passwords and Permissions
Create a password for each of the new users by typing

Administrators might also want to change group permissions, which are defined in
the svrlist.dat file located in the /opt/SUNWsscs/sscsconsole directory
during installation.

The Configuration Service Console is a Java-based utility, and as such, cannot
provide facilities to control permissions or ownership of files that Configuration
Service creates. The svrlist.dat file is easily readable by various forms of ASCII
text processors. It contains the encrypted password for the user ssmon and can be
decrypted.

Note – Do not change the permissions and group ownership of svrlist.dat after
adding all agents that are being monitored.

Uninstalling Configuration Service
You must uninstall Configuration Service when upgrading the console or agent.
Note that some files are not removed because they are created after the installation
and are still valid for the upgrade environment.

# passwd user name
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▼ To Uninstall Configuration Service
Use the pkgrm command followed by the Configuration Service package you want
to uninstall, SUNWscsu (console) or SUNWscsd (agent).

If you are removing the software permanently, you might also want to manually
remove the following directories and files:

■ The directory /etc/.ssagent_ _ and its contents. (Note the period at the start
of the name ssagent.)

■ The installation directory (/opt/SUNWsscs/sscsconsole, by default) and any
files left in it.

■ The file /etc/rs_binding.

# pkgrm SUNWscsu

# pkgrm SUNWscsd
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CHAPTER 4

Installing Configuration Service on
Microsoft Windows NT/2000
Operating Systems

This chapter provides system requirements and installation procedures for
Configuration Service Consoles and Agents on Microsoft Windows NT/2000
operating systems. Topics covered in this chapter are as follows:

■ “System Requirements” on page 17
■ “Prior to Installing Configuration Service” on page 18
■ “Installing Software” on page 19
■ “Users and Passwords” on page 22
■ “Uninstalling Configuration Service” on page 24

System Requirements
■ Netscape 4.0 or later or Microsoft Internet Explorer 4.0 or later – To view online

help.

■ TCP/IP compliant network interface for Console – Each Configuration Service
Console must have a TCP/IP compliant network interface (such as an Ethernet or
Token Ring network card, or a serial line with a modem). For other console
requirements, see the following table.
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■ TCP/IP compliant network interface for Agent – Each Configuration Service
Agent must have a TCP/IP capable network card interface and driver set
(included with the operating system). For other agent requirements, see the
following table.

Prior to Installing Configuration Service
Note the following required procedures and additional options prior to installing
Configuration Service and its related software components.

■ Be sure to read the Sun StorEdge 3310 SCSI Array Release Notes.

■ If your operating environment contains an enterprise management console, you
can optionally configure Configuration Service Agents to send trapped events to
the console using the SNMP service. The SNMP service is included with the
operating environment and is installed after installing the TCP/IP protocol stack.

■ If you want the Configuration Service servers on your network to send SNMP
traps to the enterprise management console, see “Email and SNMP” on page 199.

■ Optional. To install and use Sun StorEdge Diagnostic Reporter, a companion
utility of Configuration Service that reports your storage system events to
specified email addresses, see “Installing and Using Diagnostic Reporter” on
page 163.

TABLE 4-1 Console System Requirements

OS Version Memory Disk Space

Microsoft Windows NT 4.0
(SP 3 or later)
Microsoft Windows 2000

32 MB minimum
64 MB recommended

20 MB free disk space minimum
40 MB recommended

TABLE 4-2 Agent System Requirements

OS Version Memory Disk Space

Microsoft Windows NT 4.0
(Service Pack 3, 4, 5 or 6)
Microsoft Windows 2000

32 MB minimum or 64 MB or more
recommended. Requirement is
determined by other large application
programs, such as databases.

2 MB free disk
space
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Note – You must be administrator to install Configuration Service and run the
Configuration Service Console.

Installing Software
Configuration Service software includes the following components:

■ Configuration Service Agent

■ Configuration Service Console

■ Diagnostic Reporter (optional utility – for installation and operation details, see
“Installing and Using Diagnostic Reporter” on page 163)

Install the agent on each server whose storage will be managed by Configuration
Service. Install the console on the computer or workstation you plan to use for
managing and maintaining the system storage.

Configuration Service Installation Packages
The Configuration Service installation packages are contained on the Sun StorEdge
Professional Storage Manager CD, and include the following files:

■ SUNWscsu.exe – Configuration Service Console

■ SUNWscsd.exe – Configuration Service Agent

■ SUNWscsa.exe – Diagnostic Reporter Agent and Diagnostic Reporter Config
Tool (UI)

■ SUNWsccli.exe – Configuration Service CLI

▼ To Install the Configuration Service Agent
You need to install the Configuration Agent on every Microsoft Windows NT/2000
server whose storage you want Configuration Service to manage. Complete the
following steps to install the Configuration Service Agent.

1. To make sure the software installation utility functions optimally, close all open
Windows applications.

2. Insert the Sun StorEdge Professional Storage Manager CD and go to the
\product\windows directory.
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3. Either double-click or copy SUNWscsd.exe to a local drive, and proceed through
the series of prompts and windows.

4. On the Welcome window, click Next.

5. On the Customer Information window, enter your user name and company name,
and click Next.

6. On the Choose Destination Location window, install the default folder, C:\
WINNT\system32, and click Next.

To install to a different folder, click Browse, select another folder, and click Next.

7. On the last window, click Finish to complete the installation.

The agents start automatically.

▼ To Install the Configuration Service Console
Complete the following steps to install the Configuration Service Console. Start by
running the Configuration Service installation program on the computer or
workstation where the Configuration Service Console will be installed.

Note – Make sure Java runtime environment 1.2 or higher is installed on the
computer or workstation on which you are installing the Configuration Service
Console.

1. To ensure that the utilities install properly, close all open Windows applications.

2. If you have not done so already, insert the Sun StorEdge Professional Storage
Manager CD and go to the \product\windows directory.

3. Either double-click or copy SUNWscsu.exe to a local drive and proceed through
the series of prompts and windows.

4. On the Welcome window, click Next.

5. On the Customer Information window, enter your user name and company name,
and click Next.

6. On the Choose Destination Location window, install the default folder, C:\
Program Files\Sun\sscs, and click Next.

To install to a different folder, click Browse, select another folder, and click Next.

7. On the last window, click Finish to complete the installation.
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▼ To Start or Stop the Configuration Service Agent

Microsoft Windows NT Servers
To start the Configuration Service Agent on the server, you must either reboot the
server or start the three Configuration Service services: SUNWscsd Startup,
SUNWscsd Server, and SUNWscsd Monitor under Settings → Control Panel →
Services.

To stop the Configuration Service Agents, go to Settings → Control Panel →
Services, select the agent you want to stop, and click Stop.

Microsoft Windows 2000 Servers
1. Select Start → Administrative Services → Computer Management.

2. Click Services & Applications.

3. Right-click the service (SUNWscsd Monitor, SUNWscsd Server, SUNWscsd
Startup) you want to start or stop.

Alternatively, you can use Start → Settings → Control Panel → Admin Tools →
Computer Management.
Chapter 4 Installing Configuration Service on Microsoft Windows NT/2000 Operating Systems 21



Users and Passwords

Administrator (User) Security Levels and
Guidelines
Configuration Service administrative functions require access logins and passwords
to prevent the possibility of one administrator reallocating or removing storage
resources belonging to other clients and hosts without authorization. You assign
separate passwords for the three levels of security for Configuration Service. You do
this by setting up three users on the agents that have storage devices that are
managed by Configuration Service.

The Configuration Service security levels must have these exact names:

■ ssmon

Represents the monitoring level of the software.

■ ssadmin

Represents the administration level of the software and provides access to the
Rebuild, Parity Check, and Schedule Parity Check functions, as well as
monitoring.

■ ssconfig

Represents the configuration level of the software and gives the installer direct
access to the configuration functions and all other related aspects of the program.

These names are required for the three security levels. After installation, you must
assign a password to each security name.

ssmon, ssadmin, and ssconfig are logins that correspond only to security levels
within Configuration Service.

Configuration Service can be set up so that monitoring does not require users to
enter the ssmon password. This is done by selecting the Auto Discovery option
when the servers are added to the Managed Servers list at the Configuration Service
Console. You can set up these three logins and passwords locally on each server.
(The accounts can have different passwords on each server.)

Once you have set up these three logins on the agents to be managed, the system
administrator will then typically provide user access to Configuration Service by
assigning employees appropriate passwords, which are based on the level of security
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required to complete tasks. For example, everyone who has administration
privileges on a particular server would be assigned the same password that was
established for the user ssadmin.

Note – To add servers to the Managed Servers list, see “To Add Servers” on page 30.

Global Passwords on Multiple Servers
If you have a large network and do not want to set up logins individually, and it is
acceptable to have the same passwords on multiple servers, you can establish the
three logins on a domain server under Microsoft Windows. As a result, all other
servers within the Microsoft Windows domain will have access to the three logins
along with their respective passwords.

▼ To Create Microsoft Windows NT Users
1. Add users with the NT User Manager program.

2. Select Policies and then User Rights.

3. Select Show Advanced User Rights.

4. Give the NT User Administrator the Rights to Act as a part of the operating
system.

5. Under User Properties, uncheck User Must Change Password at Next Login.

6. Under User Properties, select User Cannot Change Password and Password Never
Expires.

7. If you plan to set up the user names on a domain server so that multiple server
setups are not required, be sure that the servers you want to manage belong to the
domain where you have established the Configuration Service user account.

Refer to your Microsoft Windows NT documentation for more information.
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▼ To Create Microsoft Windows 2000 Users
1. Under Settings → Control Panel → Administrative Tools → Computer

Management → System Tools → Local Users and Groups, select Users.

2. Right-click the Users folder and select New User to add the three users (ssmon,
ssconfig, and ssadmin).

3. Add one of the users under User name. Enter a description if desired under
Description.

4. Enter a password and if desired, select User Cannot Change Password and
Password Never Expires.

Uninstalling Configuration Service
Use the Windows Add/Remove Programs utility to remove Configuration Service
from a Microsoft Windows Console.

▼ To Uninstall Configuration Service
1. Go to Start → Settings → Control Panel → Add/Remove Programs.

2. Select the Configuration Service Agent and select Add/Remove. Respond
appropriately to the prompts.

3. Select the Configuration Service Console and select Add/Remove. Respond
appropriately to the prompts.
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CHAPTER 5

Setting Up Configuration Service

This chapter describes typical procedures for setting up Configuration Service.
Procedures covered in this chapter are as follows:

■ “To Start Configuration Service” on page 25
■ “To Add Servers” on page 30
■ “To Log In and Out” on page 36
■ “To Select a Server to Manage a Controller” on page 37
■ “To Configure Agent Parameters (optional)” on page 40
■ “To Verify Storage Configurations” on page 42
■ “To Save the Logical Drive Configuration” on page 45
■ “To Create Partitions on a Server” on page 47

▼ To Start Configuration Service

Note – You must be a superuser/administrator to run the Configuration Service
Console.

Note – Because the Configuration Service Console does not receive event alerts
unless it is running, after configuring the Sun StorEdge array, always leave
Configuration Service running in its minimized mode on the Configuration Service
Console workstation.
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Solaris Operating Environment
1. At the command prompt, type

If it is already running, an error message is displayed.

2. To verify the Configuration Service Console process, type

Microsoft Windows NT/2000 Operating System
Select Start → Programs → Sun StorEdge 3000 Family → Configuration Service.

Main Window Before and After First Use
When Configuration Service initializes for the first time, the main Configuration
Service window is blank. The Add Server window is displayed, enabling you to add
servers to the Managed Servers list of the Configuration Service Console you are
using. For details on adding servers, see “To Add Servers” on page 30.

Whenever you start Configuration Service after the first time and after you have
selected Managed Servers, the main Configuration Service window displays server
icons for the servers on the Managed Servers list. Click OK or Cancel to continue.

After a new array is configured and the workstation is booted, the program might
not see the array until the logical drives are labeled because Configuration Service
uses native Sun drivers.

On systems running the Solaris operating environment, if the Configuration Service
Console locks up during use, you can obtain the process number, and then close and
reopen the window without affecting Configuration Service.

# ssconsole

# ps -el | grep java
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▼ To Obtain the Process Number
1. At the command prompt, type

2. To close the console without affecting the Configuration Service Agent, type

# being the process number.

3. Run the program again.

This window is displayed again without affecting the Configuration Service Agent.

The Menu, Toolbar, and Tabs
It is useful to review the Configuration Service main window, which includes a
menu bar, tabs, and a toolbar for access to key functions.

# ps-el | grep sscs

# kill -9 #
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Menu Bar
The following figure shows the main menu options.

Toolbar
Located below the menu bar, the toolbar provides icons that give you quick access to
commonly used functions. Select an icon to activate its function. Toolbar icons can
appear both as active or disabled (grayed), depending on what resources are
available in the main Configuration Service window.

Icon Description

Server List Setup. Adds servers that the Configuration Service
Console manages, edits server information, or designates that
an available server is managed.

Event Log. View events such as storage device status changes,
hardware status changes, or operational notifications.

Login
Logout

Server List Setup

Save Report

Exit

View Report

View Group
View Server
View HBA Card
View Controller
View Logical Drive
View Physical Drive
View Enclosure 
View FRU

Agent Options Management

Array Admin Progress

Event Log

Host Management *
StorEdge Property *

Save Configuration
Load Configuration

Standard Configure
Custom Configure

File View Configuration Array Administration

Controller Assignment
Controller Maintenance
Download FW for Devices
View Peripheral Device *

Rebuild

Parity Check
Schedule Parity Check

Contents

About sscsConsole

Help

*Reserved for future use.
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Tabs
Located below the toolbar, tabs allow you to quickly move to other Configuration
Service Views.

Navigating Configuration Service
Configuration Service follows standard Java programming language keyboard and
navigation operation

Save Report. Creates a text file containing Configuration
Service data about each of the storage components on the
selected server as of the current date.

Standard Configuration. Creates one or more logical drives
with one RAID level on the selected array controller.

Custom Configuration. Creates one or more new logical drives
with varying on RAID levels on the selected array controller.

Tab Description

Click to go to Resource Allocation View. (Reserved for future use.)

Click to go to LUN Filter View. (Reserved for future use.)

Click to go to the main Configuration Service window.

Icon Description
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▼ To Add Servers
Before you can monitor or configure a server, you need to add it to the Managed
Servers list through Server List Setup.

1. Start Configuration Service on the console if it is not already running.

2. Select File → Server List Setup.

The Server List Setup window is displayed.

3. Organize the servers into groups:

a. Click Groups in the Server List Setup window.

The Group List Setup window is displayed.

b. Type a name in the Group Name field and click Add.
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c. To delete a group, select the group name from the Available Groups list and
click Delete.

d. When you are finished adding and deleting groups, click OK.

The Server List Setup window is displayed.

4. Add a server:

a. Click Add under the Available Servers list.

The Add Server window is displayed.

b. For Solaris, type the name of the server in the Server name field and press
Return. For Microsoft Windows NT/2000, enter the name of the server in the
Server name field and press Enter.

This is the name you use to identify the server. If this name is in your network’s
name server database, Configuration Service determines the server’s IP address
and displays it in the IP Address field.

If Configuration Service cannot find an IP address for the name, the name was
either typed incorrectly or has not been recorded in the server’s name database.
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c. If necessary, type the server’s TCP/IP address in the IP Address field.

For example, 192.168.100.1.

If Configuration Service has not already displayed the IP address (as described in
the previous step), type the IP address manually.

Selecting Get IP Address by Name, located below the IP Address field, is another
method of having Configuration Service search for the IP address and display it
automatically. As mentioned in the previous step, it works only if your network
has a name server database and you have typed the server name as it is recorded
in the that database. Otherwise, you must type the IP address manually.

5. Select or Deselect Automatic Discovery of servers:

a. Select No for Auto Discovery if you need a very secure environment where
access even to server inventory data is restricted.

When you select No, Configuration Service does not retrieve server information
when starting up. The server’s icon appears color-coded white (instead of active
purple) to indicate it is undiscovered. When you double-click an undiscovered
server, Configuration Service prompts you for the ssmon user password.
Optionally, you can also select the server and select File → Login.

Select Yes for Auto Discovery to retrieve all information available about this
server when the Configuration Service Console is started.

b. If you select Yes for Auto Discovery, type the same monitor password that was
typed earlier when the ssmon user was set up on the server (or group of servers
if you have a domain or an NDS tree).

Once the server(s) have been established using Auto Discovery, you do not need
to type the ssmon password when you log into Configuration Service; you
automatically have monitoring privileges.

However, whenever you choose a command to perform administration or
configuration activities, you are prompted with a login dialog box to change your
level of security by typing the password for either the ssadmin or ssconfig
user that was established earlier.

c. Click OK.

6. Set email addresses:

a. If you want Configuration Service to send event messages using email, select
the Mailing Lists tab and continue with the following directions.

You might want to type your own email address and the addresses of selected
users for the purpose of receiving information about critical events on the server.
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Note – Instead of keeping the Configuration Service Console program running in
the foreground, you can use Diagnostic Reporter, a companion utility of Configuration
Service that runs as a background service that sends messages from the hosts and
Sun StorEdge array to specified email addresses. (For details, see “Installing and
Using Diagnostic Reporter” on page 163).

b. For each user, type an email address in the Mail Address field.

c. In the Severity list box, scroll through the list of severity levels and choose
from the following:

Critical – a message that requires intervention by the network administrator, such
as failure of a device, power supply, or fan.

Warning – messages that generally indicate internal program events. If you see a
large number of these messages, it might mean that there is a problem with the
server or the network.

Informational – messages about the devices on the server that do not require
intervention by the network administrator.

Whatever level you choose, you receive event messages for that level and any
other levels at a higher severity. If you choose Informational, for example, you are
notified of any form of malfunction. Conversely, if you want to be notified of only
critical situations, select Critical, and you are not notified of any Informational or
Warning events.
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d. Click Add to List.

To delete a user from the list, select the mail address and click Delete from List.

e. Indicate the mail server to be used.

Note that the Setup Mail Server button toggles with Change Mail Server,
depending on whether a mail server has been defined previously.

For new setups, click Setup Mail Server. A Mail Server Setup window similar to
the following is displayed.

f. Type the IP address or name of the Simple Mail Transfer Protocol (SMTP) mail
server that is delivering the email messages to the destination addresses
specified earlier.

g. Click OK when you are satisfied with the information about the Mail Server
window.

The Add Server window is displayed showing the Mailing Lists tab.

7. Complete the Add Server function:

a. If you want this server to be part of a group, select the Grouping tab.

The Add Server window is displayed.
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b. Select the list box to view the choices available.

c. Select the desired group and release the mouse button.

d. Click OK to register the change.

8. If you want to add more servers, repeat Steps 3 through 7 for each server.

9. Move the servers you want this console to control to the Managed Servers list (see
“To Add Servers” on page 30).

■ If you want this console to manage all the available servers, click Add All located
at the top of the dialog box.

■ To move individual servers to the managed column, select each server
individually and click Add located between the two list boxes.

■ If during the process of adding servers, modifications need to be made, see“To
Edit a Server Entry” on page 159.

10. When you are finished adding servers, click OK to return to the main window.

Note – If the Sun StorEdge array is attached to multiple hosts and a Configuration
Service Agent is installed on each host, each host’s IP address must be entered and
added to the Managed Servers list.
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▼ To Log In and Out
Configuration Service’s log in and log out functions provide security within the
program. The security levels are established by setting up three users: ssmon,
ssadmin, and ssconfig, each with a password.

■ ssmon represents the monitoring level of the software; it displays alerts from the
controller.

■ ssadmin represents the monitoring level of the software; it provides access to
Rebuild, Parity Check, and Schedule Parity Check functions, as well as
monitoring.

■ ssconfig represents the administration level; it provides access to the
configuration commands and all aspects of the program.

1. To log in, choose File → Login.

Maintain continuous access only as the monitoring user. When you select a
command that requires the administration or configuration level, a login dialog box
is displayed and you log into that level with the appropriate password. After
completing your activity, log out.

2. To log out, choose File → Logout.

When you log out from the administration or configuration level, you are given the
option of logging out to the monitoring mode or logging out from the server entirely.
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▼ To Select a Server to Manage a Controller
For managing and monitoring a Sun StorEdge array, the Configuration Service
Agent needs to have access to a host LUN mapped to a partition of a logical drive
assigned to the primary controller of the array.

The Configuration Service Agent ignores all host LUNs mapped to a partition of a
logical drive assigned to a secondary controller in a redundant configuration of an
array.

Note – See “RAID Basics” on page 179 for a discussion of logical drives and LUNs.

If the same Sun StorEdge array is connected to multiple servers, it is possible to have
the Configuration Service Agent running on each of these servers trying to manage
and monitor the same array. Due to a restriction on monitoring commands to be sent
to the Sun StorEdge controller by only one server at a time, some monitoring
commands might fail if sent simultaneously by multiple servers. This could cause
inaccurate reporting or the Configuration Service processes to stop responding. To
prevent this from happening, the Configuration Service Agent can be configured to
enable/disable array monitoring on a server using one of the methods described in
the following sections.

Assigning a Controller Through the Console
The following procedure can be performed from the Configuration Service Console
to assign server control to a controller.

1. Make sure all directly attached servers were added following the directions in “To
Add Servers” on page 30.

This ensures that both Host names are present under Controller Assignments.

1. From the main Configuration Service window, click Array Administration →
Controller Assignment.

The Assign Server to Manage a RAID Controller window is displayed.

2. Select a server from the Server to manage this controller list and click Apply.

This enables the selected server to manage an array controller. It also disables all
other servers listed from managing the same array.

3. Click Close to close the view.

The Configuration Service main window shows the Sun StorEdge array controller
device icon only under the server where the monitoring is enabled for this array.
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Note – If multiple HBAs have access to the same Sun StorEdge array, the
Configuration Service main view shows the array controller device icon only under
one of the HBAs.
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Assigning a Controller Through a Config File
The following procedure describes an alternative technique for enabling/disabling
the server control of a controller by using a configuration file.

1. Select a server that has non-excluded access to a host LUN mapped to a partition
of a logical drive assigned to the primary controller of the Sun StorEdge array.

2. Write down and save the serial numbers of the primary and secondary controllers
of the array.

You can retrieve the serial numbers of the controllers by using a VT-100 compatible
terminal connected to the Sun StorEdge array serial interface. Refer to the Sun
StorEdge 3310 SCSI Array Installation, Operation, and Service Manual for connection
details.

3. By default, array controller monitoring is disabled in the Configuration Service
Agent. Stop the Configuration Service Agent services or daemons.

(Refer to instructions on starting and stopping the Configuration Service Agent in
the appropriate platform chapter.)

4. By using a utility like Windows Notepad or other text editor (not word processor),
create a sscontlr.txt (ASCII text file) and edit the file on a server in which you
want to have array monitoring.

a. Add the following line to this text file:

where primary_serial and secondary_serial are the actual serial numbers of the
controllers you accessed earlier.

You can add any non-program comment line by starting each comment line with
the # (number symbol). Note that the first command word is RAID_CONTROLLER
and must be located in the first line of the file.

b. Save all changes to the text file.

5. When completed, copy sscontlr.txt into the /etc/.ssagent_ _ directory.

Note the period before the start of the ssagent_ _ directory name.

For Microsoft Windows NT/2000, copy the file into the SYSTEM32 directory.

6. Restart the agent and the console.

RAID_CONTROLLER=Enable:primary_serial:secondary_serial
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▼ To Configure Agent Parameters (optional)
This section provides steps to configure agent parameters, including polling time,
periodic device discovery time, smart monitoring, and out-of-band storage
management using the View → Agent Options Management command.

1. From the main window, select View → Agent Options Management.

The Agent Options Management window is displayed.

Note – Agent Options Management might not be available if one or more groups
are configured and one of them is selected in the main window. To enable it, select
an icon other than a group, and click View.

2. For Monitoring Frequency in Seconds, type the desired number in seconds.

This value is the interval between successive polling for any status change of
devices, array controllers, and enclosure monitoring by the Configuration Service
Agent. The default value is 60 seconds. If you want the Configuration Service
Console to update more frequently with device status changes, decrease this value.
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3. For Periodic Device Discovery, type the value in minutes you want Configuration
Service to check for new devices.

The periodic device discovery value is used by Configuration Service to determine
how often each device ID is scanned for a new device. The default value of 0 means
Configuration Service does not scan for new devices. Note that device IDs are
scanned less frequently as the numerical value increases.

Conversely, device IDs are scanned more frequently as the numerical value
decreases. Five minutes is the minimum value.

4. For Interval of trap generation, type the amount of time (in seconds) between the
sending of each trap message.

If the value is 60 seconds or greater, Configuration Service sends a message at that
interval, for that particular trap, until the event is cleared or corrected. For example,
if a fan fails, a message regarding that fan failure is sent every 60 seconds until fixed.

If the value is 0, Configuration Service (and therefore Diagnostic Reporter) sends
only one message regarding that particular event. For example, if a fan fails, only
one email is sent.

5. For Timeout of heartbeat lost, set the amount of time in minutes to wait between
the sending of failed server messages.

The default value is 15 minutes; the value range is 1 to 30 minutes.

6. To Enable SMART Monitoring, select the check box.

SMART monitoring is a method for hard drives to report predicted failures. Most
disk vendors supply drives with this feature. The Configuration Service Agent
monitors this feature by issuing an unsolicited request sense. SMART monitoring
can be turned off if this request causes conflicts with the underlying host operating
environment/system device drivers.

7. To Enable JBOD support, select the check box.

Use Just a Bunch of Disks (JBOD) support only when you have a JBOD connected
directly to the workstation. This enables you to monitor peripheral device condition
and events. If you have a JBOD connected to the RAID array, the RAID controllers
monitor the JBOD condition and events for you. For details on monitoring a JBOD,
see “Monitoring JBODs” on page 185.

8. If you have selected any of the previous options, click OK to save your changes.
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The Setting Agent Options notification message box is displayed showing the
server’s TCP/IP address.

9. Click OK to finish the procedure.

For details on Controller Primary Agent Information, see “Out-of-Band Storage
Management” on page 104.

▼ To Verify Storage Configurations
Once you have installed Configuration Service and added all the servers for storage
that you want Configuration Service to manage, you need to verify the storage
configurations.

Note – Most Sun StorEdge arrays are shipped preconfigured. If you want to
completely remove the existing configuration and start over, see “Full
Configuration” on page 51. If you want to change the current configuration or add to
it, see “Updating the Configuration” on page 127.

1. Make sure the server icon is online (that is, the server symbol is purple).

During power up, Configuration Service starts automatically.

2. Observe the main Configuration Service window and check the storage
configuration.

3. If you have multiple managed servers, select the server you want to check.

If the server icon is not purple, determine the server’s state (see TABLE 7-1). If the
server’s icon has a satellite dish attached to it , the server might be in the
discovery process and is available after a short delay.
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4. Click the container symbol that appears to the left of the server whose storage
you want to check.

Configuration Service graphically displays each host adapter or array controller
connected to the server as shown in the following figure.

5. To see other details, click the container symbol next to the host adapter or array
controller whose storage you want to check.

If the Sun StorEdge array has not yet been configured, no logical drives (LUNs for
controllers) are displayed.

If your Sun StorEdge array has been fully configured, Configuration Service displays
the devices and logical drives that are associated with the selected array controller. It
looks similar to the devices displayed in the following figure.
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Selecting the container symbol to the left of any logical drive displays its
assigned physical drives.

Your configuration might differ dramatically from that shown in the previous figure
depending on the storage array products you have installed.

If the Sun StorEdge array is not configured, see “Full Configuration” on page 51 for
instructions on configuring it.

Once you complete configuring the Sun StorEdge array, it is ready for use.

6. If logical drives have been configured, click the container symbol that
appears next to each logical drive.
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The physical devices that are part of each logical drive appear similar to the
following figure.

7. Check the RAID level and logical drive structure.

8. If the arrays are already configured and the configuration meets your needs,
continue with the next section.

If you would like to change the configuration, see “Full Configuration” on page 51.

▼ To Save the Logical Drive Configuration
Even though logical drive configuration information is stored on array controllers
and on the physical drives attached to them, extreme circumstances such as a fire
can occur, causing damage to both the controller and the drives. Subsequently, keep
multiple backup copies of your current logical drive (or LUN) configuration on
diskette or on some other form of external media other than the Sun StorEdge array.
Keep at least one backup copy in a vault or secured location off site.

A backup copy of the configuration enables you to restore the configuration to a new
controller without having to completely reconfigure the array. If you do not have a
backup copy of the current configuration, data could be lost.
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Always save your array controller configuration to a file whenever you:

■ Install a new storage system enclosure or change the SCSI ID for the controller in
an existing enclosure

■ Replace an array controller

■ Reconfigure or add logical drives to an array controller

■ Rebuild the data from a failed drive to a standby drive

To restore a configuration from a file, see “To Restore a Logical Drive Configuration”
on page 121.

1. Select the controller with the configuration you want to save.

2. Select Configuration → Save Configuration.

The Save Configuration window is displayed.

3. Navigate to the required drive and folder to locate the configuration file(s) to be
updated, which is indicated by a .cfg extension.

Save the file(s) to a diskette or a drive external to the Sun StorEdge array. That is,
maintain copies of these configuration files off site.

4. Specify the configuration file name and click Save.
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The Save Configuration window is displayed.

5. Type a description of the configuration you are saving and click OK.

Configuration Service saves the controller confirmation information to a .cfg file.

▼ To Create Partitions on a Server
When you are satisfied with your storage configuration, you can partition the
storage array for the operating environment.
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Creating Partitions and File Systems on a Solaris
Operating Environment
The following steps are general guidelines. For detailed information, read about
creating partitions and file systems in your Sun Solaris OE manual.

1. Label a new LUN by typing

The format command displays the system disk as well as other drives attached to
the Sun StorEdge array.

A new LUN must be labeled with the format command before it can be set up for
use by the Sun StorEdge array. When the format command is initiated, the LUNs
and hard disks that are available for use are displayed.

2. Select the LUN to be used.

Label the LUN if prompted.

3. Create file systems on the partitions using the newfs command.

4. Mount the file systems by using the mount command or by editing /etc/vfstab
and using the mountall command.

# format
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Creating Microsoft Windows NT/2000 Partitions
Before starting this section, you need to restart the computer so that Microsoft
Windows NT recognizes the new storage capacity. The steps listed below are general
guidelines; for detailed information, refer to your Microsoft Windows NT
documentation.

Note – This step cannot be done remotely. It must be performed at the server.

1. Select Start → Programs → Administrative Tools → Disk Administrator.

2. Choose Yes in each of the Disk Administrator message boxes.

3. Select the logical drive by moving the cursor to the horizontal bar, and clicking
the left mouse button.

4. Select Disk Administrator Partition → Create.

A prompt window is displayed, inquiring whether you want to create a partition
that has a default capacity of the entire logical drive.

5. If you want to create multiple partitions on a logical drive, enter the desired
partition size.

Repeat this step until all the logical drive capacities are used.

6. Select Disk Administrator Partition → Commit Changes Now.

This function enables you to format and use the logical drive without restarting the
Windows NT operating system.

7. Select the newly created logical drive partition.

8. Select Disk Administrator Tools → Format. Select FAT (File Allocation) or NTFS
(NT File System) format.

Repeat Steps 7 and 8 to format each partition you created on the logical drive.

9. When formatting is complete, close the Disk Administrator.
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What to Do Next
Configuration Service (console and agent) is now installed, set up, and ready to use.

See the following chapters for additional tasks:

■ “Monitoring the Sun StorEdge Array” on page 71, for information about how to
use Configuration Service to monitor storage devices.

■ “Maintaining the Sun StorEdge Array” on page 113, for information about
maintaining the Sun StorEdge array. It includes detailed information about parity
checking, scheduling parity checks, rebuilding failed drives, and restoring a
configuration from a backup file.

■ “Updating the Configuration” on page 127, when you want to update the
configuration of the storage array. It also covers changing controller features,
making or changing a standby drive, and editing the information for available
servers.
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CHAPTER 6

Full Configuration

Sun preconfigures logical drives on the Sun StorEdge array before shipment. Read
this chapter only if the Sun StorEdge array is not already configured, or if you want
to completely remove the existing configuration and start over. If you want to change
portions of the existing configuration, see “Updating the Configuration” on
page 127.

Configuring new physical storage devices includes the following topics:

■ “Logical Drive and Partitioning Requirements” on page 52
■ “Configuring Logical Drives” on page 52
■ “Host LUN Assignments” on page 66
■ “Logical Drive Configuration File” on page 68

If you are planning to set up a cluster configuration, see “Using the Cluster
Configuration” on page 193.

The Configuration menu commands and tool icons might be temporarily disabled if
an array administration process, such as parity checking, is running. The menu
command is also deactivated when the Configuration Service Console is refreshing
its inventory on the server. A satellite dish symbol is attached to the server icon
during the refresh process.

Caution – Back up any existing data to an external device before configuring the
Sun StorEdge array. Reconfiguration overwrites any existing logical drive
configuration. When the existing logical drive configuration is overwritten, all data
is effectively erased.
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Logical Drive and Partitioning
Requirements
■ For Configuration Service to view and manage a Sun StorEdge array, each HBA

card must be connected to the primary controller.

■ Partitioning can be done during the initial configuration or after the logical drive
has been created.

Configuring Logical Drives
You can configure logical drives using standard configuration or custom
configuration.

▼ To Use Standard Configuration to Configure
Logical Drives
Use Standard Configuration Options to quickly configure all of the storage attached
to an array controller using one RAID level. All you need to supply is the RAID
controller and the RAID level. You also need to specify whether you want a standby
drive. Configuration Service then automatically configures the storage for you,
creating one or more logical drives, depending on the RAID level and the number of
drives available. The write-back cache is selected by default.

You are able to see the resulting configuration and accept or reject it before it is
completed.

Caution – Back up any existing data to an external device before using Standard
Configuration. Standard Configuration overwrites any existing logical drive
configuration. When the existing logical drive configuration is overwritten, all data
is effectively erased.

1. Log in as a user with the privileges of an ssconfig user (required to configure or
reconfigure storage devices).

2. Select the RAID controller in the main Configuration Service window.
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3. Select Configuration → Standard Configure. The Standard Configuration Options
window is displayed.

If you are not currently logged in as ssconfig, a login dialog is displayed.

The options on the window might be disabled, depending on the number of drives
available and whether you have a Microsoft Windows NT operating system or
Solaris operating environment on the server.

The NT Cluster option creates a quorum RAID 5 logical drive (100 Mbytes) and then
allocates the remaining capacity over two large RAID 5 logical drives. For this
option, three or more physical drives are required.

4. Verify the server and the controller IDs displayed at the top of the window.

If the server and the controller displayed at the top of the window are not correct for
the new logical array, click Cancel to exit the configuration window and return to the
tree view. Select the appropriate device and select the window again.

5. Indicate whether you want to use one of the drives as a standby drive.

When you select Use a standby drive, Configuration Service deactivates the RAID
levels that do not use standby drives. (For example, RAID 0 has no fault tolerance;
therefore, a standby drive provides no benefit.)
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6. From the RAID levels made available, select the appropriate RAID level for the
logical drive you are configuring.

For definitions of the RAID levels, see “Glossary” on page 253.

If you select RAID 0, 3, or 5, Standard Configuration normally configures one large
logical drive. However, if the Sun StorEdge array has more than fourteen physical
drives, more than one logical drive is created. Also, you need a minimum of three
drives to use RAID 3 or 5.

If you select RAID 1, every logical drive requires two physical drives.

After you select a RAID level, the Confirm Configuration Operation window is
displayed showing the new configuration.

7. Click OK to accept the configuration as indicated; otherwise, click Cancel to
return to the Configuration Service Console.

▼ To Use Custom Configuration to Configure
Logical Drives
Custom Configuration gives you multiple choices for configuring or reconfiguring
logical drives with varying RAID levels and other RAID parameters.

1. To make changes to the configuration, you need to be logged in as an ssconfig
level user.
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2. Select Configuration → Custom Configure.

The Custom Configuration Options window is displayed.

■ New Configuration – Configures new logical drives with varying RAID levels
and other RAID parameters. The New Configuration command erases the
previous configuration on an array controller.

■ Add a New Logical Drive to the Current Configuration – Adds a new logical
drive to an existing configuration. This command does not erase the other
configured logical drives on the controller.

■ Dynamically Grow and/or Reconfigure a Logical Drive – Enables you to expand
the capacity of a logical drive, add SCSI drives to an existing logical drive, and
copy and replace all member drives with drives of higher capacity.

■ Make or Change Standby Drives – Adds one or more new standby drives to be
associated with the array controller.

■ Change Host LUN Assignments – Enables you to assign an existing logical drive
to a host channel.

■ Change Controller Parameters – Enables you to modify the parameters for arrays
using the Sun StorEdge array controller.

■ Manage Existing Logical Drives or Partitions – Enables you to delete individual
logical drives and create/delete partitions from existing logical drives.
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In this chapter, the New Configuration option is described in detail. The remaining
options are described in “Updating the Configuration” on page 127.

▼ To Use the New Configuration Option
The New Configuration option enables you to customize the logical drive
configuration to meet the specific needs of your environment. You can configure one
or more logical drives with varying RAID levels and partitioning.

On systems running the Solaris operating environment, if the Configuration Service
Console locks up during use, you can obtain the process number, and then close and
reopen the window without affecting Configuration Service.

1. Obtain the process number of the Configuration Service Console, by typing

2. To close the console without affecting the Configuration Service Agent, type

# being the process number.

3. Run the program again.

The window is displayed again without affecting the Configuration Service Agent.

# ps-el | grep sscs

# kill -9 #
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New Configuration Overview
Because the New Configuration operation involves making selections from one
window with multiple options, it is useful to present an overview of the steps
involved.

1. Determine the background rate, which is the percentage of available array
controller CPU time assigned to array administration activities, such as rebuilding
drives, checking parity, and initialization.

If the background rate is set to 100%, the array administration activities have a
higher priority than any other system activity. At 0%, the array administration
activity is done only if there is no other activity on the array controller.

2. Select the disks (physical drives) to be included in the logical drive.

3. Indicate whether a standby drive is used.

A standby drive is a drive that is marked as a spare to support automatic data
rebuilding after a physical drive associated with a logical drive fails. For a standby
drive to take the place of another drive, it must be at least equal in size to the failed
drive and all of the logical drives dependent on the failed disk must be redundant
(RAID 1, 3, 5, and 1+0).

4. Select a RAID level; Configuration Service automatically computes the maximum
size logical drive that can be created at that RAID level.

5. The Maximum Drive Size displays the maximum drive size per selected physical
drive.

A smaller logical drive can be created by decreasing this value. The remainder can
be used later by expanding the drive (as explained in “To Expand the Capacity of a
Logical Drive” on page 134).

Note – The maximum usable capacity for a logical drive is equal to the smallest
physical disk size. For example, if you add an 18-Gbyte disk and then add a 70-
Gbyte disk to be part of the logical drive, the maximum usable capacity is 18 Gbytes
per drive.
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Max Drive Size (MB) displays the total capacity of each disk.

Part Size (MB) displays the total capacity of all disks, which is the total logical drive
size.
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6. If you do not have remaining capacity, click Commit and then initialize the logical
drive.

In Microsoft Windows NT, you need to reboot for it to recognize the new storage.

7. To clear the present configuration without having to exit the menu, click Clear.

8. If you have additional disks, and you want to create additional logical drives,
click New Logical Drive.

9. (Solaris OE only) If you want the new logical drive to be automatically added to
the operating environment without rebooting, click Write a new label to the new
LD.
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▼ To Create Partitions
A partition is a logical division of the logical drive. Partitions enable you to create the
appearance of having separate logical drives for file management, multiple users, or
other purposes.

Configuration Service enables you to easily create partitions from a logical drive. For
example, to create a 5000-Mbyte partition, type 5000 in the Part Size field in the New
Configuration window, and click Add Partition. Any remaining capacity is
automatically moved to the next partition.

Example of Creating a New Configuration for a New Logical
Drive and Partitioning

In the following example, three physical drives are selected and configured into a
RAID 5 logical drive. A small logical drive is created and partitioned.

Caution – Back up any existing data to an external device before using the New
Configuration command. Configuration Service automatically initializes new logical
drives defined on the Sun StorEdge array controller.

1. Log in as ssconfig. From the main window, select the desired disk controller.

2. Select Configuration → Custom Configure.

3. Click New Configuration.

The New Configuration Warning message box is displayed.

4. Click OK.
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5. Verify the Server and Controller displayed at the top of the window.

If the server and the controller displayed are not correct for the new logical array,
click Cancel to exit the New Configuration window and return to the tree view.
Select the appropriate disk controller and reselect New Configuration.

6. Set the Background Rate for the controller, if desired.

7. In the Select disks for Logical Drive list box, select the first disk and click Add
Disk.

Proceed to add the next two disks in the upper list box so that three disks appear in
the lower list box.

If you make a mistake or change your mind, select the drive in the participating
drives list and click Remove Disk.

The new logical drive is composed of three physical disks, totaling 209100 Mbytes,
as indicated in the Part Size field.

8. Select RAID Level 5.

This applies to all disks in this logical drive.
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9. Select the Host channel and SCSI ID to which you would like the new logical
drive to be mapped to from the Host Channel and Host SCSI ID list boxes.

Note – If you assign a logical drive to a secondary controller Host Channel and Host
SCSI ID (SID), you must reset the controller.

Note – You can create up to eight logical drives and up to 32 partitions per logical
drive on a Sun StorEdge array controller. Note that there is a maximum of 128 LUN
assignments.

To keep this logical drive as a single large logical drive, click New Logical Drive or
Commit. In this example, however, a small logical drive is created and partitioned.

10. To create a small logical drive, type 2000 in the Max Drive Size field.

Note – A total of 4000 Mbytes is shown for the logical drive size as opposed to 6000
Mbytes; because this is a RAID 5 level, you lose the capacity equal to 1 drive (2000
Mbytes) for parity.
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11. To create a partition, type 1000 in the Part Size field and click Add Partition.

Any remaining capacity moves to the next partition as shown in the logical drive
display field in the upper part of the window. Note that the remaining capacity is
also displayed in the Part Size field.
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As shown in the following example, of the original 4000 Mbytes, 2000 Mbytes was
allocated to Partition 0. The remaining 3000 Mbytes is then automatically moved to
Partition 1. The remaining usable capacity is displayed in the Part Size field.

12. (Solaris OE only) If you want the new logical drive to be automatically added to
the operating environment without rebooting, click Write a new label to the new
LD.

13. Click Commit or New Logical Drive to end the configuration of the logical drive.

When you click New Logical Drive, any available disks that haven’t been used are
displayed.
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When the logical drive configuration for this Sun StorEdge array is complete, click
Commit, and then click OK. The completed configuration is displayed.

Note – You cannot change a logical drive configuration after you click OK.

▼ To Clear a Configuration
If at any time during the configuration process in the New Configuration window
you are dissatisfied with the configuration, you can clear it.

1. Click Clear to remove all physical and logical drives from the display.

2. Either click New Logical Drive to define a new logical drive, or click Commit.

3. When you click Commit, a warning prompt is displayed; click OK.

Configuration Service initializes the entire configuration on the selected array
controller.

Note – Host LUNs are automatically mapped after logical drives have completed
the initialization process.
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▼ To Log Out of the Configuration Level
When you are finished with configuration activities, log back into the monitoring
level of the program.

1. Select File → Logout.

2. Select Logout to monitoring mode and click OK.

Host LUN Assignments
For the server to recognize a logical drive, it must first be mapped to a host
channel/ID. When a logical drive is mapped to a host channel/ID, it becomes a
LUN. The following section describes how to map a logical drive to a Host channel
or remove it.

Note – When logical drives are first created, host LUNs are automatically mapped
after logical drives have completed the initialization process.

▼ To Add (Map) a Host LUN
1. Select Configuration → Custom Configure.

2. From the Custom Configuration Options menu, select Change Host LUN
Assignments.
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The Change Host LUNs Assignments window is displayed.

3. Using the Select Host Channel and SCSI ID list box, select the channel and ID to
which the LUN is to be assigned.

All available LUNs are displayed in the Logical Drive Partitions field.

Note – If you assign a logical drive to a secondary controller Host Channel and Host
SCSI ID (SID), you must reset the controller.

4. Select the desired LUN from the Logical Drive Partitions field, and click Assign
Host LUN to accept the change.

As a result, Delete Host LUN becomes active.

5. When finished, click OK to save your changes and to return to the main menu.

Note – In the event that an error message is displayed when mapping a host
channel, repeat Steps 1 through 5.
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▼ To Delete (Unmap) a Host LUN
1. With the Change Host LUN Assignments window displayed, select the LUN to be

deleted from the Host LUN Assignments field.

2. Click Delete Host LUN.

3. When finished, click OK to save your changes and to return to the main menu.

Logical Drive Configuration File
Keep a backup copy of the current logical drive configuration on diskette or on an
external device other than the Sun StorEdge array. Even though configuration
information is stored on array controllers and on the physical drives attached to
them, circumstances such as a fire or a flood can occur, causing damage to both the
controller and the drives. A backup copy of the configuration enables you to restore
the configuration to a new controller without having to completely reconfigure the
storage array.

Always save the array controller configuration to a file whenever you:

■ Install a new storage system enclosure or change the SCSI ID for the controller in
an existing enclosure

■ Replace an array controller

■ Reconfigure or add logical drives to a array controller

■ Rebuild the data from a failed drive to a standby drive
68 Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



▼ To Save a Configuration to a Backup File
1. Select the controller with the configuration you want to save.

2. Select Configuration → Save Configuration.

The Save Configuration window is displayed.

3. If necessary, navigate to the drive and folder where you want the configuration
file to be saved.

Save the file to a diskette or a drive external to the Sun StorEdge array.

4. Specify the configuration file name and click Save.
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The Save Configuration window is displayed.

5. Type a description of the configuration you are saving.

6. Click OK.

Configuration Service saves the controller configuration information to a .cfg file.

Loading the Configuration
If a drive or controller is damaged and needs to be replaced, see “To Restore a
Logical Drive Configuration” on page 121, which describes how to load a
configuration file and restore a logical drive configuration.

Integrating the Sun StorEdge Array
When you are satisfied with the storage configuration, you need to partition the
array. Refer to “To Create Partitions on a Server” on page 47 for specific procedures.
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CHAPTER 7

Monitoring the Sun StorEdge Array

This chapter explains how to monitor the Sun StorEdge array with Configuration
Service. It describes the main Configuration Service window and the component
view windows that are available when an icon is double-clicked in the main
window. It also explains how the Event Log works and how to use Configuration
Service’s reporting function. It is organized into the following sections:

■ “The Main Configuration Service Window” on page 71
■ “Viewing Detailed Device Information” on page 78
■ “Event Log” on page 94
■ “Save Report” on page 98
■ “View Report” on page 104
■ “Out-of-Band Storage Management” on page 104
■ “Managing Storage Through the Web” on page 109

The Main Configuration Service
Window
The main Configuration Service window provides status at a glance for all Sun
StorEdge array devices. It indicates the status of the devices and logical drives
connected to servers monitored by the Configuration Service Console. The devices
include host adapters, array controllers, disk storage enclosures, physical disk
drives, and other SCSI devices.

This window’s tree structure offers detail for all devices connected to each server.
The or container symbol at the left side of the tree indicates whether the
display of devices is expanded or collapsed. The container symbol means that
you can click to display more devices. The container symbol indicates that all
devices at and below that level are shown.
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The following figure shows an example of the expanded view of the main
Configuration Service window.

Note – Dual port HBAs are displayed as separate icons because they have separate
channels to which devices can be connected.

Note – The SN# represents the unique ID of the Sun StorEdge array.
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The following figure shows an example of a collapsed view.

For more information, you can double-click an icon to open a component view
window. The component views are covered later in this chapter.

Another feature of the Configuration Service main window is that device states are
color-coded and symbol-coded so that it is easy to identify when a device is in a
state that requires attention. The status is propagated along the device tree, enabling
you to trace a failure down to the device level. See TABLE 7-1 for device status details.

TABLE 7-1 Device Status State

Color Symbol State

Purple None The group, server, or device is online.

White None The user has not logged into this server.

Yellow One or more components of this group or server are not
working properly, but the array is still functional. For
example, a logical drive that has one failed physical
drive is operating in a degraded state.

Red One or more components of this group or server are not
working. A logical drive with two failed disk drives or
an enclosure with three failed fans would be in a critical
state.

Gray The group, server, or device is unresponsive.
?
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Online Help
To access online help, select Help → Contents. The online help is in HTML format
and can be run through Internet Explorer or Netscape. It includes information about
major functions within the program.

Tree View of Product Configurations
For each server (or group of servers), devices in the tree view are arranged in a
hierarchical order with the server (or group) at the top, followed by the host adapter
and array controllers. How the remaining devices — logical drives, physical drives,
and enclosures — are shown might vary slightly, depending on which Sun StorEdge
array device and controller are being displayed. This section provides window views
that might be depicted in the tree view.

Groups

A group is a logical collection of servers within the device tree. This new data object
enables multiple servers to be contained under a single category.

The group object looks and behaves like all tree objects. It has an iconic
representation and generally assumes the status of its servers. The following figure
shows the group icon expanded to show the subordinate or underlying server
objects.
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A group is a new data object that enables multiple servers to be contained under a
single category. Groups are similar in concept to domains. They enable you to
organize servers better within Configuration Service. Instead of a linear tree of all
the managed servers, the Configuration Service operator can organize the servers
into like sets or groups.

Groups are color- and symbol-coded similarly to servers. For that scheme, states
with their corresponding colors have the following order of precedence:

■ Critical – red (the highest)
■ Nonresponding – gray
■ Degraded – yellow
■ Optimal – purple
■ Not logged into – white

A server icon assumes the color of the highest state of any of its storage system.
Likewise, a group icon takes on the highest state of any of its servers, with the
following exceptions involving non responding or unlogged servers.

When a group icon is disabled (inactive), it indicates that all the servers attached to
that group are not responding; if any number less than all of the servers in the group
is not responding, the group icon appears red, representing a critical state. For
example, if there are four servers in the group and three or fewer servers are not
responding, the group icon is color-coded red.

When a group icon is color-coded white (not logged into Configuration Service), it
indicates that one or more servers within that group have not yet been fully
configured, or could represent a period of status transition. TABLE 7-2 gives an
example of the different color coding of a two-server group.

TABLE 7-2 Two-Server Group Colors

Server 1
Icon Color

Server 2
Icon Color Group Icon Color

Gray
Gray

Gray
Yellow, Red, Purple, or White

Gray (not responding)
Red (critical)

White White White (not logged into)

White Yellow Yellow (degraded)

White Red Red (critical)

White
Red

Purple
Any Color

Purple (optimal)
Red (critical)

Yellow
Purple

Yellow or Purple
Purple

Yellow (degraded)
Purple (optimal)
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Groups are not required. You can configure Configuration Service for no groups and
fifteen servers, for example, or for one group with ten servers underneath, with an
additional five at the top level. Configuration Service enables any combination.

The number of groups permitted and the number of servers within a group is
limited only by available system memory. If a server is a member of a group and a
user deletes that group from the group list box, Configuration Service reassigns the
servers in that group to the no group category. Configuration Service automatically
remaps the tree in the main window.

Configuration Service Monitoring Process
The Configuration Service Console monitors storage devices on a network by
communicating with a Configuration Service Agent on the servers.

When Configuration Service is started, the console software begins by establishing
contact with the Configuration Service Agent on each managed server if Auto
Discovery was specified when the server was configured. If Auto Discovery was not
specified, you have to double-click each server and provide a password to start the
discovery process for that server.

Establishing a TCP/IP connection between the console and the Configuration
Service Agent on each server and receiving back inventory information can take
several minutes, depending on the complexity of the network. When this is
occurring, the server icon in the main Configuration Service window displays a
satellite dish icon on its right side. Once the inventory is refreshed, the satellite dish
symbol is replaced by an active server symbol.

The agent on each server does a periodic scan of its inventory to check for changes.
If there is a change, the agent sends an event to the console. Depending on the event,
the console might request the inventory from that server’s last scan to use for
updating the representation of the server as displayed on the main Configuration
Service window. During this process, the satellite dish icon is attached to the server
icon, and you cannot do any configuration and array activity commands on that
server until the refresh process is completed and the console main window is
updated.

When Configuration Service is running and the server agent and console are
connected, the agent pings or transmits a periodic signal to the console to verify the
server’s status. If the console does not receive a certain number of consecutive
responses (handshakes) from the agent, the console marks the server as offline and
disconnects from the server. The server’s icon is made inactive and adjacently
marked with a question mark symbol.

If a non-active server was originally made active through the Auto Discovery
function, the console periodically tries to re-establish server communications.
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Occasionally, you might want to have an inventory performed on a server between
the periodic status scans. To do this, double-click the server’s icon to display the
Server View window, and then click Rescan in that window.

Auto Discovery Options
If you have selected the Auto Discovery option (during the process of adding
servers to the Managed Servers list, see “Select or Deselect Automatic Discovery of
servers:” on page 32), Configuration Service automatically scans and performs an
inventory on these servers. You are not required to provide a monitoring password
to retrieve information provided by Configuration Service. Depending on the
complexity of the network and the number of servers, it can take several minutes for
the discovery process to finish.

However, if you choose not to use the Auto Discovery option on startup, the servers’
icons are white, indicating that there is currently no information available for these
servers. In this case, you need to double-click each server icon and specify the
appropriate monitoring password.

You can also select File → Login. Once the password is specified for a server,
Configuration Service begins the discovery process to perform an inventory on the
selected server.

Note – If you need a very secure environment where access to server inventory data
is restricted, select No for Auto Discovery (see “Select or Deselect Automatic
Discovery of servers:” on page 32).
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Viewing Detailed Device Information
Configuration Service provides detailed information about each Configuration
Service Agent or server and about the Sun StorEdge array devices that are connected
to it.

The fields on each of these views vary, depending on the capabilities of the disk
controller.

The commands and windows described in this section are accessed through the
View menu.

■ View Group
■ View Server
■ View HBA Card
■ View Controller Configuration
■ View Logical Drive
■ View Physical Drive
■ View Enclosure
■ View FRU
■ Array Administration Progress
■ Agent Options Management
■ Event Log
■ Save Report/View Report
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View Group
View Group displays the servers that comprise the group that is selected in the main
Configuration Service window.

To access View Group, double-click the group icon in the main Configuration
Service window or select the group icon and select View → View Group.

The Server List displays all servers that are attached to the specified group.

To view more information about any of the servers listed, select the appropriate
status record in the list and click View, or double-click the status record. A window
describing the corresponding server is displayed.
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View Server
View Server displays the characteristics of the server that is selected in the main
Configuration Service window.

To access View Server, double-click the server icon in the main Configuration
Service window or select the server icon and select View → View Server.

Note – Dual port HBAs are displayed as separate entries because they have separate
channels to which devices can be connected.

Part of the TCP/IP network, the socket port makes a connection between the server
and the client.

■ Rescan – sends a command to the selected server to rescan existing inventory and
refresh the console. Normally, each managed server performs a periodic scan of
its inventory and updates the console if there is a change. If you want to perform
a diagnostic of all assigned devices, click Rescan; selecting this button essentially
circumvents the periodic and automatic status updates.
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■ Probe – sends a command to the selected server to probe for new inventory (for
example, RAID controllers, JBODs, and expansion units). Whenever a new device
has been added, or a device name has changed and you want it to be displayed in
the main Configuration Service window tree view immediately, click Probe.

■ Card List – displays host adapters and array controllers that are installed in or
connected to the specified server. To view more information about any of the host
adapters or array controllers listed, select the appropriate record in the list and
click View, or double-click the selected status record. A window describing the
corresponding host adapter or array controller is displayed.

View HBA Card
View HBA Card displays the characteristics of the Host Bus Adapter (HBA) card
that is selected in the main Configuration Service window.

To access View HBA Card, double-click the host adapter icon in the main
Configuration Service window or select the host adapter icon and select View →
View HBA Card.

View HBA Card displays the status of the host adapter card and its device driver
and provides a list of the devices connected to the adapter. Configuration Service
channels start with number 0. The server listed at the top of the window is the server
in which the host adapter is installed.
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Note – Configuration Service displays a blank record or N/A in a status column
when it cannot obtain information from the host adapter regarding the queried
device.

To view additional information about any of the devices listed, either double-click
the device record, or select the record and click View. A separate dialog box is
displayed showing detailed information about that device.

View Controller Configuration
View Controller Configuration displays the components that comprise the Sun
StorEdge array.

To access View Controller Configuration, double-click the Sun StorEdge array
icon in the main Configuration Service window, or select it and select View →
View Controller.
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The tabs in the bottom section of the window provide detailed information about the
RAID controller’s LUNs, on the physical drives attached to it, on the enclosure
where the controller is located, and on the configuration of the peripherals. To bring
the information for another tab into view, click the tab.

Controllers Tab
To access this window, double-click the Sun StorEdge array icon in the main
Configuration Service window, or select it and select View → View Controller. Then
click the Controller tab.

The Controller tab lists the two controllers. To view more information about either of
the controllers, double-click the desired controller or select the controller and click
View. Depending on whether the controller is primary or secondary, the View
Primary or View Secondary Controller Configuration window is displayed. See
“View Primary/Secondary Controller Configuration” on page 86.
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Physical Drives Tab
To access this window, double-click the Sun StorEdge array icon in the main
Configuration Service window, or select it and select View → View Controller. Then
click the Physical Drives tab.

The following figure shows the View Controller Configuration with the Physical
Drives tab displayed.

The Physical Drives tab lists the physical drives associated with the Sun StorEdge
array. To see details about any of the physical drives listed, double-click the drive or
select the drive and click View. The View Physical Drive window is displayed.
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For more information about View Physical Drive, see “View Physical Drive” on
page 90.

Enclosure Info Tab
To access this window, either double-click the Enclosure icon in the main
Configuration Service window, or select the Sun StorEdge array icon and select
View → View Controller. Select the Enclosure Info tab. Select an enclosure and click
View.

The information in the Enclosure Info tab includes the status of the power supplies,
fans, and the enclosure temperature. For more information about View Enclosure,
see “View Enclosure” on page 91.

View Controller Parameters
Click View Controller Parameters to view detailed information about Channels, RS
232, Cache, Disk Array, Drive/IF, Host I/F, and Redundancy. To view the
information, click the tab that corresponds to the item you want to view. To change
controller parameters, see “To Change Controller Parameters” on page 146.
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View Primary/Secondary Controller
Configuration
View Primary and View Secondary Controller Configuration windows display the
characteristics of the RAID controller that is selected in the main Configuration
Service window. To display the primary controller characteristics, select the primary
controller from the main Configuration Service window and select View → View
Controller, or double-click the primary controller.

The following examples show the primary controller.
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The following examples show the secondary controller.
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Logical Drives Tab

To access this view window, double-click the primary or secondary RAID controller
icon in the main Configuration Service window, or select the controller icon
and select View → Controller.

Click View Controller Params for editable component parameters on the RAID
Controller Parameters window.

To view a logical drive, select and double-click a drive from the Logical Drives tab,
or select a drive and click View.
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View Logical Drive
View Logical Drive displays the characteristics of the logical drive that is selected in
the main Configuration Service window.

To access this view window, use one of the following methods.

■ Double-click the logical drive icon in the main Configuration Service window.

■ Select the logical drive icon and select View → View Logical Drive.

■ Double-click the RAID controller icon , select a logical drive in the list box,
and click View.

For more information about any of the disk drives listed, either double-click the
drive’s status record, or select the drive and click View. The View Physical Drive
window is displayed.
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View Physical Drive
View → View Physical Drive presents the characteristics of the selected physical
device. The title of the view window that appears varies, depending on the device
selected.

■ For a disk drive , it is called View Physical Drive window.
■ For a tape drive , it is called View Tape window.
■ For a CD-ROM , it is called View CD-ROM window.

You can access one of these windows by double-clicking the physical device in the
main Configuration Service window, or by selecting the device and selecting View →
View Physical Drive.

■ Associated Partitions – is displayed only when the selected device is associated
with one or more logical drive partitions.

■ View – is active when there are associated logical drives.

The previous figure displays an example of a View Physical Drive window where
the selected physical drive is associated with a single partition.
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■ Remaining Size – remaining unused capacity when part of a disk drive’s capacity
has been used in one or more logical drives.

■ RPM – the revolutions per minute of the physical drive.

■ SMART Drive – whether the drive has predictive failure capability.

You can also select the physical drive and select View. The View Logical Drive
window is displayed without the table.

The View Tape and View CD-ROM windows are similar to that shown in the
previous figure, but the categories differ slightly.

View Enclosure
The View Enclosure window displays the component and alarm characteristics of a
Sun StorEdge array enclosure (named Sun StorEdge 3310 A) that is selected in the
main Configuration Service window.

1. Select an EMU icon .

2. Select View → View Enclosure.

The upper two sections of the window identify the enclosure and provide related
information. Note that when you have a Sun StorEdge array with multiple
enclosures, you can use the Enclosure Number list box (located in the upper right
corner of the window) to reflect another enclosure attached to the same array
controller.

To display the FRU IDs and information for all FRUs in the Sun StorEdge array, click
View FRU.
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The Alarm State section of the window applies only if you have a Sun StorEdge
array with a SCSI Accessed Fault-Tolerant Enclosure (SAF-TE) card.

■ If the Alarm State field displays Alarm! and the Reset button is shown as active,
it means that there is an alarm state caused by a failure of a drive, fan, power
supply, or battery, or by an abnormal temperature in the enclosure. The audible
alarm on the box sounds.

■ For Configuration Service to continue monitoring after this alarm condition starts,
you must click Reset in this window, or you can click Reset on the Sun StorEdge
array enclosure.

■ Only users assigned configuration security privileges are allowed to Reset the
alarm through Configuration Service. Replace the failed component or check the
enclosure if its internal temperature is abnormal.

The lower section of the window provides status of the components in the window.
When there is a device in the slot, it is represented by a drive icon with a color and
a symbol representing its device state.
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View FRU
A FRU is a field replaceable unit. It is a part used to assemble a new system or to
repair a system in the field. The Sun FRU ID (field replaceable unit identification)
program is a Sun-wide solution for capturing, transmitting, and analyzing FRU-
specific configuration, diagnosis, and failure information residing on the FRU.

Select View → View FRU to display the FRU IDs and information for all FRUs in the
Sun StorEdge array including Serial Number, Model, Description, Vendor ID, Time
(time the FRU was programmed), and Location.

Note – You can also view the FRUs for a specific controller by clicking View FRU on
the View Controller Configuration window, the View Primary Controller
Configuration window, and the View Secondary Controller Configuration window.
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Array Administration Progress
Array Admin Progress displays the progress of a new logical drive(s) initialization.
This command is accessed by selecting View → Array Admin Progress.

Agent Options Management
Agent Options enables you to customize the Configuration Service Agent options,
including polling time, periodic device discovery time, and SMART monitoring.

To access Agent Options, select View → Agent Options Management. For more
information see, “To Configure Agent Parameters (optional)” on page 40.

Event Log
The Configuration Service Console receives, logs, and displays events generated by
managed servers and by the Configuration Service Console itself.

The majority of the events are generated by the Configuration Service Agents on the
managed servers and occur when there are:

■ Status changes on any device on a managed server, including the server itself
(because of device failure, malfunction, or disconnection)

■ Inventory changes (addition or removal of devices)

■ Configuration changes (initial configuration setup and subsequent configuration
changes)

■ Array processes running on the server (initialization, parity checking, rebuilding)

Although array processes are initiated by the Configuration Service Console, it is the
server agent that generates operation notification events after these processes start
on the server.

The Configuration Service Console generates a much smaller number of events. For
example, it generates an event if it does not receive a certain number of consecutive
heartbeats from a managed server.
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When the console receives any event, it logs it into Configuration Service’s Event
Log file, EVENTLOG.TXT, and displays it in the Event Log window. Also, if the event
occurs on a server, the notification of the event is sent to that server’s operating
environment/system event log. On an NT server, it would go to the NT event log. In
addition, when the event occurs on a server and that server is set up to send traps to
an SNMP enterprise management console, such as HP OpenView, the server agent
also sends a trap message to that computer.

Depending on the event received, the console might initiate a refresh process to
request the inventory from the last periodic scan of the server involved, so the
console can update the server’s inventory on the main Configuration Service
window.

During this refresh process, the satellite dish icon is attached to the server icon, and
you cannot perform any Configuration Service configuration and array activity
commands on that server until the process is completed and the main window is
updated.

Event Log File
Configuration Service’s Event Log window displays up to 500 events at a time. If
you have more than 500 events, only the most recent 500 are displayed in the Event
Log window; however, Configuration Service does not delete any events from the
Event Log file, EVENTLOG.TXT, until more than 10,000 events have been logged.

■ After 10,000 events, Configuration Service reduces the Event Log file to the most
current 500 events and then accumulates events until the limit of 10,000 is
exceeded again.

■ The fields of each event record are separated by a semi-colon so you can easily
import the file into a database.

■ EVENTLOG.TXT is located in the directory where the Configuration Service
Console program files are installed.
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Event Log Window
To access Event Log, select View → Event Log. This window can be hidden by
clicking Close and reopening (from the View menu) without losing any content.

Configuration Service Consoles begin to receive events when they are running,
regardless of whether the Event Log window is open.

1. To delete the log file, click Delete Logfile.

The Confirmation window is displayed, prompting you to save the log file.

2. Select one of the following options:

■ Select yes at the prompt, select a folder and a file name, and save the log file.

■ Select no at the prompt.

The log file is deleted.
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Each event record contains the fields shown in the following table.

Severity Levels
■ Critical. A message that does require intervention by the network administrator,

such as the failure of a device, power supply, or fan.

■ Warning. Warning messages generally indicate internal program events.
However, if you see a large number of these messages, it might mean that there is
a problem with the server or the network.

■ Informational. A message about the devices on the server that does not require
intervention by the network administrator.

You receive alarm forwarding for the level selected and any other levels of a higher
severity. Thus, if you choose Informational, you are also notified of all alarm
conditions. However, if you choose Critical, only Critical alarms are received.

For further information about messages, see “Troubleshooting” on page 211.

TABLE 7-3 Event Record Fields

Date The date on the server when the event occurred.

Time The time on the server when the event occurred.

Server The IP address of the server and the server name.

Card The card name, if applicable, for the event.

Severity
One of three severity levels: Critical, Warning, or Informational. (These
states are described in the following subsection.)

Error Code The basic error code and the extended error code, separated by a dash.

Text Message A text message describing the event.
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Save Report
Use Configuration Service’s Save Report option to create a text file containing all the
information available to Configuration Service about a specific Sun StorEdge array.

1. Select File → Save Report.

The Report dialog box for confirming the server’s ID is displayed.

2. Select Save report.

The Save Report File window is displayed. The report files are saved using the
ASCII text file format.
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3. Type a file name with a .txt extension to identify the file type and click Save.

Configuration Service writes the report on the inventory and status of the selected
server and its devices.

The default save location for the report file is in the Configuration Service
installation directory. It might be helpful to create a subdirectory for saving reports,
so they do not clutter up the installation directory.

The following figure shows an excerpt from an example report.
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View Report
Use Configuration Service’s View Report option to review a report that was created.

1. Select File → View Report.

The Open dialog box for selecting the report is displayed.

2. Select the report you want to review and click Open.

Out-of-Band Storage Management
Configuration Service’s out-of-band storage management capability enables you to
monitor and manage Sun StorEdge arrays over the network using TCP/IP. Unlike
in-band storage management (the standard method of storage management for
storage), which requires the Configuration Service Agent to be running on the server
that is physically attached to the storage, out-of-band storage management does not
require the Configuration Service Agent to be running on the server that is
physically attached to the storage. With out-of-band storage management, you do
not need to load extra software on the server, and you have the flexibility to monitor
and manage storage from anywhere on the network.
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The following figures show examples of in-band and out-of-band storage
management configurations.

FIGURE 7-1 In-Band Management

FIGURE 7-2 Out-of-Band Storage Management
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▼ To Use Out-of-Band Management

Note – Before you begin, make sure you have set up a static or dynamic IP address
for the Sun StorEdge array.

Note – Controller, SAFT-TE, and Drive firmware cannot be upgraded through out-
of-band management.

1. Select the server.

2. Select View → Agent Options Management.

3. In the Agent Options Management window, check Out-Of-Band Agent preferred
over In-Band.

Note – With this option checked, out-of-band becomes the preferred method of
storage management. If the out-of-band configuration is removed, Configuration
Service reverts to in-band storage and monitoring after you start/restart the services.

4. Type the IP address of the Sun StorEdge array in the IP Address field, and click
Add.

5. For Configuration Service to recognize the out-of-band Sun StorEdge array and
display it in the main window, select the server.

6. Select View → View Server.
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7. Click Probe.

An additional HBA is displayed in the Configuration Service main window.
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When you view the HBA (View→ View HBA Card), notice the eth in the Driver field,
which indicates out-of-band management.

▼ To Remove a Sun StorEdge Array From
Out-of-Band Management

1. Select the server.

2. Select View → Agent Options Management.

3. Select the Sun StorEdge array you want to remove from the Managed Primary
Agent list, and click Remove.

The additional HBA remains displayed in the Configuration Service main window;
to remove it, you need to stop/restart services.
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Managing Storage Through the Web
Configuration Service’s web-based storage management capability enables you to
conveniently manage the Sun StorEdge array through the web without having to
load the entire Configuration Service package. The following steps describe how to
set up the Sun StorEdge array for web-based management and to access it through a
web browser.

Web Browser Requirements

Solaris Operating Environments
■ Netscape 4.76 (standard browser for Solaris 8 OE)
■ Java Plug-in 1.2.2_02 (comes with Netscape)

Microsoft Windows NT/2000 Operating Systems
■ Internet Explorer 6.0
■ Java Plug-in 1.2.2_02

or

■ Netscape 4.76
■ Java Plug-in 1.2.2_02 (comes with Netscape)

Setting Up the Sun StorEdge Array
1. Copy the following files/directory from opt/SUNWsscs/sscsconsole to

anywhere on the machine from which you are going to manage storage. (The files
must stay together.)

■ console.html
■ lib (directory)

■ sscs.jar
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2. After you have copied the above files, you need to modify the java.policy file.
Depending on your operating environment/system, go to

Solaris Operating Environment

/usr/java1.2/jre/lib/security

Microsoft Windows NT/2000

C: Program Files\JavaSoft\JRE\1.2\lib\security

3. As shown in the code example, edit java.policy by adding the following line to
the end of the file

4. Save the file.

grant {
permission java.security.AllPermission;

};
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▼ To Access Sun StorEdge Array
1. Open the web browser.

2. Select File → Open Page.

3. Type the location of the console.html file.

4. Click Open Navigator.

5. Continue monitoring, maintaining, and updating storage as explained in the
applicable chapters in this guide.
Chapter 7 Monitoring the Sun StorEdge Array 111



112 Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



CHAPTER 8

Maintaining the Sun StorEdge
Array

This chapter describes how to maintain the integrity of the Sun StorEdge array using
Array Administration. Topics covered in this chapter are as follows:

■ “Array Administration Activities” on page 113
■ “To Check Parity” on page 114
■ “To Schedule a Parity Check” on page 115
■ “Failed Drives” on page 117
■ “To Automatically Rebuild a Drive Using a Standby Drive” on page 118
■ “To Rebuild a Device Without a Standby Drive” on page 118
■ “To Check the Progress of the Rebuilding Process” on page 119
■ “To Manually Rebuild a Failed Drive” on page 119
■ “To Restore a Logical Drive Configuration” on page 121
■ “To Reset the Controller” on page 124
■ “To Mute the Controller Beeper” on page 124
■ “To Bring a Failed Controller Back Online” on page 125

Array Administration Activities
Array administration activities such as initialization, drive rebuilding, and
parity checking can take some time, depending on the size of the logical drive or
physical drives involved.
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After one of these processes has started, the Controller Array Progress window is
displayed. If you close the window, to view progress, click the Progress Indicator
icon or select View → Array Admin Progress.

▼ To Check Parity
Parity checking is the process where the integrity of redundant data on fault-tolerant
logical drives or LUNs (RAID 3 and 5) is checked.

1. Select the logical drive on which you want to run parity check.

2. Select Array Administration → Parity Check.

Note – You need to be logged in as either ssadmin or ssconfig to access options
on this menu.
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3. When the Logical Drive Parity Check window is displayed, select the logical drive
on which you want to run a parity check.

To run a parity check on multiple drives, use the Array Administration → Schedule
Parity Check command to schedule a parity check to be run in the near future (such
as within three minutes). When scheduled parity check runs, it automatically
performs the parity checks one after another.

4. Click the Parity Check button to start the parity check process.

Once a parity check has started, the Progress Indicator is automatically displayed. If
this window is closed, it can be reopened by selecting View → Array Admin
Progress or by clicking the Progress Indicator icon. A window is displayed that
shows the percentage of completion progress for each array.

▼ To Schedule a Parity Check
Select Array Administration → Schedule Parity Check to check parity of a specific
logical drive array at scheduled intervals (for example, during off hours).

■ You can choose to schedule any number of logical drives configured on a
managed server; however. you can establish only one schedule per array
controller.

■ When you schedule multiple logical drives, the check is done in sequence from
the lowest to the highest numbered logical drive.

■ A parity check requires an average of five minutes per Gbyte of storage.
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■ You can control the amount of system resources allocated to the parity check by
changing the background rate.

■ A parity check can be stopped once it has started. There is no result of data
corruption as a result of this operation.

Note – You need to be logged in as either ssadmin or ssconfig to access options
on this menu.

1. Select the controller on which you want to schedule the parity check.

2. Select Array Administration → Schedule Parity Check.

The Schedule Parity Check window is displayed.
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3. Make selections in the appropriate fields on this window.

■ Listed Logical Drives – A list of the fault-tolerant logical arrays connected to the
selected host adapter. Use the Shift key to select multiple drives.

■ Background Rate – The percentage of available array controller CPU time
assigned to array administration activities. Select Change Controller Parameters
from the Custom Configuration Options window to change the background rate.

■ How Often – Specify how often you want the parity checked.

■ Starting Day – Specify the day of the week you would like this schedule to start.

■ Starting Time – Specify the time on the starting day you would like this schedule
to begin.

■ Existing Schedule – The current parity schedule: logical drive, frequency, starting
day, and time.

■ Next Parity Check – The date and time you want the next parity check to start.

4. When you are satisfied with the schedule, click OK.

Failed Drives
This section contains procedures for recovering from a drive failure with and
without a standby drive. If for some reason these procedures do not start the
rebuilding process, instructions are also provided for manually starting a rebuild
after a drive failure.

Caution – Install either local or global standby drives previously installed and
configured for each logical drive array before a failure occurs. Depending on the
type of RAID level used and archiving procedure implemented, significant data loss
might occur in cases of single or multiple drive failures. Additionally, make tested
spare drives readily available on site for immediate replacement if a malfunction
occurs.
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▼ To Automatically Rebuild a Drive Using a
Standby Drive
When a drive associated with a fault tolerant logical drive fails, and a standby drive
has previously been installed and configured as either a global or local spare, the
failed drive is automatically substituted and its data rebuilt using the designated
spare drive. For this to occur flawlessly, the spare drive’s capacity must always be
equivalent or larger than the failed drive that is being replaced.

The rebuilding process normally starts within one to two minutes. It is performed in
the background and takes approximately eight minutes per Gbyte when there is no
other activity on the controller.

During the automatic rebuild process, normal activity might continue, although
performance might degrade. The degree to which performance degrades is
determined by the background rate set for the controller.

The progress of the rebuild process is displayed when you select View → Array
Admin Progress.

1. Re-establish automatic rebuild capability by replacing the failed drive using
instructions contained in the Sun StorEdge 3310 SCSI Array Installation, Operation,
and Service Manual.

2. Wait at least 60 seconds after removing the failed drive before inserting a new
drive.

Make sure the replacement drive is at least equal to the largest drive in the
enclosure. Install the replacement drive in the same slot (drive bay) as the failed
drive; the replacement drive then becomes the new standby drive.

3. After the rebuild process is complete and the logical drive becomes online again,
back up the array controller configuration to a file on an external drive or diskette.

See “To Save the Logical Drive Configuration” on page 45.

▼ To Rebuild a Device Without a Standby Drive
If there is no standby drive in the Sun StorEdge array, you need to replace the failed
drive before the automatic rebuild process can start.

1. To recover from a drive failure when there is no standby drive, replace the failed
drive by using the instructions contained in the Sun StorEdge 3310 SCSI Array
Installation, Operation, and Service Manual.
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2. Wait at least 60 seconds after removing the failed drive before inserting a new
drive.

Make sure the capacity of the replacement drive is at least equal to that of the failed
drive. Install the replacement drive at the same address (drive bay) as the failed
drive.

3. Once the failed drive is replaced in the same slot, you need to scan it in.

For detailed instructions on scanning in a drive, see “To Scan in New Hard Drives”
on page 139.

4. After the drive has been scanned, you need to manually rebuild it by selecting
Array Administration → Rebuild.

▼ To Check the Progress of the Rebuilding Process
1. Select View → Array Admin Progress or click the Progress Indicator icon in the

upper right corner of the window .

The Controller Array Progress window is displayed that shows the completion
percentage of the rebuild. However, if there are array activities (such as
initialization, rebuild, or parity check) occurring on multiple controllers, the Select
Controller Progress window is displayed first.

2. Select the controller whose progress you want to view and click OK.

The Controller Array Progress window is displayed that shows the array progress of
the selected controller. Refer to “Array Administration Activities” on page 113.

▼ To Manually Rebuild a Failed Drive
In most cases, you do not need to use the manual rebuild process because replaced
drives are automatically rebuilt.

If a spare is not present when the failure occurs, or for some reason the drive does
not rebuild, you can use Rebuild to manually start the rebuild process. Also, if the
rebuild process is interrupted by a reset, use Rebuild to restart the rebuilding
process.

1. Replace the failed drive, using the instructions contained in the Sun StorEdge 3310
SCSI Array Installation, Operation, and Service Manual.

2. Wait at least 60 seconds after removing the failed drive before inserting a new
drive.

Make sure the capacity of the replacement drive is at least equal to that of the largest
drive in the enclosure.
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3. Select Array Administration → Rebuild.

The Rebuild window is displayed.

4. Select the status record of the replacement drive.

5. Click OK to start the rebuild process.

The rebuild process is performed in the background and takes approximately eight
minutes per Gbyte when there is no other activity on the array controller. During a
rebuild, normal activity can continue, although performance might degrade. The
degree to which performance degrades is determined by the background rate set for
the controller.

6. To check the progress of the rebuilding process, select View → Array Admin
Progress or click the Progress Indicator icon in the upper right corner of the
window.

The Controller Array Progress window is displayed that shows the completion
percentage of the rebuild.

If there are array activities (such as initialization, rebuild, or parity check) occurring
on multiple controllers, the Select Controller Progress window is displayed first.

7. Select the controller whose progress you want to view and click OK.

The Controller Array Progress window is displayed and shows the array rebuilding
status for that controller.
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▼ To Restore a Logical Drive Configuration
This section describes how to restore the array configuration information from a
backup file. You must have saved a backup file using the Save command as
explained in “Logical Drive Configuration File” on page 68. If the array controller
and its drives are damaged, you can restore the array configuration to a new
controller without having to completely reconfigure the storage array.

Caution – Restore the array configuration from a file only if the configuration file is
current. Data loss will result from restoring an outdated or incorrect configuration.

If you are sure that the backup file contains the correct array configuration
information, continue with the following procedure to restore the configuration.

1. Select the controller for the appropriate Sun StorEdge array.

2. Select Configuration → Load Configuration.

The Select Configuration File window is displayed.

3. Specify the name and location of the backup configuration file and click Open.
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The Load Configuration window is displayed. To see a tree-view representation of
the configuration, click the Configuration View tab.

The Saveset Description tab displays the description of the file that was specified
when the configuration file was created.
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4. To load the saved configuration, select OK.

The Load Configuration Confirmation window is displayed.

Carefully review the information presented in the Load Configuration Confirmation
window before making a decision to continue.

5. Click Apply to load this configuration or click Cancel to terminate this function.

Apply causes the configuration operation to continue, and a progress window is
displayed.

Note – Do not initialize LUN(s) after restoring the array configuration backup file
contents.

6. If you are running Microsoft Windows NT, shut down and restart the operating
system.

Reinitializing the operating system is required to enable the logical drive
configuration to be recognized by Windows NT.
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▼ To Reset the Controller
Whenever you make changes to the controller parameters, you are asked if you want
to reset the controller so that the changes take effect. If you are making multiple
changes, you might not want to stop and reset the controller after each change. Use
the Issue Reset to the Controller option to manually reset the controller after making
multiple parameter changes.

1. Select any storage icon in the main window.

2. Select Array Administration → Controller Maintenance.

3. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

4. Click Issue Reset to the Controller.

▼ To Mute the Controller Beeper
When an event occurs that causes the controller to beep, for example, when a logical
drive fails, during a rebuild, or when adding a SCSI drive, you can mute the
controller beeper.

1. Select the controller icon in the main window.

2. Select Array Administration → Controller Maintenance.

3. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

4. Click Mute Controller Beeper.

or

1. Select the desired controller icon in the main window.

2. Select Configuration → Custom Configure.

3. Select Change Controller Parameters.

4. Select Mute Beeper.
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▼ To Bring a Failed Controller Back Online
If a controller fails, bring it back online as described in the following steps.

1. Select the desired controller icon in the main window.

2. Select Array Administration → Controller Maintenance.

3. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

4. Click Deassert Failed Redundant Controller.

or

1. Select the desired controller icon in the main window.

2. Select Configuration → Custom Configure.

3. Select Change Controller Parameters.

4. Select the Redundancy tab.

5. From the Set Controller Config field, select Redundant Deassert Reset.
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CHAPTER 9

Updating the Configuration

Refer to this chapter when you want to change the current configuration or add to it.
This chapter describes the following tasks:

■ “To Add a Logical Drive” on page 128
■ “To Delete a Logical Drive” on page 130
■ “To Create a Partition” on page 132
■ “To Delete a Partition” on page 133
■ “To Expand the Capacity of a Logical Drive” on page 134
■ “To Add SCSI Drives to an Existing Logical Drive” on page 135
■ “To Copy and Replace Member Drives” on page 137
■ “To Scan in New Hard Drives” on page 139
■ “To Download RAID Controller Firmware” on page 140
■ “Downloading Firmware for Devices” on page 143
■ “To Change Controller Parameters” on page 146
■ “To Mute the Controller Beeper” on page 157
■ “To Save Changed Values” on page 157
■ “To Assign or Change Standby Drives” on page 158
■ “To Edit a Server Entry” on page 159

The Configuration menu commands and tool icons might be temporarily disabled if
an array administration process, such as parity checking, is running. The menu
command is also shown as deactivated when the Configuration Service Console is
refreshing its inventory on the server. A satellite dish symbol is attached to the
server icon during the refresh process .

To use the Configuration options, you must log into the ssconfig security level of
the software with the ssconfig password. When you are finished with the
configuration activities, log back into the monitoring level of the program.
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▼ To Add a Logical Drive
Use this option to add one or more logical drives to an existing configuration of
RAID sets.

1. Select the appropriate Sun StorEdge array.

2. Select Configuration → Custom Configure.

Note – This selection is inactive unless you have selected a Sun StorEdge array with
available physical drives.

3. Select Add a New Logical Drive to the Current Configuration from the Custom
Configuration Options window.

4. Verify the server and controller are displayed at the top of the window.

5. Select a disk you want to be included in the new logical drive and click Add Disk.

If you make a mistake or change your mind, select the drive in the participating
drives list and click Remove Disk.

6. Select a RAID level.

For definitions on RAID levels, see “Glossary” on page 253.

7. Select the desired Host channel and SCSI ID to which you would like the new
logical drive to be mapped to from the Host Channel and the Host SCSI ID list
box.

Note – If you assign a logical drive to a secondary controller Host Channel and Host
SCSI ID (SID), you must reset the controller.

8. Set the Max Drive Size.

The Max Drive Size displays the total capacity of each disk. A smaller logical drive
can be created by decreasing this value.

Note – If you do not change the Max Drive Size but you do change the Partition
Size, Configuration Service creates a new partition at the specified partition size. The
remaining logical drive size capacity moves to the last partition. Remaining capacity
can be used later by expanding the drive (as explained in “To Expand the Capacity
of a Logical Drive” on page 134). The drive capacity is no longer editable after a
partition is created.
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Note – You can create up to eight logical drives and up to 32 partitions per logical
drive on a Sun StorEdge array controller. If you want to create another logical drive
on the same controller, click New Logical Drive. Configuration Service creates the
logical drive you just defined and returns to the top of the window, enabling you to
create another logical drive.

9. When you are satisfied with the selections on this window, and do not want to
define another logical drive, click Commit.

A confirmation window is displayed showing the new configuration.

10. Click OK to accept the configuration.

11. Select Cancel to return to the Configuration Service Console.

This provides additional fault tolerance. A drive’s state can always be changed back
to available when needed.

Note – You cannot change a logical drive configuration after you click OK.
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▼ To Delete a Logical Drive
Use this option to delete one or more logical drives from an existing configuration of
RAID sets.

Note – Before you can delete a logical drive, you need to delete all assigned LUNs.

1. Select the appropriate Sun StorEdge array.

2. View the logical drive(s) you want to delete.

3. If any of the logical drives have host LUN assignments, proceed to Step 4; if they
do not, proceed to Step 8.

4. Select Configuration → Custom Configure.

5. Select Change Host LUN Assignments.

6. Select the host LUNs attached to the logical drive you want to delete, and click
Delete Host LUN.

7. Click OK, and then click Close.

8. Select Configuration → Custom Configure.

9. Select Manage Existing Logical Drives and Partitions from the Custom
Configuration Options window.

10. Select the Logical Drives tab on the Manage Existing Logical Drives and Partitions
window.

11. Select the logical drive you want to delete, and click Delete Logical Drive and
click OK.
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12. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.

About the Logical Drive Number

The logical drive number displayed in the LD field in the Manage Existing Logical
Drives and Partitions window is dynamic; it changes when logical drives are
created/deleted. Used strictly as a placeholder that enables you to visually keep track
of logical drives, this LD number is insignificant to the controller. That is, the
controller does not report on the logical drives according to this number. For
example, if four logical drives exist, and LD2 is deleted, the existing LD3
dynamically changes to LD2, and LD4 changes to LD3. Only the LD number
changes; all LUN mapping and data on the logical drives remains unchanged. The
actual LD number as displayed in the LD field is irrelevant; the controller reports on
the total number of logical drives, which in this case is three. In this example, if a
new logical drive is created, it takes the LD number of the logical drive that was
deleted and the controller reports that there are a total of four logical drives. All
existing logical drives return to their original primary/secondary designation.

Note – The LG number on the firmware terminal menu option View and Edit
Logical Drives is not dynamic. After a logical drive is deleted, the logical drive
numbers do not automatically change; you see an empty placeholder. When a logical
drive is created from the console or from the terminal, this empty placeholder is
filled with the new logical drive.
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▼ To Create a Partition

Note – Before you can create a partition, you need to delete all assigned LUNs.

1. Select the appropriate Sun StorEdge array.

2. View the logical drive(s) you want to create partition(s) on.

3. If any of these logical drives have host LUN assignments, proceed to Step 4; if
they do not, proceed to Step 8.

4. Select Configuration → Custom Configuration.

5. Select Change Host LUN Assignments.

6. Select the Host LUN(s) that are attached to the logical drive(s) you want to
partition, and click Delete Host LUN.

7. Click OK, and then click Close.

8. Select Configuration → Custom Configure.

9. Select Manage Existing Logical Drives and Partitions from the Custom
Configuration Options window.

10. Select the Partitions tab on the Manage Logical Drives and Partitions window.

11. Select a logical drive you want to partition.

12. Specify the Partition Size in Mbytes and click Create.

13. To change the size of a partition you have already created, select the logical drive,
and click Modify Size.

14. Specify the new size (in Mbytes) in the Partition Size field, and click OK.
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15. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.

▼ To Delete a Partition

Note – To delete a partition on a logical drive, you need to delete all assigned LUNs.

1. Select the appropriate Sun StorEdge array.

2. View the logical drive(s) on which you want to delete the partitions.

If any of the partitions on the drive have host LUN mappings, proceed to Step 3; if
they do not, proceed to Step 7.

3. Select Configuration → Custom Configure.

4. Select Change Host LUN Assignments.

5. Select the LUNs that are mapped to the logical drive’s partitions that you want to
delete, and click Delete Host LUN.

6. Click OK, and then click Close.

7. Select Configuration → Custom Configure.

8. Select Manage Existing Logical Drives and Partitions from the Custom
Configuration Options window.
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9. Select the Partitions tab on the Manage Logical Drives and Partitions window.

10. Starting from the bottom of the list of partitions, select the partition you want to
delete.

11. Click Delete, and then click OK.

12. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.

▼ To Expand the Capacity of a Logical Drive
Use this option to expand the capacity of an existing logical drive. For example, you
might originally have had an 18-Gbyte drive of which only 9 Gbytes were selected to
build a logical drive. To use the remaining 9 Gbytes, you need to expand the logical
drive.

1. Select the appropriate Sun StorEdge array.

2. Select Configuration → Custom Configure.

3. Select Dynamically Grow and/or Reconfigure Logical Drives from the Custom
Configuration Options window.

4. Select the logical drive you want to expand.

5. Select the Expand Logical Drive tab on the Dynamically Grow and/or Reconfigure
Logical Drives window.
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6. Specify the capacity in Mbytes by which you want to expand the logical dive in
the Maximum Drive Expand Capacity field, and click OK.

The Maximum Drive Expand Capacity cannot exceed the Maximum Available Drive
Free Capacity.

7. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.

▼ To Add SCSI Drives to an Existing Logical Drive
1. Select the appropriate Sun StorEdge array.

2. Select Configuration → Custom Configure.

3. Select Dynamically Grow and/or Reconfigure Logical Drives from the Custom
Configuration Options window.

4. Select the logical drive to which you want to add a SCSI drive.

5. Select the Add SCSI Drives tab on the Dynamically Grow and/or Reconfigure
Logical Drives window.
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6. From the list of Available disks, select the drive you want to add to the logical
drive.

7. Click Add Disk.

The drive is moved to the Add disk(s) to LD list.

If you make a mistake or change your mind, select the disk from the Add disk(s) to
LD list and click Remove.

8. When you are finished adding the SCSI drives, click OK.

9. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.
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▼ To Copy and Replace Member Drives
Use this option to copy and replace existing member drives with drives of higher
capacity. For example, a logical drive that is originally composed of three member
drives, each of which has a capacity of 18 Gbytes, can be replaced with new member
drives each with a capacity of 36 Gbytes, as illustrated in the following figure.

FIGURE 9-1 Copying and Replacing Member Drives

1. Select the appropriate Sun StorEdge array.

2. Select Configuration → Custom Configure.

3. Select Dynamically Grow and/or Reconfigure Logical Drives from the Custom
Configuration Options window.

4. Select the logical drive for which you are going to perform the copy and replace
operation.

5. Select the Copy and Replace Drive tab on the Dynamically Grow and/or
Reconfigure Logical Drives window.

6. From the Drive to Copy Data To list, select the new hard drive.

18 GB 18 GB 18 GB

RAID5 (4 GB) Copy and replace each member drive

New
Drive
36 GB

36 (GB) 36 (GB) 36 (GB)

RAID5 (4 GB)

In Use

Unused

New
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7. From the Drive to Copy Data From list, select the hard drive that is going to be
replaced, and click OK.

To use the additional capacity provided by the new drives, follow the instructions in
“To Expand the Capacity of a Logical Drive” on page 134.

8. Click OK in the Confirm Configuration Operation window to complete the
operation, and click Close.

9. When the operation is complete, close the progress window.
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▼ To Scan in New Hard Drives
A hard drive can be scanned in and made available without having to shut down the
Sun StorEdge array.

1. Double-click the appropriate Sun StorEdge array.

2. The View Controller Configuration window is displayed.

3. Select the Physical Drives tab, and click Scan SCSI Drive.

4. Select the correct Channel and ID that the drive was input on.

If the scan was successful, the drive is appropriately displayed and made available.
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▼ To Download RAID Controller Firmware
The following procedures are used to upgrade the controller firmware for both a
single and redundant controller configuration.

1. Select the desired controller icon in the main window.

2. Select Array Administration → Controller Maintenance.

3. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

4. If upgrading firmware only (not boot record), select the Download Firmware
option.

The Select Firmware File window is displayed.
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5. Select the firmware you want to download, and click Open.

The Confirmation Dialog prompt is displayed.

6. Click Yes.

The firmware download to the RAID controller displays a progress bar.
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7. When the progress bar reaches 100%, click OK.

8. After the firmware has been downloaded, check the settings to make sure they are
configured correctly.

▼ To Upgrade Firmware and Boot Record
1. Go to Array Administration → Controller Maintenance.

2. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

3. Select Download Firmware with Boot Record.

The Select Boot Record File window is displayed.
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4. Select the boot record and click Open.

5. Select the appropriate firmware file.

The Select Firmware File is displayed.

6. Click Open.

The Confirmation Dialog window is displayed.

7. Repeat Steps 6 through 8 in the previous subsection.

Downloading Firmware for Devices
This option enables you to upgrade the firmware on hard drives and SAF-TE
devices.

▼ To Upgrade Firmware on Hard Drives
1. Select the Sun StorEdge array.

2. Select Array Administration → Download FW for Devices.

3. Click the Download FW for Disks tab.

4. Select either To All disks under Controller, and select a Sun StorEdge array from
the menu, or select To All disks under LD, and select the logical drive from the
menu.
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■ If there are drives that you do not want the new firmware downloaded to, select
them from Selected Disks, and click Remove.

■ If there are logical drives that you want to add, select them from Available Disks
and click Add.

■ If you have multiple drives that have different product IDs, make sure you select
the product ID for the drive(s) to which you are downloading firmware from the
Product ID list box.

5. Click Browse and locate the download firmware file.

Select Open.

6. Select the download firmware file, click Open, and click OK.

The firmware starts to download.

7. When the progress reaches 100%, click OK.

8. To verify that the firmware has downloaded successfully, select View → View
Physical Drive, and make sure the firmware version has changed in the Product
Revision field.
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▼ To Upgrade Firmware on SAF-TE Devices
1. Select the Sun StorEdge array.

2. Select Array Administration → Download FW for Devices.

3. Click the Download FW for SAFTE Devices tab.

■ To add a device, select it from Available SAF-TE Devices and click Add.
■ To remove a device, select it from Selected SAF-TE Devices and click Remove.

4. Click Browse and locate the download firmware file.

5. Select the download firmware file, click Open, and click OK.

The firmware starts to download.

1. When the progress reaches 100%, click OK.

2. To verify that the firmware has downloaded successfully, select View → View
Enclosure, and make sure the firmware version has changed in the Firmware Rev
field.
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▼ To Change Controller Parameters
1. Select the appropriate Sun StorEdge array controller from the main menu and the

tree view.

2. Select Configuration → Custom Configure.

If necessary, log into the configuration level of the program with the ssconfig
password.

3. From the Custom Configuration Options window, select Change Controller
Parameters.

The Change Controller Parameters window with the Channel tab selected is
displayed.

■ Controller Name – If the controller name needs to be set, select Controller Name
and type the desired name. Click OK to save the change.

■ Controller Unique ID – This ID is automatically set.
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Channel Tab

1. From the Channel Settings tab, select the channel to be edited.

2. Click Change Settings.

The Change Channel Settings window is displayed. For the server to recognize the
Sun StorEdge array, a host channel must have an ID assigned to a logical drive and
a logical drive mapped to that host channel and ID. This window enables you to
configure the host/drive channel.

3. From the Channel Mode list box, select either Host or Drive.

A Drive channel is what the drives are connected to (internal or external). A Host
channel is what is connected to the server.

Note – Depending on the controller configuration, you might need to select both
primary and secondary channel IDs as described in the following steps.

4. From the Available SCSI IDs list box, first select the primary channel ID, which is
designated as PID. Then click Add PID.

5. If you have two controllers installed, select a secondary channel ID from the
Available SCSI IDs list box, and click Add SID.
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RS 232 Tab

1. After all channel settings have been made, from the Change Controller Parameters
window, select the RS 232 Settings tab.

2. Select the port desired, and click Change Settings.

The Change RS232 Port Settings window is displayed.
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3. Select any baud rate desired including the default setting of 9600, and then click
OK to return to the previous window.

Cache Tab

1. From the Change Controller Parameters window, select the Cache tab.

2. Select Optimization from the list box or accept the current setting.

This option indicates the amount of data that is written across each drive in an array.
Sequential I/O indicates large blocks of data; random I/O indicates small blocks of
data.

If an existing logical drive was created with Optimization set for Random I/O, the
same logical drive is not be capable of reading or writing data when changed to
sequential I/O mode. The reverse is also true because the stripe size is different for
each.
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3. To utilize Write Back, click the list box and select either Enabled or Disabled.

Disk Array Tab

1. From the Change Controller Parameters window, select the Disk Array tab.

2. Select either Disabled or Enabled from the three Write Verify list boxes.

Normally, errors might occur when a hard drive writes data. To avoid the write
error, the controller can force the hard drives to verify the written data.

■ Write Verify on Initialization - performs verify-after-write while initializing the
logical drive.

■ Write Verify on Rebuild – performs verify-after-write during the rebuilding
process.

■ Write Verify on Normal – performs verify-after-write during normal I/O requests.
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3. Select from the four options available in the Rebuild Priority list box: Low,
Normal, Improved, or High.

The RAID controller provides a background rebuilding ability. This means the
controller is able to serve other I/O requests while rebuilding the logical drives. The
time required to rebuild a drive set largely depends on the total capacity of the
logical drive being rebuilt. Additionally, the rebuilding process is totally transparent
to the host computer or the operating environment.

■ Low – the default that uses the controller’s minimum resources to rebuild

■ Normal – to speed up the rebuilding process

■ Improved – to speed up the rebuilding process

■ High – to use the controller’s maximum resources to complete the rebuilding
process in the shortest time possible
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Drive I/F Tab

1. From the Change Controller Parameters window, select the Drive I/F tab.

2. From the SCSI Motor Spin Up field, select either Disabled or Enabled.

The SCSI Motor Spin Up decides how the SCSI drives in a Disk Array are started.
When the power supply is unable to provide sufficient current for the hard drives
and controllers that are powered up at the same time, spinning up the hard drives
serially is one of the best ways to consume lower powerup current. By default, all
hard drives spin-up when powered on.

3. From the Power Up SCSI Reset field, select either Enabled or Disabled.

By default, when the controller is powered up, it sends a SCSI bus reset command to
the SCSI bus. When disabled, it does not send a SCSI bus reset command on the next
power up.

When connecting dual host computers to the same SCSI bus, the SCSI bus reset
interrupts all the read/write requests being performed. This might cause some
operating environments or host computers to act abnormally. Disable Power Up
SCSI Reset at power up to avoid this situation.

4. Set the Disk Access Latency.

This function sets the delay time before the controller tries to access the hard drives
after power on. The default is 15 seconds.

5. Set the Tag Count Per drive.

This is the maximum number of tags that can be sent to each drive at the same time.
A drive has a built-in cache that is used to sort all of the I/O requests (tags) that are
sent to the drive, enabling the drive to finish the requests faster.

The cache size and maximum number of tags varies between different brands and
models of drive. Use the default setting of 32. Changing the maximum tag count to
Disable causes the internal cache of the drive to be ignored (not used).

The controller supports tag command queuing with an adjustable tag count from 1
to 128.

6. From the SAF-TE Polling Period (Sec) field, select the variable time options
shown in the list box, or select 0.0 to disable this function so that all installed
Event Recording Modules (ERMs) are never polled.
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7. From the SCSI I/O Timeout (Sec) field, select from 0.5 through 10 seconds.

The SCSI I/O Timeout is the time interval for the controller to wait for a drive to
respond. If the controller attempts to read data from or write data to a drive but the
drive does not respond within the SCSI I/O timeout value, the drive is considered a
failed drive.

The default setting for SCSI I/O Timeout is 7 seconds. Do not change this setting.
Setting the timeout to a lower value causes the controller to judge a drive as failed
while a drive is still retrying or while a drive is unable to arbitrate the SCSI bus.
Setting the timeout to a greater value causes the controller to keep waiting for a
drive, and it might sometimes cause a host timeout.

When the drive detects a media error while reading from the drive platter, it retries
the previous reading or recalibrates the head. When the drive encounters a bad block
on the media, it reassigns the bad block to another spare block. However, all of this
takes time. The time to perform these operations can vary between different brands
and models of drives.

During SCSI bus arbitration, a device with higher priority can use the bus first. A
device with lower priority sometimes receives a SCSI I/O Timeout when devices of
higher priority keep using the bus.

8. From the Drive Check Period (Sec) field, select from 0.5 through 30 seconds.

The Periodic Drive Check Time is an interval for the controller to check the drives on
the SCSI bus. The default value is Disabled, which means if there is no activity on
the bus, the controller does not know if a drive has failed or has been removed.
Setting an interval enables Configuration Service to detect a drive failure when there
is no array activity; however, performance is degraded.
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Host I/F Tab

1. From the Change Controller Parameters window, select the Host I/F tab.

2. Set the Max Queued IO Count.

This function enables you to configure the maximum size of the I/O queue the
controller can accept from the host computer by byte size. The default is 256. The
predefined range is from 1 to 1024 bytes, or you might choose the Auto Computer
(Automatically Configured) mode.

3. Set the LUNs Per Host.

This function is used to change the number of LUNs per host SCSI ID. The default
setting is 32 LUNs, with a predefined range of 1 to 32 LUNs available.
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Redundancy Tab

1. From the Change Controller Parameters window, select the Redundancy tab.

Three read-only fields are displayed: Controller Configuration, Controller Status,
and Secondary Serial No.

2. Select an option from the Set Controller Config field.

■ Redundant Deassert Reset – if you have failed a controller and want to bring it
back online.

■ Redundant Force Sec Fail – if you want to force the secondary controller to fail.

■ Redundant Force Pri Fail – if you want to force the primary controller to fail.

Note – Set both controllers in the Redundant Primary configuration. The controllers
then determine which one is primary and which one is secondary. This prevents any
possible conflicts between controllers.
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3. To save changes in the Change Controller Parameters window, select the Issue
Controller Reset.

4. Click Close to return to the Configuration Service main menu tree.

Network Tab

1. From the Change Controllers Parameter window, select the Network tab.

2. To manually configure an IP address, subnet mask, gateway, and MAC address,
click Change Settings.

3. If you have set up a Sun StorEdge array in an environment with a DHCP Server,
you can select Enable Dynamic IP Assignment to enable the Sun StorEdge array to
automatically obtain an IP address from the network.
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▼ To Mute the Controller Beeper
When an event occurs that causes the controller to beep, for example, when a logical
drive fails, during a rebuild, or when adding a SCSI drive, you can mute the beeper.

1. Select the desired controller icon in the main window.

2. Select Array Administration → Controller Maintenance.

3. If you are not already logged in as ssconfig, a password prompt is displayed;
type the ssconfig password.

The Controller Maintenance Options menu is displayed.

4. Click Mute Controller Beeper.

or

1. Select the desired controller icon in the main window.

2. Select Configuration → Custom Configure.

3. Select Change Controller Parameters.

4. Select Mute Beeper.

▼ To Save Changed Values
1. After you are satisfied that all changes to the variables previously described have

been made, select Configuration → Custom Configuration.

2. Click Change Controller Parameters.

3. Select Issue Controller Reset.

4. Click OK and then click Close to return to the Configuration Service menu tree.
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▼ To Assign or Change Standby Drives
A standby drive acts as a spare to support automatic data rebuilding after a physical
drive in a fault tolerant (non-RAID 0) logical drive fails. For a standby drive to take
the place of another drive, it must be at least equal in size to the failed drive and all
of the logical drives dependent on the failed disk must be redundant (RAID 1, 3, 5,
or 1+0).

With this function you can either assign a global or local standby drive or change a
ready drive’s state to standby or a standby drive’s state to ready. A drive that is
assigned as a global spare rebuilds if a member of any existing drive fails. You can
have one or more standby drives associated with an array controller. A local spare
has to be assigned to a particular logical drive and only rebuilds for a member
within that logical drive.

1. In the main Configuration Service window, select the desired array controller.

2. Select Configuration → Custom Configure or click the Custom Configuration tool.

If necessary, log into the configuration level of the program with the ssconfig
password. The Custom Configuration Options window is displayed.

3. Select Make or Change Standby Drives from the Custom Configuration Options
window.

The Make or Change Standby Drives window is displayed.
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4. Check the server and the controller IDs at the top of the window.

If you want to select a different server or controller, click Cancel to return to the
Configuration Service tree view, select the correct server, or controller from the tree
view, and repeat Steps 2 and 3.

5. Select a drive to be assigned or changed.

6. Change or assign the drive’s state by selecting Ready, Global StandBy, or StandBy
for LD# (local).

7. Click Modify.

8. Click Apply, and then click Close.

9. Whenever you make changes to the configuration, save the new configuration to a
file. (For details, see “Logical Drive Configuration File” on page 68).

Available Servers
Occasionally, you might need to edit or delete an entry from the Available or
Managed Servers lists in the Server List Setup window.

▼ To Edit a Server Entry
1. Select File → Server List Setup. The Server Setup window is displayed.

If necessary, move the server name from the Managed Servers list to the Available
Servers list in the Server List Setup window. Note that only the server entries in the
Available Servers list can be edited.
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2. Select the name of the server in the Available Servers list, and click Edit.

The Edit Server window is displayed.
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3. Make the necessary changes. Click OK to register your changes.

For descriptions of the fields in this window, see “To Add Servers” on page 30. The
Add Server and Edit Server windows contain the same fields.

IP Address Shortcut: If the network address has changed, click Get IP Addr by
Name. Configuration Service searches for and displays the correct IP address if you
typed the name of the server as it is recorded by the name service used by the
network.

If the name used for the server is not the same as the server’s network name or if the
naming service is not yet updated, delete the server and add it again.

4. Move the server name back to the Managed Servers list.

5. Click OK to exit the Edit Server window.
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CHAPTER 10

Installing and Using Diagnostic
Reporter

This chapter introduces Diagnostic Reporter and explains how to install and use it.
Topics covered in this chapter include the following:

■ “What is Diagnostic Reporter?” on page 163
■ “How Diagnostic Reporter Operates” on page 164
■ “Diagnostic Reporter Installation Packages” on page 165
■ “To Install Diagnostic Reporter” on page 166
■ “Setting Up the Diagnostic Reporter Configuration” on page 169
■ “To Set Up and Use the Mail Receiver Tool” on page 176

What is Diagnostic Reporter?
Instead of keeping the Configuration Service Console program running in the
foreground, you can use Diagnostic Reporter as a companion utility of
Configuration Service running as a background service that sends messages from the
hosts and Sun StorEdge arrays to specified email addresses. Using Diagnostic
Reporter, you can:

■ Define the types of message traps sent

■ Define the timing of messages sent

■ Send encrypted messages

■ Receive messages and decrypt encrypted messages on the Mail Receiver Tool
(which functions as an email viewing program if you do not have a program such
as Microsoft Outlook on the receiving computer)

To use Diagnostic Reporter throughout the storage data network, install it as a
service on each computer that has a controlling Configuration Service Agent (a
controlling agent is the only agent that talks to a specific Sun StorEdge array).
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One major benefit of installing Diagnostic Reporter on all host computers is that it
can be configured to ping each computer periodically, and to send a single-point-of-
failure message from a Configuration Service Agent to the specified email addresses
when a host fails.

Diagnostic Reporter includes the following components:

■ Diagnostic Reporter Agent (daemon) – operates in background mode
continuously on the computer where it is installed. The daemon can be installed
and used on any computer where Configuration Service is running.

■ Diagnostic Reporter Config Tool (UI) – a utility that configures the types of
message traps that are sent to the Configuration Service Agent and that are sent to
a specific email address as an alert or for informational purposes. Also known as
the UI (user interface).

■ Diagnostic Reporter Mail Receiver Tool – displays the messages that are collected.
Also known as the POP3 Mail Receiver.

How Diagnostic Reporter Operates
After connecting to a Configuration Service Agent, Diagnostic Reporter receives any
event from the agent; if the event is assigned a TRAP condition, then Diagnostic
Reporter emails the event to the user-specified email address.

If Diagnostic Reporter cannot connect to any agent or the agent is offline, it tries to
discover the agent every five minutes. This prevents Diagnostic Reporter from being
disconnected from the agent when network traffic is congested.

In the typical setup shown in the following figure, the Sun StorEdge array hosts
(computers #1, #2, and #3) are used with the Sun StorEdge array devices (#A, #B, and
#C respectively). Each host contains a Configuration Service Agent and a Diagnostic
Reporter daemon. Each Diagnostic Reporter daemon can be configured by the
Config Tool to send event messages to any email address (shown as computer #5,
which uses the Mail Receiver Tool to download the messages).

The Diagnostic Reporter Config Tool and the Configuration Service Console
program can be located on any computer on the network and are located on one
computer (#4) for convenience only.
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FIGURE 10-1 Typical Diagnostic Reporter and Configuration Service Setup

Diagnostic Reporter Installation
Packages
Diagnostic Reporter installation packages are contained on the Sun StorEdge
Professional Storage Manager CD, and include the following files:

Solaris Operating Environment

■ SUNWscsa – Diagnostic Reporter Agent
■ SUNWscui – Diagnostic Reporter Config Tool (UI)

Microsoft Windows Operating System

■ SUNWscsa.exe - Diagnostic Reporter Agent and Config Tool (UI)

#1

#2

#3

#5

Sun StorEdge Array

#A

Support host - receivesConfiguration Service Agent

Diagnostic Reporter

Configuration Service Agent

Diagnostic Reporter

Configuration Service Agent

Diagnostic Reporter

#4
Diagnostic Reporter

Configuration Service Console

Mail Receiver

Sun StorEdge Array Host

Sun StorEdge Array Host

Sun StorEdge Array Host

Sun StorEdge Array Host

Sun StorEdge Array Host

#B

#C

#D

Sun StorEdge Array

Sun StorEdge Array

Sun StorEdge Array

Diagnostic Reporter messages

 Tool

Config Tool
Chapter 10 Installing and Using Diagnostic Reporter 165



▼ To Install Diagnostic Reporter

Solaris Operating Environment

Note – You must install the Configuration Service Agent before installing the
Diagnostic Reporter Agent and Config Tool.

Note – Make sure Java runtime environment 1.2 or higher is installed on the
computer or workstation on which you are installing Configuration Service.

1. Insert the Sun StorEdge Professional Storage Manager CD and type

2. To install the Diagnostic Reporter Agent (daemon), type

3. To install the Diagnostic Reporter Config Tool (UI), type

4. Provide appropriate responses to each of the standard installation prompts.

The installation prompts are standard pkgadd -d prompts regarding which
packages to install and how to process scripts (with superuser privileges).

5. When the installation procedure is complete, reboot to activate the server
daemons.

Diagnostic Reporter software is installed in the following directories:

■ /opt/SUNWsscs/ssdiagreporterd
■ /opt/SUNWsscs/ssdiagreporterui

# cd /cdrom/cdrom0/product/solaris

# pkgadd -d SUNWscsa

# pkgadd -d SUNWscui
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Microsoft Windows NT/2000 Operating System

Note – You must install the Configuration Service Agent before installing the
Diagnostic Reporter Agent and Config Tool.

Note – Make sure Java runtime environment 1.2 or higher is installed on the
computer or workstation on which you are installing Configuration Service.

1. To make sure the software installation utility functions optimally, close all open
Microsoft Windows applications.

1. Insert the Sun StorEdge Professional Storage Manager CD and go to the
\product\windows directory.

2. Either double-click or copy SUNWscsa.exe to a local drive, and proceed through
the series of prompts and windows to complete the installation of the agent
software.

3. On the Welcome window, click Next.

4. On the Choose Destination Location window, install the default folder, C:
Program Files\Sun\ssdgrpt, and click Next.

To install to a different folder, click Browse, select another folder, and click Next.

5. When the next window is displayed, click Full Installation and click Next.

■ Full Installation – installs all three software components (Service, Config Tool, and
Mail Receiver Tool)

■ Service Installation – installs only the background Service software; note that the
Service function can be configured remotely from the Config Tool

■ UI Installation – installs only the Config and Mail Receiver Tools (not the Service)

Note – If you are not the administrator or you did not install the Java runtime
environment, you will see error messages that the Diagnostic Reporter Service is not
running or is failing, and will not be able to complete installation.

6. After the components are installed, click Finish to complete the installation.
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▼ To Manually Start/Stop the Diagnostic Reporter
Agent

Solaris Operating Environment

Note – To start the daemons, you must have superuser privileges and you must be
using the Bourne shell.

1. To start the Diagnostic Reporter Agent, type

2. To stop the Diagnostic Reporter Agent, type

Microsoft Windows NT Operating System
To start the Diagnostic Reporter Agent software on the server, you must either
reboot the server or start the Diagnostic Reporter Service under Settings → Control
Panel → Services.

To stop the Configuration Service Agents, go to Settings → Control Panel → Services
and select the agent you want to stop and click Stop.

Microsoft Windows 2000 Operating System
1. To start the Diagnostic Reporter Agent software on the server, you must click Start

→ Administrative Services → Computer Management.

2. Click Services & Applications.

3. Select the Diagnostic Reporter Server and right-click the service you want to start
or stop.

Alternatively, you can use Start → Settings → Control Panel → Admin Tools →
Computer Management.

# /etc/init.d/ssdgrptd start

# /etc/init.d/ssdgrptd stop
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Setting Up the Diagnostic Reporter
Configuration
Only one instance of the Diagnostic Reporter Config utility can be open at a time.
The configuration information is saved to a file named ssdgrpt_cfg.xml.

Note – To implement any configuration change to a Diagnostic Reporter service,
you must be connected to a Diagnostic Reporter server and you must click Save
Configuration after you have completed the changes.

▼ To Set Up the Configuration
1. Start Diagnostic Reporter.

On a Solaris operating environment, type

On a Microsoft Windows NT/2000 operating system, select Start → Programs → Sun
StorEdge 3000 Family → Diagnostic Reporter Config Tool.

If you have previously configured and connected to one Diagnostic Reporter
daemon, the Config Tool automatically connects to the server that you last used.

2. For the first-time installation, you must first set up a connection between the
Config Tool and a server where a Diagnostic Reporter daemon is running.

a. To create a server connection, select Servers → Server List Setup.

b. In the Server List Configure dialog box, click Add and type the Diagnostic
Reporter daemon server name and IP address.

c. Keep the default port number (which is displayed automatically and is used by
the Diagnostic Reporter Config Tool to communicate with the Diagnostic
Reporter daemon).

d. Type the ssconfig login password for the server.

This is the same login password that was set when you installed Configuration
Service. If this password has not already been set, you must set it before
continuing. See “Users and Passwords” on page 13 for details.

# ssdgrptui
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e. Click Apply.

The Diagnostic Reporter server Name and IP Address are displayed in the Server
List. The Diagnostic Reporter Config Tool can access multiple servers, but can only
connect to one server and one Diagnostic Reporter service at a time.

If you do not specify a password for each server, you are asked for a password each
time you reconnect to a server.

3. Click Close.

4. To connect to a Diagnostic Reporter server, select Servers → Connect Servers, and
then select the desired server from the list that is displayed.
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5. Click the Basic Information tab and provide the information used for the email
server and provided with event messages.

■ System ID and Location – descriptive fields for the server where the Diagnostic
Reporter service resides.

■ Customer and Contact Information – provides information to be attached to the
event emails, which is helpful when the event messages are sent to multiple email
locations.

■ SMTP Server – the IP address or domain name for the server that Diagnostic
Reporter uses to send email. If you provide an incorrect address (or domain
name), Diagnostic Reporter cannot find it and mail messages are not sent. If the
SMTP server needs authorization, you must provide the necessary information to
log in to the SMTP server.

6. You must configure the From field using the following command

name@domain
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7. To specify the trap messages that are to be reported, select the Trap Information
tab, and click Add.

In the Add one Trap dialog box, select the desired parameters.
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As a minimum, select a trap event, specify the minimum interval between mails, and
provide one email address. To provide multiple email addresses, separate each
address with a space, comma, or semicolon.

TABLE 10-1 Trap Information Parameters

Parameter Values/Description

Content Specifies the information to include in the email body. Values:
all/ event /log /report /hosteventlog

If you select an event trap and the Minimum interval is 0 or *, the
Content must be Event.
To select periodic trap, Content cannot be Event.

Trap type Select trap type Property of event type trap or Property of periodic
trap.

Minimum interval
between mails

For the interval between emails for an event type trap, specify the
desired values:
* - reports all events as they occur
0 - reports all events as they occur
HH[:MM] - sets a specific time of day in hour:minute format, for
reporting the last event message delivered during the time interval,
using a 24-hour clock. Example: 16:30 = 4:30PM

Active trap events An event trap is activated by an event, with a choice of any three
kinds of event.

Periodic trap type Use crontab format to define when to send emails:
minute (0-59)
hour (0-23)
day of month (1-31)
month (1-12)
day of week (0-6 with 0=Sunday)

Checkbox – use
encrypt

If checked, sends encrypted emails. The encrypt key is an identifier
(optional) that is displayed when you download event messages.

Checkbox – pager
enabled

Checkbox – no
content

To send mail to a pager-enabled mail address, check this box and
specify the mail subject in Subject for Pager. If you do not want this
mail to include any content, select no content.

mail to: Define the email address for mail. You can specify several mail
addresses, separated by “ “, “,”, “;”.
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In the following example, all events were selected and sent to support@sun.com.

8. Diagnostic Reporter can connect to multiple Configuration Service Agents at the
same time.

To connect to one or more Configuration Service Agents, click the SSCS Agent
Information tab and click Add.
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For each Configuration Service Agent, you must specify the Agent Name, Agent IP
Address, Port and Password for the ssconfig user accessing that agent.

■ Agent Name – name that is included in emails. You can use the real machine host
name or an alias.

■ Port – the Configuration Service Agent listener port number. Keep the default
value 1270 (other valid values are 1271, 1272, and 1273). If you cannot connect to
the agent, change the value and try again.

■ Password – the password for the ssconfig user. Before the Diagnostic Reporter
daemon can connect to the Configuration Service Agent, the Service must provide
the correct password for the ssconfig user.

After you have provided the agent parameters, click Discard to cancel changes, or
click Apply to save the configuration. Each agent listed in the agent list sends the
specified event messages to the Diagnostic Reporter Service where this configuration
has been saved.

9. After you create or edit any configuration, click Save Configuration in the main
window to save the configuration to the Diagnostic Reporter.

The Diagnostic Reporter Service restarts to read the configuration file again.

10. To see the current status of each agent at a specific moment, click Probe
Configuration Service Agent in the main window.

In the Agent Information window, the colored status buttons indicate if the
Diagnostic Reporter Service is active with the Configuration Service Agent on each
agent server.

■ Red – Diagnostic Reporter cannot connect to the Configuration Service Agent.

■ Yellow – Diagnostic Reporter is seeking the Configuration Service Agent.

■ Green – Diagnostic Reporter is connected to the Configuration Service Agent.

■ None – The Configuration Service Agent information has not been saved.

The color and text of this button can change every 20 seconds.
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▼ To Set Up and Use the Report Tool
On systems running the Solaris operating environment, Diagnostic Reporter’s
Report capability enables you to generate a report that contains the configuration of
all locally attached Sun StorEdge arrays.

1. Configure the local host to monitor the locally attached Sun StorEdge arrays.

a. From the main Configuration Service window, click Array Administration →
Controller Assignment.

The Assign Server to Manage a RAID Controller window is displayed.

b. Select a server from the Server to manage this controller list and click Apply.

This enables the selected server to manage an array controller. It also disables all
other servers listed from managing the same array.

c. Click Close to close the view.

2. .Add the local server to the ssdgrcli.cfg file by typing

You are prompted for the ssconfig password.

3. Run the following command to generate the report

▼ To Set Up and Use the Mail Receiver Tool
The Mail Receiver Tool is optional and can be used in place of your regular email
application. It can be used to receive and forward encrypted and unencrypted email.

1. Start the Mail Receiver Tool.

On a Solaris operating environment, type

On a Microsoft Windows NT/2000 operating system, select Start → Programs → Sun
StorEdge 3000 Family → Diagnostic Reporter Mail Receiver Tool.

# /usr/sbin/ssdgrptd -c -s @ip address

# /usr/sbin/ssdgrptd -r

# ssdgrptpop
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2. In the POP3 Mail Receiver window, identify the UserName, Password, and email
server IP address (POP3 Server) where the event messages are sent.

If needed, specify the appropriate SMTP information.

a. To receive event messages, click Connect.

b. If decryption is necessary, click Decrypt File.

c. For event information or alerts that need to be sent to additional staff, click
Forward All or Forward Selected and specify the destination address(es).
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▼ To Uninstall Diagnostic Reporter

Solaris Operating Environment
Use the pkgrm command followed by the Diagnostic Reporter package you want to
uninstall, SUNWscsa (agent) or SUNWscui (Config Tool).

Microsoft Windows NT/2000 Operating
Environment
Use the Windows Add/Remove Programs utility to remove Diagnostic Reporter
from a Windows Console.

1. Go to Start → Settings → Control Panel → Add/Remove Programs.

2. Select the Diagnostic Reporter application and select Add/Remove.

Respond appropriately to the Windows prompts.

# pkgrm SUNWscsa

# pkgrm SUNWscui
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APPENDIX A

RAID Basics

This appendix provides background information about RAID including a discussion
on SCSI channel, logical drive, and LUN.

SCSI Channel, Logical Drive, and LUN
(Logical Unit)
A logical drive is simply an array of independent physical drives. The logical drive
appears to the host the same as a local hard disk drive does.

A logical volume is composed of one or several logical drives. The member logical
drives can be composed of the same RAID level or each of different RAID levels. The
logical volume can be divided into a maximum of 8 partitions. During operation, the
host sees a non-partitioned logical volume or a partition of a logical volume as one
single physical drive.

A local spare drive is a standby drive assigned to serve one specified logical drive.
When a member drive of this specified logical drive fails, the Local Spare Drive
becomes a member drive and automatically starts to rebuild.

A global spare drive does not only serve one specified logical drive. When a member
drive from any of the logical drives fail, the Global Spare Drive joins that logical
drive and automatically starts to rebuild.

A SCSI channel (SCSI bus) can connect up to 15 devices (excluding the controller
itself) when the Wide function is enabled (16-bit SCSI). Fibre channel enables the
connectivity of up to 125 devices in a loop. Each device has one unique SCSI ID.
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The following figure illustrates this idea. If you file documents into a cabinet, you
must put the document into one of the drawers. From a SCSI point of view, a SCSI
ID is like a cabinet, and the drawers are the LUNs (Logical Units). Each SCSI ID
enables up to 32 LUNs. Data can be stored into one of the LUNs of the SCSI ID. Most
SCSI host adapters treat a LUN like another SCSI device.

FIGURE A-1 SCSI ID/LUNs

Examples of Drives/Partitions/LUNs

FIGURE A-2 Connecting Drives

The physical connection of a RAID controller is similar to the one shown in the
previous figure. Install the controller into an enclosure canister, and then connect
drives to the controller's SCSI/Fibre channels.

A Logical Drive consists of a group of SCSI or Fibre Channel drives. Physical drives
in one logical drive do not have to come from the same SCSI channel. Also, each
logical drive can be configured a different RAID level.
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A drive can be assigned as the Local Spare Drive to one specified logical drive, or as
a Global Spare Drive. A spare is not available for logical drives that has no data
redundancy (NRAID and RAID 0).

FIGURE A-3 Allocation of drives in Logical Drive Configurations

You can divide a logical drive or logical volume into several partitions, or use the
entire logical drive as single partition.
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FIGURE A-4 Partitions in Logical Drive Configurations

Map each partition to LUNs under host SCSI IDs or IDs on host channels. Each SCSI
ID/LUN acts as one individual hard drive to the host computer.
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FIGURE A-5 Mapping Partitions to Host ID/LUNs

FIGURE A-6 Mapping Partitions to LUNs under an ID
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APPENDIX B

Monitoring JBODs

This appendix explains how to monitor and download firmware to a standalone
JBOD. Note that not all of the Sun StorEdge Array functionality is supported for
JBODs. Procedures covered in this appendix include the following:

■ “To Enable JBOD Support” on page 185
■ “To View Component and Alarm Characteristics” on page 187
■ “To Upgrade Firmware on Hard Drives” on page 188
■ “To Upgrade Firmware on SAF-TE Devices” on page 189
■ “To Replace a Failed Drive” on page 190

▼ To Enable JBOD Support
To monitor peripheral device condition and events of a JBOD, you first need to
enable JBOD support.

1. Select View → Agent Options Management.

The Agent Options Management window is displayed.

2. Select the Enable JBOD Support check box.

3. To immediately display the JBOD in the main Configuration Service window, you
need to probe for new inventory. Select View → View Server and click Probe.

4. Click OK.

The JBOD is displayed in the main Configuration Service window.

In a single bus configuration, both ports of the JBOD are connected to one HBA on
the server as shown in the following example.
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In a dual bus configuration, each port is connected to its own HBA as shown in the
following example.

Note – In a dual bus configuration, if each port is connected to different servers,
Configuration Service can only monitor the JBOD from the server connected to port
B.
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▼ To View Component and Alarm Characteristics
The View Enclosure window displays the component and alarm characteristics of a
JBOD.

1. Select the EMU icon .

2. Select View → View Enclosure.

To display FRU ID information, click View FRU.
Appendix B Monitoring JBODs 187



Downloading Firmware for Devices
This option enables you to upgrade the firmware on hard drives and SAF-TE devices
on the JBOD.

▼ To Upgrade Firmware on Hard Drives
1. Select any JBOD component.

2. Select Array Administration → Download FW for Devices.

3. Click the Download FW for Disks tab.

4. Select the drives that you want to download the new firmware to from Available
Disks and click Add.

If there are logical drives that you want to remove, select them from Selected Disks
and click Remove.
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5. Click Browse and locate the download firmware file. Select it, click Open, and
click OK.

The firmware starts to download.

6. When the progress reaches 100%, click OK.

7. To update Configuration Service, select View → View Server.

8. Click Probe and click OK.

9. To verify that the firmware has downloaded successfully, select View → View
Physical Drive, and make sure the firmware version has changed in the Product
Revision field.

▼ To Upgrade Firmware on SAF-TE Devices
1. Select any JBOD component.

2. Select Array Administration → Download FW for Devices.

3. Click the Download FW for SAFTE Devices tab.

4. To add a device, select it from Available SAF-TE Devices and click Add.

To remove a device, select it from Selected SAF-TE Devices and click Remove.
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5. Click Browse and locate the download firmware file. Select it, click Open, and
click OK.

The firmware starts to download.

The Sun StorEdge array starts beeping and the LEDs start blinking at around 70%.

6. When the progress reaches 100%, click OK.

7. To update Configuration Service, select View → View Server, and click Probe.

8. Click OK.

9. To verify that the firmware has downloaded successfully, select View → View
Enclosure, and make sure the firmware version has changed in the Firmware Rev
field.

▼ To Replace a Failed Drive
A drive failure is indicated by a red device status symbol . After replacing a
failed drive, perform the following steps.

Solaris Operating Environment
1. If the drive comes back online automatically (that is, the red device status symbol

disappears), run the command

2. Run the command

3. If the drive does not come back online automatically (that is, the red device status
symbol does not disappear), perform a reconfiguration reboot by running the
command

# devfsadm

# format

# reboot -- -r
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Microsoft Windows NT/2000 Operating System
1. Install the new drive according to the instructions in the Sun StorEdge 3310 SCSI

Array Installation, Operation, and Service Manual.

2. Select View → View Server, and click Rescan.

3. To verify that Configuration Service recognizes the new drive, select it on the
Configuration Service main window.

4. Select View → View Physical Drive, and verify the information.
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APPENDIX C

Using the Cluster Configuration

If you are using Microsoft Windows NT, Configuration Service can monitor shared
SCSI storage. This section covers the following topics:

■ “Planning the Cluster Configuration” on page 193
■ “Cluster Configuration Requirements” on page 194
■ “To Set Up Cluster Configuration” on page 194

A cluster configuration must be set up with the appropriate hardware first, and it
also requires Microsoft Windows NT Server, Enterprise Edition, with Service Pack 3
or 4, and Microsoft Cluster Server (MSCS) software.

If you are planning to set up a cluster configuration, make sure to read this chapter.

Planning the Cluster Configuration
Before you set up a cluster configuration, you need to determine what type of
configuration you want because it can make a difference in how you configure the
storage initially in Configuration Service.

There are two main types of cluster configuration:

■ A hot standby server cluster where all of the LUNs belong to one of the two
servers in the cluster. If the server owning the LUNs fails, the LUNs are moved to
the second server, which has been idle to this point. A minimum of two LUNs are
required in this configuration.

■ A load balanced cluster, where some LUNs are maintained on one server and
some LUNs are maintained on the other server. Both servers process data at the
same time, but they are processing I/O on different LUNs.
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A minimum of three LUNs must be defined. This enables one small LUN to be
established for quorum disk use and a large LUN to be used on each server in the
cluster. The quorum disk maintains the cluster configuration data necessary to
recover the cluster in the event of a server failure.

Cluster Configuration Requirements
When you are installing the Microsoft Cluster Server software, identify the disk to be
used for the quorum disk, which maintains cluster information.

In a cluster configuration, Configuration Service runs on only one server at a time,
the server that has the quorum disk. If the server running with Configuration
Service malfunctions, the Cluster Administrator automatically changes the first
server’s disk load to the second server and start the Configuration Service services
on that server.

In a two-server cluster configuration, the cluster itself, with its own IP address,
becomes the managed server on Configuration Service’s Managed Servers list. Add
the cluster to the Managed Servers list as the last step in setting up the cluster to
work with Configuration Service.

▼ To Set Up Cluster Configuration
Following is an overview of the steps needed to set up a Sun StorEdge array in a
cluster configuration with two host servers.

1. Set up the servers.

a. Set up the two servers, each with a PCI bus and a boot disk that is not a part of
the shared SCSI storage.

b. Install a host adapter card such as Ultra-Wide, differential host adapter, in each
server and set a unique SI ID for each host adapter on the shared SCSI bus.

c. Install two network adapter cards on each server.

d. Install the Microsoft Windows NT Server, Enterprise Edition, software and
Windows NT Service Pack 3 or later on the boot disk of each server.

2. Install the dual active-active storage subsystem and connect it to both host
adapters.

Refer to the supplied documentation for installation steps.
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3. Install the Configuration Service Agent on each server.

a. Stop Configuration Service services on one server before installing it on the
other server.

b. Ensure that the Configuration Service service is running on a server that has
access to a host LUN mapped on logical drive assigned to primary controller.

c. See the appropriate installation chapter for specific steps for installing the
agent.

After installing the agent, you do not need to reboot. However, once the agent is
installed, be sure to stop Configuration Service services on of the servers.

Note – In the next few steps, you will work with one server only as an example.

4. Install the Configuration Service Console software.

You can install the Configuration Service Console on one of the servers or on any
computer on the network where the servers reside. Configuration Service enables
you to configure and monitor the Sun StorEdge array remotely. See the appropriate
installation chapter for detailed steps.

5. Add the server that has started Configuration Service services to the Configuration
Service Console’s Managed Servers list (see “To Add Servers” on page 30).

Be sure to select Auto Discovery and add the ssmon password.

6. Use the Configuration Service Console software to verify and configure the
Configuration Service storage on the active server and then reboot that server.

Your storage array might already be preconfigured on the dual active-active storage
subsystem. You need to look at the configuration in the Configuration Service tree
view to determine whether this is the case.

If the storage is not configured or you want to change the configuration, configure
all of the LUNs on one server. Later, after the Microsoft Cluster Server software is
installed, you can allocate the storage between the servers with Cluster
Administrator.
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7. Use NT Disk Administrator to create partitions and format the LUNs on the active
server.

a. If necessary, reassign drive letters for the disks.

Note that partitions must be formatted with NTFS.

Microsoft Windows NT sees the LUNs on the dual active-active controllers as
being on both servers in the cluster. You can create partitions and logical drives
on only one server. Later, after MSCS is installed, you can use the Cluster
Administrator to apportion the storage between the two servers.

The drive letters for the shared SCSI storage for the two servers must be the same.
If there is an additional CD-ROM drive or external hard disk on one server and
not on the other, you might need to reassign the drive letters for the shared
storage. After this step, check them on the other server to make sure they are the
same.

b. Write down the drive letters assigned to the shared storage.

8. Access the second server.

a. Start Disk Administrator and make sure that the second server has the same
drive letters as the first.

If it does not, reassign the drive letters so that they are consistent on both servers.

9. Shut down the second server.

10. Install the Microsoft Cluster Server software on the first server and reboot.

a. After MSCS is installed, start Cluster Administrator and make sure that it can
see the cluster.

11. Access the second server, install MSCS on that server by joining it to the first, and
reboot.

a. After installing MSCS on the second server, reboot the second server and verify
in Cluster Administrator that both servers are included in the cluster.

12. Adjust the disk groups in the Cluster Administrator.

Make sure that the quorum disk and the other disks, if any, are together in one disk
group under the first server where you originally configured the storage. Refer to
the Microsoft Cluster Service documentation for details to perform this step.

Note – Once you put the two LUNs in the same disk group, you have an empty
disk group that you can delete.
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13. Add the Configuration Service services to the group that has the quorum disk on
the first server.

a. On both servers, stop each of the three Configuration Service services,
Configuration Service Startup, Configuration Service Monitor, and
Configuration Service Server, and set them to manual.

b. Use Cluster Administrator to install each Configuration Service service as a
resource to the group that has the quorum disk.

For each service, enter it in the order listed below and type its name in the format
indicated (with the two words run together). After each service is installed, bring
the service online to start it on the active server.

Enter the services as generic services. You are asked to indicate the dependencies
for each resource. The dependencies in the group are as follows:

■ Disk associated with the quorum disk
■ Other disk, if any to be added to this group
■ Configuration ServiceStartup
■ Configuration ServiceMonitor
■ Configuration ServiceServer

Configuration ServiceStartup is dependent on the two disks that are already in
the group. Configuration ServiceMonitor is dependent on Configuration Service
Startup, and Configuration ServiceServer is dependent on Configuration Service
Monitor.

14. For the two cluster servers to be displayed as one icon in Configuration Service
under the cluster IP address, edit CLUSTER.TXT.

The file is located in the same directory as the Configuration Service Console files. It
is on the system disk of the computer where the Configuration Service Console is
installed. If Drive C is the system disk, the path is:

C:\Program Files\Sun\sscs
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The following text shows the contents of the file:

15. Edit the last line of the file to insert the IP address of the cluster and then the IP
addresses of the two servers that make up the cluster.

a. Remove the number symbol (#).

16. Start the Configuration Service Console and remove the first server from the
Managed Servers list, and add the cluster as a server to the list.

a. Access the Server List Setup function. See “To Add Servers” on page 30.

Be sure to select Auto Discovery and add the ssmon password. If you type in the
cluster name, Configuration Service supplies the IP address if your network has
DNS.

At this point, the cluster configuration is properly configured to work with
Configuration Service. If the server that has the Configuration Service services
running on it malfunctions, its disk groups are transferred to the second server
and the Cluster Administrator automatically starts the Configuration Service
services on that server.

Note – When one server fails, it can take as long as 15 minutes for the cluster icon
in the Configuration Service Console to turn from purple to gray and perhaps
another 10 minutes before it goes back to purple again.

If you want to have a load balanced configuration with some of the storage
running on the other server, you need to use the Cluster Administrator to move
one or more disk groups to the other server.

#Edit this file to map the NT cluster IP address to several
#servers constituting the cluster.
#The format of the entry is:
#<Cluster IP Address>=<server1 IP Address>:<server2 IP Address>
#The IP address must be in dot form.
#Example: If the cluster IP address is 151.239.130.70 and the
#IP addresses of individual servers are 151.239.130.71 and
#151.239.130.72,the entry would be:
# 151.239.130.70=151.239.130.71:151.239.130.72
#
#IMPORTANT NOTE:
#Use only the Cluster IP address to configure an NT cluster
#server on the Configuration Service console.
#
#151.239.130.70=151.239.130.71:151.239.130.72
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APPENDIX D

Email and SNMP

Configuration Service has full event monitoring and email notification capabilities.
Configuration Service Consoles can send SMTP email messages to a specified list of
email addresses. Some email systems, like Microsoft Exchange, can be configured or
programmed with scripts to page administration personnel based on events. Some
paging services also support sending these email messages to a pager.

Configuration Service Agents place events in the operating environment’s error logs.
Configuration Service Agents can also send SNMP traps about mass storage events
to an enterprise management console, such as HP OpenView.

This appendix explains how to set up Configuration Service Consoles to send email
messages. It also explains how to configure servers to send traps to SNMP
management consoles, describes the trap format, and gives background information
about SNMP. An additional method for sending SNMP traps that does not require
Configuration Service is also discussed. Topics covered in this chapter include:

■ “To Send Email Messages for Each Server” on page 200
■ “Setting Up Servers to Send Traps” on page 202
■ “To Check the Community String” on page 203
■ “To Specify the Trap Recipient” on page 204
■ “To Set Up Solaris Servers” on page 205
■ “How SNMP Works” on page 206
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▼ To Send Email Messages for Each Server
Configure the console to send email messages for each managed server through the
Server List Setup function.

1. Select File → Server List Setup.

The Server Setup window is displayed.

2. Click Add.

If the server has already been added, you need to move it to the Available Servers
list and click Edit.

The Add Server window or Edit Server window is displayed. The two windows
have the same fields.
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3. If you have not already added the server, fill in the information about the
Properties tab.

For detailed information see “Add a server:” on page 31.

4. To send event messages using email, select the Mailing Lists tab.

The Add Server window is displayed with Mailing Lists selected.

a. For each user, type an email address in the Mail Address field.

b. In the Severity list box, scroll through the list and select the desired one.

c. Click Add to List.

To delete a user from the list, select the mail address and click Delete from List.

d. Indicate the mail server. Click Setup Mail Server.

The Mail Server Setup window is displayed.
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Type the IP address or name of the Simple Mail Transport Protocol (SMTP) mail
server that delivers the email messages to the destination addresses specified
earlier.

e. Click OK when you are satisfied with the information about the Mail Server
window.

The Add Server or Edit Server window is displayed.

5. Click OK when you are satisfied with the information about the Add Server or
Edit Server window.

The Server Setup window is displayed.

6. If you want to add additional servers, repeat Steps 2 through 5 for each server.

7. If necessary, move the server or servers you want this console to control to the
Managed Servers list.

If you are editing a server, you must move it back to the Available Servers list.

8. Click OK to return to the main Configuration Service window.

Setting Up Servers to Send Traps
If you have an enterprise management console on your network — for example, HP
OpenView or IBM NetView, you can configure Configuration Service servers to send
traps about events to the console. This section describes the configuration steps
needed.

Note – You need to follow the instructions in this section only if you want
Configuration Service to send SNMP traps to other enterprise management consoles.

Caution – If HP OpenView is installed on the same server that you are setting up to
send traps, to avoid initialization errors, you need to reconfigure the system
resources. For instructions on reconfiguring system resources, see the
troubleshooting item “Symptom: HP OpenView won’t install or the trap daemon
won’t start.” on page 215.
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Microsoft Windows NT Servers

To configure a Microsoft Windows NT server to send SNMP traps to one or more
enterprise management consoles, you need to configure each SNMP service on the
server to make sure that:

■ The server lists the community string or community name of the enterprise
management console.

■ The server lists the enterprise management console as the recipient of traps from
the Microsoft Windows NT agents software.

▼ To Check the Community String
You can use the default community name or community string of public. However,
choosing a community name other than public provides more security because it
limits the communication to only those computers that have the specified
community string.

To set the community string for Microsoft Windows NT 4.0:

1. In the Control Panel window, double-click the Network icon, and then click the
Services tab if it is not already selected.

In the Network Services list, scroll to the SNMP service, click once to select it, and
then click Properties.

The Microsoft SNMP Properties window is displayed.

Note – If you do not have the SNMP service installed, you can install it by clicking
Add in the Network window. The Select Network Service window is displayed,
from which you can select SNMP Service. You need to insert the Microsoft Windows
NT 4.0 CD to enable the computer to copy the necessary files for the SNMP service.

2. Click the Security tab in the Microsoft SNMP Properties window to display the
Security settings.

3. Make sure that the community name or community string that you want to use for
the server is specified in the Accepted Community Names list.

If the name is not already on the list, click Add to display the Service Configuration
window. Type the new name in the entry field and click Add in that window. The
Security tab is displayed with the new name on the Accepted Community Names
list.

Note – Community names or community strings are case-sensitive.
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4. (Optional) If desired, change the default setting of Accept SNMP Packets from
Any Host to Only Accept SNMP Packets from These Hosts and add the network
address of the enterprise management computer that receives the traps from the
Configuration Service Agent on the server.

Using this setting provides more security because it lets you specify the computer or
computers from which the Microsoft Windows NT agents accept information.

To add the network address of the computer with Configuration Service
management console software to the lower list box, click Add to access the Security
Configuration window. Type the IP address in the Entry box and click Add in that
window. The Security tab reappears with the Configuration Service management
console computer’s address.

5. Click OK.

▼ To Specify the Trap Recipient
In this procedure, you are listing the enterprise management console as a recipient of
traps from the server.

Note – For the procedure, you need the IP address of the enterprise management
console that receives the traps. The procedure also requires the same community
name as specified in the preceding sections.

The steps for specifying an enterprise management console computer as the
recipient of the agent traps are as follows.

1. Click the Traps tab of the Microsoft SNMP Properties window to display the
Traps settings.

2. Make sure the same community name is specified as the community name that
was indicated in the Security tab earlier.

If you need to correct the community name, type the name in the Community Name
field and click Add. If another name is already in the entry field, it is retained after
you type over it. To remove a name, select it and click Remove.

3. Add the IP address of the enterprise management console in the Trap Destinations
list.

a. Click Add.

The Service Configuration window is displayed.

b. Type the IP address in the Entry field and click Add.

The Traps tab is displayed with the new network address in the Trap Destinations
list.
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c. Type each IP address in the following format: AAA.BBB.CCC.DDD

You do not need to type leading zeros. An example of an appropriate address is:

192.168.100.1

4. If you want to send optional Configuration Service traps to another enterprise
management console, type the network address of that management workstation.

If you have more than one enterprise management console, each one needs to have
its address indicated here.

5. Click OK to confirm your settings.

6. Click Close to leave the Network window.

7. Exit Microsoft Windows NT and restart the server.

If you are planning to install Configuration Service, you do not have to reboot until
after you install the software.

▼ To Set Up Solaris Servers
With Configuration Service for systems running the Solaris operating environment
(SUNWscsd), you can generate SNMP version 1 traps through an interface to an
SNMP trap daemon called sstrapd. By default, this daemon does not start
automatically during the boot process. The following steps describe how to enable
trap processing.

1. Create the file /etc/sstrapd.conf using any standard text editor.

This file contains the name or the IP address of the SNMP manager console or
consoles. If there is more than one console, list them on separate lines.

2. Edit the file /etc/init.d/ssagent and remove the comment marks from the
SNMP-related start section. These lines are marked by an initial double hash
mark (##).

3. Save the file after these edits.

The sstrapd daemon starts at the next boot or can be started immediately by
running the following command

This starts the sstrapd daemon as well as the other two Configuration Service
daemons if they are not currently running. Only one instance of each daemon is
running at this point, whether or not any daemons were previously running.

/etc/init.d/ssagent start
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How SNMP Works
Simple Network Management Protocol (SNMP) is one of the most widely used
protocols for network management. It does what its name says—it manages network
devices in a relatively simple manner. SNMP is a simple, unacknowledged,
connectionless protocol.

SNMP was originally developed to work under the umbrella of the Internet suite of
protocols, primarily in TCP/IP (Transmission Control Protocol/Internet Protocol)
transport protocols. Since then, SNMP has been implemented to work over other
common transport protocols, such as Novell’s IPX/SPX (Internet Packet
Exchange/Sequenced Packet Exchange).

SNMP Trap Messages
Configuration Service Agents use SNMP to send information to enterprise
management systems.

Once a server is configured to send traps, Configuration Service event information
flows to that system.

Configuration Service’s trap messages contain the following information:

■ OID (Object Identifier) 1.3.6.1.4.1.2294.1.2

■ Event Date (MM, DD,YY, such as 01,22,98)

■ Event Time (HH:MM:SS, such as 15:07:23)

■ Server Address and Name (IP Address Name, such as 192.187.249.187
Administration)

■ Card Name

■ Event Severity (Informational, Warning, Critical)

■ The text message

The information that is displayed and its format are dependent on the SNMP
management console you are using.

The file RST_OID.MIB must be loaded into the enterprise management console for
traps to be received. On Solaris OEs, this file is located in
/opt/sun/SUNWsscs/ssagent. On Microsoft Windows, this file is located in
\Program Files\Sun\ssagent.
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Agents and Managers
The SNMP software model consists of agents and managers. An agent is the
software that enables variables in the managed device to be monitored. The agent
software is either embedded in the device that is managed or running on a computer
to which the device is connected.

The manager or management console is the network monitoring software that uses
SNMP to send requests to the agents about the variables. The manager polls the
agents periodically because the values of variables change. SNMP managers
typically analyze the data received from the agents and make it available to the user
in a graphical display. The data can be stored in a database for historical and trend
analysis.

In addition to responding to the SNMP manager’s requests, agents can send
unsolicited notifications or traps to the management station. This is similar to
interrupts in conventional software.

Management consoles can take various actions in response to a trap. Usually, traps
are logged, and the information in them is forwarded through a notification scheme
to the interested user. Traps can also cause the SNMP manager to initiate further
action, such as querying the agent with more requests to find out the current status
of the network entity or launching an application.

Management Information Base (MIB)
On a network, each device instrumented by SNMP agents has one or more variables
or objects associated with it. An example of a typical variable might be one that
keeps track of the name of the device. These variables or objects are described in a
text file called Management Information Base (MIB). A MIB is a precise textual
definition of variables being managed. The procedures for defining a MIB have been
established by the Internet Engineering Task Force (IETF) of the International
Standards Organization (ISO).

SNMP Objects
Some variables for network management are common to all LAN network devices.
Many of these variables have been standardized and are referred to as MIB-II
variables and MIB-II extensions. The IETF has also defined the procedures for MIBs
that are not in a standard MIB-II category. These variables are listed in private
enterprise MIBs.
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Configuration Service variables are listed under the Configuration Service entry of
the private enterprise MIB. For example, the object ID 1.3.6.1.4.1.2294.1.2 refers to an
object ID (or OID) of a variable for keeping track of the agent version under one of
Configuration Service’s MIBs.

The chart in FIGURE D-1 shows how the OID was derived. The check marks indicate
the nodes in the OID. In a MIB, the data of a specific variable or object resides below
its OID.

Sun’s tree node is 2294. Every private enterprise wanting to develop agents to
recognize its own devices can apply to the IETF for its own tree node.

SNMP Request Types
The SNMP operations that support accessing MIB data are Get, GetNext, and Set.
Get retrieves a scalar value from a table entry field value, given an index value.
GetNext is used to traverse the instances of table entries, with each command
returning the next sequential value in the column (or field) of interest. The Set
operation is used to create or change the value of a MIB variable.

SNMP Security
Setting values raises the issue of security. SNMP V1 (version 1) has a simple security
scheme. Each protocol data unit (PDU) contains a community string, which is like a
combination of user name and password. Each agent can be configured for a
particular community string. An agent does not respond to a request sent to it except
when the community string in the request PDU matches the community string in its
own configuration.
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FIGURE D-1 Object Identifier of a MIB Variable
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▼ To Send SNMP Traps Without Using
Configuration Service
The following is an alternative method for sending SNMP traps that does not require
Configuration Service.

The Sun StorEdge array can send SNMP traps about mass storage events to an
enterprise management console, such as HP OpenView. The following configuration
does not require that the Configuration Service Agent be installed in order to send
SNMP traps.

1. Open a text editor.

2. Type the following information, replacing the variables as they apply to your
network:

[SNMP_TRAP]
ENABLED=1
RECEIVER1=123.123.123.123

[EMAIL]
ENABLED=1
SUBJECT=RAID Event
SENDER_MAIL_BOX=someone@somecompany.com
SMTP_SERVER=123.123.123.123
RECEIVER1=somebody@somecompany.com

3. Save the file using the following name agent.ini.

4. FTP from your workstation to the Sun StorEdge array.

5. Type the user name of root and press Return

6. When prompted for a password, press Return.

If you have previously specified a password for the controller, you need to type that
password when prompted.

7. Once logged in, change to the /cfg directory.

8. Put the file from your workstation into the /cfg directory.

9. Quit the FTP session.

10. Reset the controllers through which ever method you are using to manage the Sun
StorEdge array, for example, Configuration Service Console, Telnet, or terminal
session.
210  Sun StorEdge™ 3310 SCSI Configuration Service User Guide • October 2002



APPENDIX E

Troubleshooting

This chapter provides troubleshooting suggestions for the following symptoms:

■ “Symptom: When Installing Configuration Service, java -version returns a
pre 1.2.2 Java runtime environment version, but the machine has Java runtime
environment 1.2.2, 1.3, or 1.4 installed.” on page 212

■ “Symptom: A server is not responding or a server may be down.” on page 212

■ “Symptom: An IP address of a server in a DHCP environment has changed.” on
page 213

■ “Symptom: Traps are not received from a server.” on page 214

■ “Symptom: HP OpenView won’t install or the trap daemon won’t start.” on
page 215

■ “Symptom: The console does not show changes when hardware is added or
replaced.” on page 216

■ “Symptom: Environmental alarms not being reported” on page 217

■ “Symptom: The Configuration Service console appears to run slowly” on
page 217

■ “Symtom: Diagnostic Reporter Stops Working” on page 217
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Symptom: When Installing Configuration Service, java -version
returns a pre 1.2.2 Java runtime environment version, but the machine
has Java runtime environment 1.2.2, 1.3, or 1.4 installed.

1. Check the /usr directory to confirm there is a link from Java to the latest version
of Java instead of Java 1.1.

To check the Java version, type

(Solaris OE) If the link is not to the latest version of Java listed, type

where xxx is the latest version of Java.

Symptom: A server is not responding or a server may be down.

Make sure the Configuration Service services are running at the server.

1. (Solaris OE) Run the following command

The names ssmon and ssserver should both be present in the output. If they are
not, proceed to Step 2. If they are, proceed to Step 4.

(Microsoft Windows NT) Go to Settings → Control Panel → Services and verify that
SUNWscsd Monitor, SUNWscsd Server, and SUNWscsd Startup services are started.
If they are not, proceed to Step 2. If they are, proceed to Step 4.

(Microsoft Windows 2000) Go to Start → Administrative Services → Computer
Management. Click Services & Applications and verify that SUNWscsd Monitor,
SUNWscsd Server, and SUNWscsd Startup services are started. If they are not,
proceed to Step 2. If they are, proceed to Step 4.

2. (Solaris OE) Stop and start the daemons as explained in“To Start or Stop the
Configuration Service Agent” on page 12.

(Microsoft Windows NT/2000) Stop and start the services by right-clicking the service
you want to start or stop.

# cd /usr
ls | grep java

rm java
ln -s /usr/xxx /usr/java

# ps -e | grep ss
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3. If the daemons/services do not stop/start properly, do a reconfiguration reboot.

4. Make sure that the TCP/IP protocol software is loaded, and that the network card
and the network connection are working.

To test the TCP/IP connectivity at the command line, type

If you do not get a reply, there is a problem in the TCP/IP protocol services. Contact
your MIS department for assistance.

5. Make sure that the correct server name and password are specified.

If the name or password is not correct, make the correction by editing the entries.
For Solaris OEs, see “Administrative (User) Security Levels and Guidelines” on
page 13; for Windows Microsoft NT/2000, see “Administrator (User) Security Levels
and Guidelines” on page 22.

The password has to be the one established through the procedure for setting up
Configuration Service users.

■ Make sure the Configuration Service users (ssmon, ssadmin, ssconfig) were set
up properly. Be sure that Users are set up in Microsoft Windows NT with
Permissions Act as a part of the operating system and Log on as a batch job.

■ If you are using a naming service (Windows NT domains, and NIS or NIS+ in a
Solaris OE), make sure that the users have been correctly added to the naming
service.

■ If you have entered the user names in a domain under Microsoft Windows NT,
allow some time for the user names to propagate.

Symptom: An IP address of a server in a DHCP environment has
changed.

In a DHCP environment, there is a remote possibility of a server’s IP address
changing if the server has been offline for longer than three days.

In these cases, the Configuration Service Console must be notified of the new IP
address of the server because the console communicates with the server through its
IP address.

To remedy this situation, the server’s new IP address needs to be entered into the
Edit Server window of the Configuration Service Console software.

1. Select File → Server List Setup.

# ping {IP address of the server or the server name}
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2. Move the server name from the Managed Servers list to the Available Servers list.

The Edit Server window is displayed. This window shows the server name and the
IP address as it was configured.

3. Select the name of the server in the Available Servers list, and click Edit.

The Edit Server window is displayed. This window shows the server name and the
IP address as it was configured.

4. If the network address has changed, click Get IP Addr by Name.

Configuration Service searches for and displays the correct IP address if you
provided the name of the server as it is recorded by the service used by your
network. Otherwise, you must type the IP address.

If the name used for the server is not the same as the server’s network name, or if
the naming service is not yet updated, you have to type the IP address manually.

5. Once the server IP address is entered, click OK to specify the changed address and
go back to the Server List Setup window.

6. Move the server name back to the Managed Servers list.

7. Click OK to leave the Server List Setup window.

Symptom: Traps are not received from a server.
To troubleshoot why a trap from a Configuration Service server is not received on an
SNMP management workstation, such as HP OpenView, use the following steps:

1. Make sure that the SNMP service has been started on the server.

Verify that sstrapd is running by running the following command

The output includes the name sstrapd; if it does not, see “To Start or Stop the
Configuration Service Agent” on page 12 for instructions on enabling a daemon.

Under Microsoft Windows NT, go to Control Panel → Services and check whether
the SNMP service is listed and is shown as started. If it is not, install it, and then
start the service. Refer to your Microsoft Windows NT documentation for details.

2. Check that the proper target address of the enterprise management console and
the community string is set up on the server properly.

The detailed steps for the proper setup on a Microsoft Windows NT server for
sending traps to an enterprise management console are given in “Setting Up Servers
to Send Traps” on page 202.

# ps -e | grep ss
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3. Make sure that the Configuration Service MIB is compiled under the SNMP
management console.

On Solaris OEs, the RST_OID.MIB file is located in
/opt/sun/SUNWsscs/ssagent. On Microsoft Windows, this file is located in
\Program Files\Sun\ssagent. Refer to your SNMP management console
documentation (such as HP OpenView) for information about how to compile the
MIB.

4. Under Microsoft Windows NT, check the NT registry entries for Configuration
Service.

If the Configuration Service entries are absent, reinstall the Configuration Service
Agent on the server.

a. First, make sure that

HKEY_LOCAL_MACHINE SYSTEM.CurrentControlSet.Services.SNMP.
Parameters.ExtensionAgents

contains an entry for SSAGENT.

b. Second, check that

HKEY_LOCAL_MACHINE SOFTWARE.SUN, SUN StorEdge Configuration
Agent 1.0, Current Version Extension Agent.CurrentVersion

points to the extended agent program with the complete path name:

%SystemRoot%\System32\SSAGENT.DLL

c. Third, make sure that

SSAGENT.DLL

is in the %SystemRoot%\System32 directory.

Symptom: HP OpenView won’t install or the trap daemon won’t start.
If you installed HP OpenView on the same server that you set up to send SNMP
traps, there are insufficient system resources for both the trap daemon and HP
OpenView to run. Reconfigure system resources as explained in the following steps.
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1. Add the following lines to the end of /etc/system.

2. Reboot the server.

Symptom: The console does not show changes when hardware is added or
replaced.

If you add new equipment or if you replace a failed device, such as a disk drive,
tape drive, power supply, or fan, the Configuration Service Console does not always
show updated information. At times, the tree view and the other views associated
with it do not reflect the actual status of a device.

If a new device is added and you want this device to be recognized before the next
periodic scan, click Rescan in the Server View window. The server immediately
rescans for the inventory, and the console updates its server inventory and present
the result of any changes in the tree view. To ensure a timely inventory, do a manual
scan.

You might have to click Rescan more than once. When the server is in the process of
a rescan and the console sends a request for the inventory, the server sends the
console the server inventory at its last update, because it has not yet finished the
current scan.

Symptom: LG is not present on systems running the Solaris operating
environment.

If the LG is not being displayed by Configuration Service, be sure the LG is labeled
and not excluded by Configuration Service (if installed).

set shmsys:shminfo_shmmax=x2000000
set shmsys:shminfo_shmmin=1
set shmsys:shminfo_shmmni=256
set shmsys:shminfo_shmseg=256

set semsys:seminfo_semmap=256
set semsys:seminfo_semmni-=512
set semsys:seminfo_semmns=512
set semsys:seminfo_semms1=32
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Symptom: Environmental alarms not being reported

Storage enclosures with SCSI-based enclosure monitoring capabilities (such as SAF-
TE cards) send environmental alarms to the Configuration Service console. The
alarm state can be caused by a failure of a drive, fan, power supply, or battery, or by
an abnormal temperature.

If an environmental alarm occurs, you must click Reset in the View Enclosure
window to clear the alarm. You need to have configuration security privileges to
click Reset in the software.

The SAF-TE monitoring specification for these storage enclosures requires that after
an alarm occurs, subsequent environmental alarms are not generated until the alarm
has been reset.

After the alarm is reset, environmental events are again displayed in the Event Log.

Symptom: The Configuration Service console appears to run slowly

The Configuration Service console under Windows NT requires at least 10 Mbytes of
free virtual memory (physical memory plus the page file size) on the console
workstation. The console program is more responsive with larger available physical
memory, which minimizes the operating system paging of memory from physical
memory to the page file.

When the amount of memory used approaches the total available virtual memory
(physical memory plus the page file size), the excessive paging likely causes
problems, resulting in poor performance of all applications on that workstation.

Increase the physical memory and page file size to increase the overall virtual
memory. To change the page file size, select Control Panel → System, and then
choose the Performance tab in the System Properties window that is displayed. In
Windows NT, change the page file size under the Virtual Memory section of the
Performance tab window.

Symtom: Diagnostic Reporter Stops Working

If you stop receiving email messages from Diagnostic Reporter, it may no longer be
working and may need to be stopped and restarted.

(Solaris OE) There are three conditions under which Diagnostic Reporter stops
working and does not report its condition. The workaround is to stop and restart
Diagnostic Reporter.

■ If the Configuration Service Agent fails or is stopped and restarted, Diagnostic
Reporter stops working.
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■ If the Diagnostic Reporter Config Tool is running and the Diagnostic Reporter
daemon is stopped and restarted, a condition may occur whereby the Diagnostic
Reporter Config Tool can no longer communicate with the daemon.

■ If the Configuration Service Agent fails or is stopped, the Diagnostic Reporter
daemon does not detect it, stops sending email messages, and continues to show
that the Diagnostic Reporter is still connected by displaying a green status.

Stop and restart Diagnostic Reporter by typing

# /etc/init.d/ssdgrptd stop
# /etc/init.d ssdgrptd start
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APPENDIX F

Error Codes and Messages

This appendix provides a list of error codes and error and status messages.

Error Codes
Shown and described in the Event Log, an error code is an eight-character code that
consists of four fields of two characters each. The following tables describe the error
codes used in each two-character field. The format of the four fields of two
characters is:

SSMMmmEE

where

SS = the Severity Field

MM = the Major Field

mm = the Minor Field

EE = the Error Field

TABLE F-1 Severity Field

Severity Field Description

01 Critical

02 Warning

03 Informational
219



The Minor field is defined in following table. The definition of the Error Field is
dependent upon the definition of the Minor Field in which case the appropriate
Table is referenced.

TABLE F-2 Major Field

Major Field Description

01 Not Used

03 Legacy

04 RAIDCard Card message

05 JBOD (Just a bunch of disks) message

06 SSMon monitor message

07 dll/shared library message

08 SSserver message

09 HBA (Host Bus Adapter) message

0A Server Communications message

0B Sun StorEdge controller message

TABLE F-3 Minor Field

Minor Field Description

01 Unknown

02 See “Error Field: System Drive State” on page 221.

03 See “Error Field: Disk State” on page 222.

04 See “Error Field: SAF-TE State” on page 222.

05 See “Error Field: Tape State” on page 223.

06 See “Error Field: Redundancy State” on page 224.

07 See “Error Field: Internal State” on page 225.

08 See “Error Field: Device State” on page 225.

09 See “Error Field: Initialization State” on page 225.

0A See “Error Field: Invalid Client Parameter” on page 226.

0B See “Error Field: Open Transport” on page 226.

0C See “Error Field: Close Transport” on page 227.
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Error Field: System Drive State

0D See “Error Field: Memory Allocation” on page 227.

0E RaidCard fault detected.

0F See “Error Field: Transport” on page 227.

10 See “Error Field: Command” on page 228.

11 See “Error Field: Command” on page 228.

12 See “Error Field: Main Communications” on page 228.

13 See “Error Field: Communications Async” on page 229.

14 See “Error Field: Communications Security” on page 229.

15 See “Error Field: Timeout” on page 229.

16 See “Error Field: Administration” on page 229.

17 See “Error Field: Firmware” on page 230.

18 See “Error Field: System Shutdown” on page 230.

19 Dynamic Growth fault detected.

1C See “Error Field: Sun StorEdge Set Config” on page 231.

1D See “Error Field: Sun StorEdge Controller Event” on page 231.

1E See “Error Field: Sun StorEdge Drive Side Event” on page 232.

1F See “Eror Field: Sun StorEdge Host Side Event” on page 233.

20 See “Error Field: Sun StorEdge Logical Drive Event” on page 233.

23 See “Server Manage/Monitor Event Error” on page 233.

TABLE F-4 System Drive State Errors

Error Field

01 Offline

02 Degraded

03 Online

04 Unknown

05 Parity Check

06 Reconstruction

TABLE F-3 Minor Field (Continued)

Minor Field Description
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Error Field: Disk State

Error Field: SAF-TE State

07 Reconfiguration

08 Dynamic Growth

09 Nonexistent

0A Initialization

TABLE F-5 Disk State Errors

Error Field Description

01 Offline

02 Degraded

03 Online

04 Unknown

05 SMART

06 Dead

TABLE F-6 SAF-TE State Errors

Error Field Description

01 Power

02 Fan

03 Thermal

04 Alarm

05 Locked

06 Slot

07 Unknown

08 Unable to get SAF-TE information

TABLE F-4 System Drive State Errors (Continued)

Error Field
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Error Field: Tape State

09 Battery

0A Invalid Number of Slots

0B Environmental Data Not Available

TABLE F-7 Tape State Errors

Error Field Description

01 Read

02 Write

03 Hard Error

04 Media Error

05 Read Failure

06 Write Failure

07 Media Life

08 Not Upgradable

09 Write Protect

0A Nonremoval

0B Cleaning Media

0C Unsupported Format

0D Snapped Tape

14 Clean Now

15 Clean Periodic

16 Expired Cleaning Media

1E Hardware A

1F Hardware B

20 Interface

21 Eject Media

22 Down Load Fail

28 Loader Hardware A

29 Loader Tray Tape

TABLE F-6 SAF-TE State Errors (Continued)
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Error Field: Redundancy State

2A Loader Hardware B

2B Loader Door

C8 Query Log Failed

C9 Inquire Tape Failed

TABLE F-8 Redundancy State Errors

Error Field Description

01 Mode OK

02 No Memory for Negotiation

03 Secondary Failure

04 Secondary Removed

05 Detected Removal of Secondary

06 Detected Insertion of Secondary

07 Primary Failure

08 Primary Removed

09 Detected Removal of Primary

0A Detected Insertion of Primary

0B Unknown State

0C Partner Failed

0D Partner Inserted

0E Partner Removed

TABLE F-7 Tape State Errors (Continued)

Error Field Description
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Error Field: Internal State

Error Field: Device State

Error Field: Initialization State

TABLE F-9 Internal State Errors

Error Field Description

01 No Memory

02 Semaphore

03 Thread

04 No Devices

TABLE F-10 Device State Errors

Error Field Description

01 Inquiry

02 Unknown

TABLE F-11 Initialization State Errors

Error Field Description

01 dll Initializing

02 dll Initializing Failed
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Error Field: Invalid Client Parameter

Error Field: Open Transport

TABLE F-12 Client Parameter Errors

Error Field Description

01 Set Configuration – Configuration Miscompare

02 Set Configuration – Configuration Device Invalid

03 Set Configuration – Enquire Miscompare

04 Set Configuration – Enquire2 Miscompare

05 Incorrect Application Length

06 Command not Supported

07 Invalid Command

08 Set Configuration – General Miscompare

09 Invalid Length

0A Invalid Card Identifier

0B Invalid Card Name

0C Invalid Parameter

0D Invalid Command for Card Type

0E Set Configuration – Invalid Additional Parameter

0F Set Configuration – Block Overlap

10 Set Configuration – Device Information Invalid

TABLE F-13 Open Transport Errors

Error Field Description

01 Open Transport
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Error Field: Close Transport

Error Field: Memory Allocation

Error Field: Transport

TABLE F-14 Close Transport Errors

Error Field Description

01 Close Transport

TABLE F-15 Memory Allocation Errors

Error Field Description

01 Insufficient Memory

02 Insufficient Memory for Administration Operation

TABLE F-16 Transport Field Errors

Error Field Description

01 Lock Fault

02 Insufficient Memory

03 Acquire Lock Fault

04 Release Lock Fault

05 Invalid Command

06 Invalid Length

07 Invalid Card Name

08 Invalid Card Identification

09 No Cards Found

0A No Devices Found

0B Open Fault

0C Card Name not Found
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Error Field: Command

Error Field: Main Communications

Error Field: Communications Link

TABLE F-17 Command Code Errors

Error Field Description

01 Lock Fault

TABLE F-18 Main Communications Errors

Error Field Description

01 Socket Fault

02 Report Fault

03 Thread Fault

04 Lock Fault

05 System Fault

TABLE F-19 Communications Link

Error Field Description

01 Socket Fault
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Error Field: Communications Async

Error Field: Communications Security

Error Field: Timeout

Error Field: Administration

TABLE F-20 Communications Async

Error Field Description

01 Socket Fault

02 Thread Fault

03 Cold Link Fault

04 Send Event Fault

TABLE F-21 Communications Security

Error Field Description

01 Security Violation

TABLE F-22 Timeout Errors

Error Field Description

01 Configuration Update

02 Lock Timeout

TABLE F-23 Administration Errors

Error Field Description

01 Set Customer Name Fault

02 Set Configuration Ended

03 Initialize
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Error Field: Firmware

Error Field: System Shutdown

04 Initialize Ended

05 Rebuild

06 Rebuild Ended

07 Parity Check

08 Parity Check Ended

09 Set SAF-TE Slot State

0A Set SAF-TE Perform Slot

0B Set SAF-TE Send Global

0E Schedule Parity Check

0F Schedule Parity Check Ended

10 Set Controller Parameters

11 Firmware Download

12 Consistency Check or Rebuild Ended

TABLE F-24 Firmware Download Errors

Error Field Description

01 Not a SAF-TE Device

02 Invalid Data Length

03 Download Failed

04 Check Sum Failed

TABLE F-25 System Shutdown Errors

Error Field Description

01 System Shutdown Failed

TABLE F-23 Administration Errors (Continued)

Error Field Description
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Error Field: RDP Path Change

Error Field: Sun StorEdge Set Config

Error Field: Sun StorEdge Controller Event

TABLE F-26 RDP Path Change Errors

Error Field Description

01 RDP Path Failed

02 RDP Path Restored

TABLE F-27 Sun StorEdge Set Config Errors

Error Field Description

01 Set Configuration Thread creation Failed

02 Get Logical Drive List Command Failed

03 Create Config Command Failed

04 Init Completion Status Command Failed

05 Get Configuration Command Failed

06 Change Volume Config Command Failed

07 Delete Logical Drive Command Failed

TABLE F-28 Sun StorEdge Controller Event Errors

Error Field Description

01 Controller Reset

02 Controller DRAM Parity Error

03 Redundant Controller Failed

04 Controller Power Supply Failed

05 Controller Fan Failed

06 Controller Temperature Alert
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Error Field: Sun StorEdge Drive Side Event

07 Controller UPS AC Power Loss

08 Controller Initialization Complete

09 Controller Power Supply Back Online

0A Controller Fan Back Online

0B Controller Temperature Normal

0C Controller UPS AC Power Back On

TABLE F-29 Sun StorEdge Drive Side Event Errors

Error Field Description

01 Drive Channel Select Timeout

02 Drive Channel SCSI Bus Error

03 Drive Channel Unexpected Disconnect

04 Drive Channel Negotiation Error

05 Drive Channel Target Timed Out

06 Drive Channel Parity Error

07 Drive Channel Data Under Or Overrun

08 Drive Channel Undefined Error

09 Drive Channel SCSI Bus Reset Issued

0A Drive Channel Not Ready Error

0B Drive Channel Target HW Error

0C Drive Channel Target Media Error

0D Drive Channel Unexpected Unit Attention

0E Drive Channel Unexpected Sense Data

0F Drive Channel Block Reassign Fail

10 Drive Channel Block Reassign Success

11 Drive Channel SCSI Aborted Command

12 Drive Channel SCSI Channel Fail

TABLE F-28 Sun StorEdge Controller Event Errors (Continued)

Error Field Description
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Eror Field: Sun StorEdge Host Side Event

Error Field: Sun StorEdge Logical Drive Event

Server Manage/Monitor Event Error

TABLE F-30 Sun StorEdge Host Side Event Errors

Error Field Description

01 Host Channel SCSI Bus Reset

02 Host Channel SCSI Bus Device Reset

03 Host Channel Abort Tag Message

04 Host Channel Parity Error

05 Host Channel Reselect Timeout

TABLE F-31 Sun StorEdge Logical Drive Event Errors

Error Field Description

01 Logical Drive SCSI Drive Fail

02 Logical Drive Initialization Fail

03 Logical Drive Rebuild Fail

04 Logical Drive Initialization Commenced

05 Logical Drive Initialization Completed

06 Logical Drive Rebuild Commenced

07 Logical Drive Rebuild Completed

TABLE F-32 Server Manage/Monitor Event Error

Error Field Description

01 Server to Manage/Monitor has Sun StorEdge changed.
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Error and Status Messages
Most error and status messages are self-explanatory. TABLE F-33 clarifies terms which
are used in messages. TABLE F-34 lists the Error/Status messages.

TABLE F-33 Substituted Values

Value Description

Channel Card channel number indicating a SCSI channel. A value of 1
indicates the first channel.

Fan Fan number.

Enclosure Enclosure number.

LogicalArray Logical array number.

LogicalDrive Logical Drive number.

Lun LUN number.

Name A text name.

Power Power supply number.

Slot Slot number.

State State of a logical array or a device or an enclosure in text. The
values are: Critical, Online, Offline, Critical Rebuild, Non Existent,
Low Battery, Normal

Target A target or SCSI ID number.

Temperature The temperature in centigrade.

TABLE F-34 Error/Status Messages

Error and Status Messages

A tape has been left in the autoloader by a previous hardware fault. Insert an empty
magazine to clear the fault. If the fault does not clear, turn the autoloader off and then on
again. If the problem persists, call the tape drive supplier helpline.

A user named ssconfig must be created for configuring SUNWsscs Diag Reporter.

Abort/Clear-Queue/Abort-Tag Message (SCSI Channel %d, SCSI ID %d, Target Lun %d).
Possible failure of I/O module, cable, controller, or HBA.

Access denied for one or more servers. Log in as an ssconfig user, and then try the
operation again.
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Active trap events is empty.

Add SCSI Drive into Logical Drive information.

Agent Name is empty.

An error occurred while getting data from the server.

An existing configuration for this package is found. Do you want to restore it?

An HBA card with this WWN already exists.

Another instance of this program is already running!

Are you sure you want to continue?

Are you sure you want to delete the log file?

Are you sure you want to overwrite the file?

Are you sure you want to rebuild the drive?

Array Admin in Progress.

At least one email address needs to be configured.

Attempted to load a cartridge type, not supported by this drive. The cartridge has been
automatically ejected. Attempted to load an unsupported tape format.

Attempted to write to a write-protected cartridge. Remove the write-protection or use
another tape.

Audible alarm has an unknown status

Audible alarm has been triggered.

Audible alarm has been turned off.

Background check or rebuild operation in progress.

Background initialization in progress.

Background parity check in progress.

Background rebuild operation in progress.

Background rebuild/check has been successfully terminated by abort command.

Background rebuild/check has failed. Cause unknown.
See additional messages.

Background rebuild/check has failed. Possible device failure.
See additional messages.

Background rebuild/check has failed. Possible system drive failure.

Before starting to use SUNWsscsConsole, run /opt/SUNWsscs/sscsconsole/config_sscon
to input the pathanme of the default Web browser to access HTML help files.

TABLE F-34 Error/Status Messages (Continued)

Error and Status Messages
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Begin downloading firmware to devices. Do you want to continue?

Block Reassignment Failure (Ch:%d,Id:%d). Defective drive. Replace.

Block Reassignment Succeeded( Ch:%d,Id:%d.) Informational message. Drive might be
failing.

Cannot find the Java Runtime Environment $JRE_MAJOR.$JRE_MINOR or above!
SUNWsscs Console needs JRE 1.2 or above to run. The Console will try to find it in
/usr/java, /usr/jre, /usr/local/java, or /usr/local/jre. If you installed the JRE
in a directory other than one mentioned above, make a link.

Cannot get available LUN to assign this parition.

Cannot get SAFTE device status!

Changes made to Optimization will NOT take effect until all the logical drives are deleted
and then the controller is RESET.

Changes made to this setting will NOT take effect until the controller is RESET. Prior to
resetting the controller, the operation may not proceed normally. Do you want to RESET
controller?

Click View to select one file.

Collect mail canceled by user.

Completed Dynamic Growth.

Configuration information saved successfully!

Connect and Login command error

Contact Fax number format is wrong.

Contact Name is empty

Contact Phone number format is wrong.

Continuing Dynamic Growth - Parity Check Phase Completed.

Continuing Dynamic Growth - Rebuild Phase Completed.

Controller Event, Controller Init Complete. Controller has been rebooted. Informational
message.

Controller Event, Controller Reset.

Controller Event, DRAM Parity Error. Likely controller error. If error persists, replace
defective controller.

Controller Event, Fan Back On-line. Informational message.

Controller Event, Fan Failure Detected. Fan is integrated with power supply. Replace power
supply. Check LED indicators to identify supply.

Controller Event, Power Supply Back On-line. Informational message.
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Controller Event, Power Supply Failure Detected. Replace power supply. Check LED
indicators to identify supply.

Controller Event, Redundant Controller Failure Detected. Likely controller error. If error
persists, replace defective controller.

Controller Event, SDRAM Error. Likely controller error. If error persists, replace defective
controller.

Controller Event, Temperature Alert. Check room temperature, clogged or restricted
airflow. Correct as necessary.

Controller Event, Temperature Back to Normal. Informational message.

Controller Event, UPS AC Power Back On. Informational message.

Controller Event, UPS AC Power Loss Detected. Contact technical support.

Creating Host LUN filter Entry; please wait…

Creating standard Host LUN mapping; please wait…

Customer Fax number format is wrong.

Customer name has been updated.

Customer Name is empty.

Customer Phone number format is wrong.

Data is at risk. Media performance of this tape is severely degraded. Copy any data you
require from this tape. Do not use this tape again. Restart the operation with a different
tape.

Data Under/Overrun(Ch:%d,Id:%d). Likely poorly seated or defective drive. If random
drives, possible I/O module or cable failure on drive loop.

Decrypt mail canceled by user.

Deleted disk successfully!

Deleting disk; please wait…

Deleting Host LUN filter Entry; please wait…

Deleting standard Host LUN mapping; please wait…

Device at [Channel:Target] has been marked DEAD.

Device at [Channel:Target] has failed the self-reliability test. Replace the device.

Device information failed.

Device is being automatically replaced by device [Channel:Target].

Device will NOT be automatically replaced.

Disk at [Channel:Target] has failed. Replace the device.
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Disk at [Channel:Target] is back online.

Disk information is not available.

Do you want to download firmware to the controller?

Do you want to download firmware with boot recrod to the controller?

Do you want to save the current event log file?

Do you want to set up the mail server?

Door lock has an unknown status.

Door locked.

Door unlocked.

Download Firmware with Boot Record.

Downloading Firmware to the devices

Downloading Firmware to the RAID Controller.

Drive SCSI Ch:%d Check drive seating, cables, and I/O module. Replace as required.
Redundant controllers failed to bind.

Drive SCSI Ch:%d; Id:%d Likely poorly seated or defective drive. If random drives, possible
I/O module or cable failure.

Dynamic Growth Add Capacity Failed.

Dynamic Growth Check Consistency Failed.

Dynamic Growth Close Transport Failed.

Dynamic Growth Disable Controller failed.

Dynamic Growth has completed on logical drive LogicalDrive.

Dynamic Growth has started on logical drive LogicalDrive.

Dynamic Growth Kill Partner Failed.

Dynamic Growth Partner Status Failed.

Dynamic Growth Rebuild Failed.

Email address format is wrong.

Enclosure #Enclosure state change: Name

Enclosure #Enclosure, Cache backup battery has changed from State state to State state.

Enclosure #Enclosure, Fan #Fan has changed from a State state to a State state.

Enclosure #Enclosure, Power supply #Power has changed from a State state to a State state.

Enclosure #Enclosure, temperature threshold has changed from a State state to a State state.
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Engaging firmware; a controller reset is not necessary.

Enter a Contact Name.

Enter a Customer Name.

Enter a Location.

Enter a mail address.

Enter a System ID.

Enter a valid gateway address.

Enter a valid IP address.

Enter a valid network mask.

Enter SMTP server information

Enter the login password.

Enter the ssconfig user password to login

Error in writing file, please try later!

Error occurred. Reset the config file.

Error on RAIDFlex port inquiry.

Expand Logical Drive information.

Failed primary controller has been removed.

Failed secondary controller has been removed.

Fan #Fan has an unknown status.

Fan #Fan is malfunctioning.

Fan #Fan is not present in the system.

Fan #Fan is operational.

File I/O error. Configuration could not be saved!

Firmware downloaded to Safte device (Ch:%d,Id:%d) failed.

Firmware downloaded to Safte device (Ch:%d,Id:%d) successfully.

Firmware downloaded to SCSI drive (Ch:%d,Id:%d) failed.

Firmware downloaded to SCSI drive (Ch:%d,Id:%d) successfully.

First select one Logical Drive!

First select one physical device.

First select one RAID controller.
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For NRAID Logical Drive 'Expand'/'Add Drive'/'Copy and Replace' function is disabled.

For RAID1 Logical Drive 'Add Drive'/'Copy and Replace' function is disabled.

Forward mail canceled bu user

Getting Agent Options failed!

Getting Controller Parameters failed!

Getting Host LUN Assignments failed! Please try again

Getting the configuration failed!

Gross Error on SCSI Bus Detected (Log drive LogicalDrive, Ch:Channel,Id:Target,Lun:Lun).

Gross Phase/Signal Error Detected. Check drive seating, cables, and I/O module. Replace
as required. Redundant controllers failed to bind.

Group Name cannot be empty

Host LUN filter Entry created successfully!

Host LUN filter Entry deleted successfully!

Host LUN filter map (StorEdge SN#%d LD %d Partition %d) is created.

Host LUN filter map (StorEdge SN#%d LD %d Partition %d) is deleted.

If file access is not properly coordinated when assigned to multiple hosts, data corruption
and access contentions may occur.

If Minimum interval is \“0\” or \“*\”, then Content must be \“Event\”

If the firnware download progress is interrupted the controllers/devices may become
unusable.

Initialization operations have completed.

Initializaton, rebuild, expand, or add SCSI drive activities are in progress. Try again later.

Inserted failed primary controller.

Inserted failed secondary controller.

Install JRE 1.2.2, 1.3, 04 1.4 before installing the console.

Invalid server IP address!

IP Address format error (must be xxx.xxx.xxx.xxx and 0 &amp;lt; xxx &amp;lt;255) !

IP Address is duplicated!

IP Address is empty.

Issue Reset to the controller.

Location is empty.
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Log in as \"ssconfig\" user and try the operation again.

Logical array LogicalArray Dynamic Growth has completed.

Logical array LogicalArray Dynamic Growth has started.

Logical array LogicalArray has changed from a State state to a State state.

Logical array LogicalArray initialization has completed.

Logical array LogicalArray initialization has started.

Logical array LogicalArray parity check has completed.

Logical array LogicalArray parity check has started.

Logical array LogicalArray scheduled parity check has completed.

Logical array LogicalArray scheduled parity check has started.

Logical Drive %d, a SCSI Drive Failed. Replace defective drive.

Logical Drive LogicalDrive, Parity Check Failed. Non-recoverable error. Likely drive failure
or a non-recoverable error on stripe. Run parity check on the logical drive. Contact technical
support.
Do not contact technical support. There is no risk of data corruption as a result of this action.

Logical Drive ID %d, Rebuild Completed. Informational message. Replace defective drive
with new drive.

Logical Drive ID LogicalDrive, Add drive paused. Informational message.

Logical Drive ID LogicalDrive, Add SCSI Drv Completed. Informational message.

Logical Drive ID LogicalDrive, Starting Parity Check. Informational message.

Logical Drive ID LogicalDrive, Starting Rebuild. Informational message.

Logical Drive ID LogicalDrive, Add SCSI Drv Failed. Non-recoverable error. Likely drive
failure or a non-recoverable error on stripe. Run parity check on the logical drive. Contact
technical support.

Logical Drive ID LogicalDrive, Clone Completed. Informational message.

Logical Drive ID LogicalDrive, Clone Failed. Non-recoverable error Likely drive failure or a
non-recoverable error on stripe. Run parity check on the logical drive. Contact technical
support.

Logical Drive ID LogicalDrive, Expand Completed. Informational message.

Logical Drive ID LogicalDrive, Expand Failed. Non-recoverable error. Likely drive failure or
a non-recoverable error on stripe. Run parity check on the logical drive. Contact technical
support.

Logical Drive ID LogicalDrive, Initialization Completed. Informational message.
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Logical Drive ID LogicalDrive, Initialization Failed. Informational message. Possible
defective drive or slot. User might have aborted operation.

Logical Drive ID LogicalDrive, Parity Check Completed. Informational message.

Logical Drive ID LogicalDrive, Rebuild Failed. Informational message. Possible defective
drive or slot. User might have aborted operation.

Logical Drive ID LogicalDrive, Starting Add SCSI Drive Operation. Informational message.

Logical Drive ID LogicalDrive, Starting Clone. Informational message.

Logical Drive ID LogicalDrive, Starting Expansion. Informational message.

Logical Drive ID LogicalDrive, Starting Initialization. Informational message.

Logical Drive LogicalDrive has changed from a State state to a State state.

Logical Volume Components List. Total disks in this Logical Volume=

Login successful

Login unsuccessful

Logout command error.

Mail information is empty.

Memory Allocation Error.

Minimum interval between emails must be one of the following formats: \"*\" \"0\" \
"nn\" \"nn:mm\"

Minimum interval can’t meet Content value.

Minimum interval format error.

Minimum interval format is HH[:MM].

Minimum interval is empty.

Multiple IP assignment mechanisms are not supported. Select only one mechanism.

Mute controller beeper failure.

Mute controller beeper.

Negotiating with the secondary controller.

Negotiation completed successfully, waiting for next ping.

Negotiation Error(Ch:%d,Id:%d). Check drive seating, cables, and I/O module. Replace as
required.

New parity check schedule has been created.

No admin progress exists.

No Admin progress was found. All activity should be complete!
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No array administration activity in progress!

No more events to report.

Not Ready Error Reported by Target(Ch:%d,Id:%d). Likely poorly seated or defective drive.
Possible defective drive slot.

Only the last partition of a logical drive can be deleted.

Operation completed successfully.

Operation failed.

Operation in progress.

Operation on one of the servers failed.

Out of the scope!

Parity check could not be started on logical drive LogicalDrive.

Parity check has completed on logical drive LogicalDrive.

Parity check has started on logical drive LogicalDrive.

Parity check or Rebuild has completed on logical drive LogicalDrive.

Parity check schedule has been removed.

Parity check schedule has been updated.

Parity Error(Ch:%d,Id:%d ). Likely poorly seated or defective drive. If random drives,
possible I/O module or cable failure.

Parity Error(SCSI Channel %d, SCSI ID %d, Target Lun %d). Possible failure of I/O module,
cable, controller, or HBA

Partition 0 cannot be deleted.

Partition table is full, 'Expand Logical Drive'/'Add Drive' function is disabled.

Password error!

Password is empty

Physical drive Channel:Target rebuild has completed.

Physical drive Channel:Target rebuild has started.

Poll interval limited to 600 seconds (10 minutes). Specify a lower value.

Port is invalid (port must be between 0 and 65535)

Port is invalid (port must be between 1270 and 1273)

Power supply #Power has an unknown status.

Power supply #Power is malfunctioning and has been switched off.
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Power supply #Power is malfunctioning or disabled.

Power supply #Power is not present in the system.

Power supply #Power is operational but disabled.

Power supply #Power is operational.

Power supply #Power is present in the system.

Primary controller failed. Secondary controller is servicing I/O.

Primary controller has stopped negotiation because of insufficient memory.

Probe Agent command error!

Progress not available

Raid Controller is back online.

Rebuild or check operations have completed with error - Drive Failure.

Rebuild or check operations have completed with error - Job Terminated.

Rebuild or check operations have completed with error - System Drive Failure.

Rebuild or check operations have completed with error - Unknown causes.

Rebuild or check operations have completed.

Received command to establish redundancy with secondary controller.

Received command to return control to primary controller.

Received first ping after successful negotiation.

Received the first ping from secondary controller.

Redundant Array State Change: Controllers back in redundancy mode!

Redundant Array State Change: Primary controller failed! Replace the Primary Controller.

Redundant Array State Change: Secondary controller failed! Replace the Secondary
Controller.

Remove the package @PKG_NAME@ and then try to install this package

Removed a failed primary controller.

Removed a failed secondary controller.

Reselect Timeout(SCSI Channel %d, SCSI ID %d, Target Lun %d). Possible failure of I/O
module, cable, controller, or HBA.

Restoring control to primary controller.

Retry the configuration operation after the update is complete.

SAF-TE card Channel:Target firmware has been updated.
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SAF-TE card Channel:Target global status has been updated.

SAF-TE card Channel:Target slot perform status has been updated.

SAF-TE card Channel:Target slot status has been updated.

Save a Copy in server.

Saving configuration information; please wait…

Scan SCSI Drive information.

Scan SCSI Drive Successful. Informational message.

Scheduled parity check could not be started on logical drive LogicalDrive.

Scheduled parity check has completed on logical drive LogicalDrive.

Scheduled parity check has started on logical drive LogicalDrive.

Scheduled parity check on logical drive LogicalDrive completed with error - Drive Failure.

Scheduled parity check on logical drive LogicalDrive completed with error - Job Terminated.

Scheduled parity check on logical drive LogicalDrive completed with error - System Drive
Failure.

Scheduled parity check on logical drive LogicalDrive completed with error - Unknown
causes.

Scheduled parity check skipped to next schedule due to incompletion of previous check.

SCSI Aborted Command(Ch:%d,Id:%d). Informational message. Drive might be failing or
defective slot.

SCSI Bus Device Reset(SCSI Channel %d, SCSI ID %d, Target Lun %d). Possible failure of
I/O module, cable, or HBA.

SCSI Bus Reset Issued(Ch:%d,Id:%d). Check drive seating, cables, and I/O module. Replace
as required.

SCSI Bus Reset(SCSI Channel %d, SCSI ID %d, Target LUN %d). Possible failure of I/O
module, cable, or HBA.

SCSI Channel Failure - (Ch:%d,Id:%d) Replace defective I/O or drive module.

SCSI Channel Failure - Fibre Loop Connection Failure Check drive path. Possible cable or
module failure.

SCSI Channel Failure - General. Check drive path.

SCSI Channel Failure - Redundant Loop/Path Failure. Check drive path. Possible cable or
module failure.

SCSI Channel Failure(Log drive LogicalDrive, Ch:Channel,Id:Target,Lun:Lun).

SCSI Channel Restored - Fibre Loop Connection Restored. Informational message.
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SCSI Channel Restored - Redundant Path Restored. Informational message.

SCSI Drive Failed. Replace defective drive.

Secondary controller has failed.

Select a Product ID before downloading firmware.

Select either AM or PM.

Select only ONE logical drive!

Select only one row to edit it.

Select only one row to remove it.

Select the agent before clicking Remove.

Select the agent item before clicking Edit.

Select the Channel/ID of the drive you want to scan

Select the firmware file before downloading it

Select the Logical Drive(s)

Select the server item before clicking Edit.

Select the server item before clicking Remove.

Select the Starting Day.

Select Timeout(Ch:%d,Id:%d). Likely poorly seated or defective drive. If random drives,
possible I/O module or cable failure.

Server failed the operation due to insufficient memory.

Server Name is empty

Server Not managed!

Set configuration failed!

Slot #Slot has had a device Name.

SMART Predictable Failure Detected Ch:%d,Id:%d). Informational message. Drive might be
failing.

SMTP From address format is wrong or empty.

SMTP From address format is wrong.

Specify how often you want the parity checked.

Standard Configuration options provide a group of basic default RAID sets whereby the
drive size, quantity, and assignments are preconfigured.

Standard Configuration will replace the existing configuration.
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Standard Host LUN mapping created successfully!

Standard Host LUN mapping deleted successfully!

Standard maps are available to all connected hosts in certain configurations.

Standby rebuild operation completed with an unknown error.

Standby rebuild operation in progress.

Starting Dynamic Growth.

Startup state of the secondary controller.

Successful negotiation between both controllers.

Successful startup. Both controllers have entered redundancy modes.

SUNWsscsConsole needs JRE 1.2.2, 1.3, or 1.4 to run.The Console will try to find it in
/usr/java, /usr/jre, /usr/local/java, or /usr/local/jre. If you installed the JRE
in a directory other than one mentioned above, make a link.

System ID is empty.

Tape operation has stopped because an error occurred while reading or writing data, which
the drive cannot correct.

TapeAlert notification. Device [Channel:Target].

Target HW Error Reported(Ch:%d,Id:%d). Likely poorly seated or defective drive. Possible
defective drive slot.

Target Media Error Reported(Ch:%d,Id:%d). Likely poorly seated or defective drive.
Possible defective drive slot.

Target Timed-out(Ch:%d,Id:%d). Check drive seating, cables, and I/O module. Replace as
required.

Temperature Alert. Check room temperature, clogged or restricted airflow. Correct as
necessary.

Temperature Back to Normal. Informational message.

Temperature change from TemperatureC to TemperatureC.

The changer mechanism is having difficulty communicating with the tape drive. Turn the
autoloader off then on and restart the operation. If problem persists, call the tape drive
supplier helpline.

The client receives events only when it is running. Are you sure you want to exit?

The configuration has been updated.

The configuration was successfully updated. If new logical drives were created, the server
may need to be rebooted.

The Content of Periodic Trap cannot be \"Event\". Please select another one.
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The Controller devices list changed.

The controller needs to be reset for the new firmware to take effect. Do you want to reset
the controller?

The controller parameters have been updated.

The current user is ssconfig; you cannot log in again.

The device does not belong to the same HBA card. The operations cannot continue.

The device resource cannot be locked for exclusive use. Check to see if some applications
are currently accessing the resource. If so, close those applications and try the operation
again.

The drive can no longer write data to the tape.

The drive letter (mounted point) cannot be assigned.

The encrypt key is empty.

The encrypt key you entered includes extra space in the beginning or at the end, which can
cause encryption errors. Do you want to continue

The firmware does not support multiple IP assignment mechanisms.

The firmware download failed because you have tried to use the incorrect firmware for this
tape drive. Obtain the correct firmware and try again.

The IP Address cannot be empty.

The last cleaning cartridge used in the tape drive has worn out. Discard the worn out
cleaning cartridge, wait for the current operation to finish, and then use a new cleaning
cartridge.

The LD# is moved up after you delete the LD, so it may not be consistent with the LD#
shown in the RS-232 terminal window.

The length of the encrypt key must be greater than 8 characters.

The Mail Server field cannot be empty.

The media has exceeded its specified life. The tape cartridge has reached the end of its
useful life. Copy any data you need to another tape. Discard the old tape.

The memory allocation Failed.

The mount point (drive letter) cannot be written into file (registry).

The operation failed because the autoloader door is open. Clear any obstructions from the
autoloader door, eject the magazine, and then insert it again. If the fault does not clear, turn
the autoloader off and then on again.

The operation failed because the tape in the drive has snapped. Discard the old tape.
Restart the operation with a different tape.

The Selected Device list is empty!
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The server already exists!

The Server Name cannot be empty or only contain any extra spaces

The set configuration Failed.

The tape cartridge is not data grade. Any data you backup to the tape is at risk. The drive
has not been able to read the MRS stripes. Replace the cartridge with a data-grade tape.

The tape drive has a hardware fault, which is not read/write related. Turn the tape drive off
and then on again and restart the operation. If the problem persists, call the tape drive
supplier helpline.

The tape drive has a hardware fault. Eject the tape or magazine, reset the drive (hold the
unload button down for 5 seconds), and restart the operation.

The tape drive has a problem with the SCSI interface. Check the cables and cable
connections and restart the operation.

The tape drive is due for routine cleaning. Wait for the current operation to finish and then
use a cleaning cartridge.

The tape drive is having problems reading data.No data has been lost, but there has been a
reduction in the capacity of the tape.

The tape drive needs cleaning. If the operation has stopped, eject the tape and clean the
drive. If the operation has not stopped, wait for it to finish and then clean the drive.

The tape in the drive is a cleaning cartridge. If you want to backup or restore, insert a data-
grade tape.

The tape is damaged or the drive is faulty. The drive can no longer read data from the tape.
Call the tape supplier helpline.

The tape is from a faulty batch or the tape drive is faulty. Use a good tape to test the drive.
If the problem persists, call the tape drive supplier helpline.

The tape operation failed. Eject and then reinsert the tape or magazine.

The WWN must be a Hex string that is less than 17 characters.

There are no available disks to configure.

There are no logical drives to manage.

There are not enough available disks to add a new LD.

There is a problem with the autoloader mechanism. Loader mechanism has detected a
hardware fault.

There is no spare or replacement drive. Rebuild cannot continue.

This Configuration Will Overwrite the Existing Configuration. All Previous Configuration
Information and Data Will Be Lost.

This operation will add to the existing configuration.
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This operation will delete the fibre map.

This operation will erase any existing configuration and data.

This operation will result in the loss of current controller settings and data on ALL of the
logical drives. Are you sure you want to restore factory defaults?

This operation will result in the loss of data on ALL of the modified partitions. Do you
want to continue?

To find out the java version currently installed, type “java-version”

Trap information has been modified. Do you want to save it?

Unable to allocate memory for array inquiry. Unable to monitor this array.

Unable to determine local host, terminating!

Unable to eject cartridge because the tape drive is in use. Wait until the operation is
complete before ejecting the cartridge.

Unable to inquire card. Array error.

Unable to inquire SAF-TE device. SAF-TE monitoring for this enclosure disabled.

Unable to inquire tape device. This device willbe removed.

Unable to inquire target devices. Device and SAF-TE monitoring disabled.

Unable to issue Self-Reliability Query on device at [Channel:Target].

Unable to open bindings file -or- no bindings present. Check Bindings file.

Unable to open I/O transport layer

Unable to query TapeAlert log data. TapeAlert monitoring disabled for this device.

Unable to read enclosure environmental status.

Unable to send login info to the server.

Undefined Error(Ch:%d,Id:%d). Contact technical support.

Unexpected Disconnect(Ch:%d,Id:%d). Check drive seating, cables, and I/O module.
Replace as required.

Unexpected Sense Data Received from Target(Ch:%d,Id:%d). Likely poorly seated or
defective drive. Possible defective drive slot.

Unexpected Unit Attention Received from Target(Ch:%d,Id:%d). Likely poorly seated or
defective drive. Possible defective drive slot.

Unknown redundancy state.

UNMAPPED LUN, NOT AVAILABLE TO HOST

Username is empty.

Waiting for debounce ping.
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Write config file error.

Wrong Fax number format.

Wrong Phone number format.

You must first delete the host mapping for the partitions whose index number is greater
before you can change this partition.

You must first delete the host mapping for the partitions whose index number is greater or
equal before you can delete this partition.

You must first delete the host mapping for this logical drive before you can delete it.

You must first delete the host mapping of the last partition before you can add a new
partition.

You selected “Event” as the Trap Type, therefore, you must select at lease one Active trap
event.

You selected “My SMTP server needs authorization,” therefore, you must enter a Password.

You selected “My SMTP server needs authorization,” therefore, you must enter a Username.

You selected “use encrypt,” therefore, you must enter an encrypt key.
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Glossary

This appendix lists acronyms and defines RAID terms found through the
documentation. It also includes definitions of the operational states for disk drives,
logical drives, and redundant controllers.

Acronyms
ANSI American National Standards Institute

CH Channel

CISPR International Special Committee on Radio Interference

EMU Event Monitoring Unit

FC-AL Fibre Channel-Arbitrated Loop. FC-AL is implemented as either a loop or a
Fabric. A loop can contain up to 126 nodes, accessible through only one or two
servers.

FRU Field-Replaceable Unit

GB Gigabyte. 1,000,000,000 (one billion) bytes.

GBIC Gigabit Interface Converter. A hot-swappable input/output device that plugs
into a Gigabit Ethernet port or Fibre Channel.

HBA Host Bus Adapter

ID Identifier number

IEC International Electrotechnical Commission

JBOD Just a Bunch of Disks (a Sun StorEdge unit with drives and no controllers)

LAN Local Area Network

LD Logical drive
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LUN Logical unit number. The major and minor device numbers make up the logical
unit numbering sequence for a particular device connected to a computer.

LVD A low-noise, low-power, and low-amplitude signaling system that enables data
communication between a supported server and storage devices. LVD
signaling uses two wires to drive one signal over copper wire and requires a
cable that is no longer than 25 meters (82 feet).

MB Megabyte. 1,000,000 bytes or characters of data.

NVRAM Non-Volatile Random Access Memory. A memory unit equipped with a battery
so that the data stays intact even after the main power had been switched off.

PID Primary controller identifier number

RAID Redundant Array of Independent Disks. A configuration in which multiple
drives are combined into a single virtual drive to improve performance and
reliability.

SAN Storage Area Networking. A high-speed, open-standard scalable network of
storage devices and servers providing accelerated data access.

SCSI Small Computer Systems Interface. An industry standard for connecting disk
and tape devices to a workstation.

SES SCSI Enclosure Services driver. An interface to SCSI Enclosure Services
devices. These devices sense and monitor the physical conditions within an
enclosure, as well as enable access to the status reporting and configuration
features of the enclosure (such as indicator LEDs on the enclosure).

SID Primary controller identifier number

S.M.A.R.T. Self Monitoring Analysis and Reporting Technology. The industry standard
reliability prediction indicator for both the IDE/ATA and SCSI hard disk
drives. Hard disk drives with SMART offer early warning of some hard disk
failures so critical data can be protected.

SMTP Simple Mail Transfer Protocol. A protocol for sending email messages between
servers and from mail clients to mail servers. The messages can then be
retrieved with an email client using either POP or IMAP.

SNMP Simple Network Management Protocol. A set of protocols for managing
complex networks. SNMP works by sending messages, called protocol data
units (PDUs), to different parts of a network. SNMP-compliant devices, called
agents, store data about themselves in Management Information Bases (MIBs)
and return this data to the SNMP requesters.

WWN world wide name. A number used to identify array volumes in both the array
system and systems using the Solaris operating environment.
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Terminology
active-active

controllers A pair of components, such as storage controllers in a failure tolerant storage
system that share a task or set of tasks when both are functioning normally.
When one component of the pair fails, the other takes the entire load. Dual
active controllers (also called dual-active controllers) are connected to the same
set of devices and provide a combination of higher I/O performance and
greater failure tolerance than a single controller.

automatic rebuild A process where data is automatically reconstructed after a drive failure and
written to a standby (spare) drive. An automatic rebuild also occurs when a
new drive is installed manually in place of a failed drive. If the rebuild process
is interrupted by a reset, use the Array Administration → Rebuild to restart the
rebuilding process.

background rate The background rate is the percentage of available array controller CPU time
assigned to array administration activities, such as rebuilding failed drives,
checking parity, and initialization. If the background rate is set to 100%, the
array administration activities have a higher priority than any other system
activity. At 0%, the array administration activity is done only if there is no
other activity on the array controller.

caching Allows data to be stored in a pre-designated area of a disk or RAM (random
access memory). Caching is used to speed up the operation of RAID systems,
disk drives, computers and servers, or other peripheral devices.

channel Any path used for the transfer of data and control information between storage
devices and a storage controller or I/O adapter. Also refers to one SCSI bus on
a disk array controller. Each disk array controller provides at least one channel.

fabric Fibre Channel network built around one or more switches.

failover A mode of operation for failure tolerant systems in which a component has
failed and its function has been assumed by a redundant component.

fault tolerance The capacity to cope with internal hardware problems without interrupting
data availability, often by using backup systems brought online when a failure
is detected. Many storage systems provide fault tolerance by using RAID
architecture to give protection against loss of data when a single disk drive
fails. Using RAID 1 (mirroring), RAID 3 or 5 (striping with parity), or RAID 6
or 1+0 (mirroring and striping) techniques, the array controller can reconstruct
data from a failed drive and write it to a standby or replacement drive.

fault tolerant logical
drive A logical drive that provides protection of data in the event of a single drive

failure by employing RAID 1, 3, 5, or 6 (also known as RAID 1+0).

fibre channel A cost-effective gigabit communications link deployed across a wide range of
hardware.
Glossary 255



groups A group is a new data object that enables multiple servers to be contained
under a single category, are similar in concept to domains, and enable you to
organize servers within Configuration Service. Instead of a linear tree of all the
managed servers, the Configuration Service operator can organize the servers
into like sets or groups.

Groups are not required. You can configure Configuration Service for no
groups and fifteen servers, for example, or for one group with ten servers
underneath, with an additional five at the top level. Configuration Service
enables any combination.

The number of groups permitted and the number of servers within a group is
limited only by available system memory. If a server is a member of a group
and a user deletes that group from the group list box, Configuration Service
reassigns the servers in that group to the no group category. Configuration
Service automatically remaps the tree in the main window.

hot spare A drive in a RAID 1 or RAID 5 configuration that contains no data and acts as
a standby in case another drive fails.

hot-swappable The ability of a field-replaceable unit (FRU) to be removed and replaced while
the system remains powered on and operational.

logical drive An array of independent physical drives that appears to the host as one large
drive.

LUN mapping The ability to change the virtual LUN as presented to the server from storage.
This enables such benefits as the ability of a server to boot from the SAN
without requiring of a local disk drive. Each server requires LUN 0 to boot.

LUN masking The characteristic that enables an administrator to dynamically map an HBA to
a specified LUN. This provides an individual server or multiple servers access
to an individual drive or to multiple drives, and prohibits unwanted server
access to the same drives.

mirroring (RAID 1) Data written to one disk drive is simultaneously written to another disk drive.
If one disk fails, the other disk can be used to run the system and reconstruct
the failed disk. The primary advantage of disk mirroring is 100% data
redundancy. Since the disk is mirrored, it does not matter if one of the disks
fails. Both disks contain the same data at all times and either can act as the
operational disk.

Disk mirroring provides 100% redundancy, but is expensive because each drive
in the system is duplicated.

N port A Fibre Channel port in a point-to-point or Fabric connection.

out-of-band Refers to the connections and devices that are not in the data path.

parity check A process whereby the integrity of the redundant data on fault tolerant arrays
(RAID 1, 3, 5, and 6 or 1+0) is checked. The parity checking procedure on a
logical drive recalculates the parity of data stripes in each of the logical drive’s
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RAID stripe sets and compares it with the stored parity. If a discrepancy is
found, an error is reported and the new correct parity is substituted for the
stored parity.

partition A section of disk storage space, also referred to as a System Drive or LUN, that
is presented to the host operating environment as a single physical drive. A
logical drive can be located on one or more physical drives.

partner group A pair of interconnected controller units. Expansion units interconnected to the
pair of controller units can also be part of the partner group.

physical array A physical array is a group of physical drives in Configuration Service that
participate in one or more logical drives. If a group of physical drives is
configured into a logical drive without using the entire capacity of the physical
drives, Configuration Service requires that the same physical array of drives be
used together in any remaining logical drives that are created with the
remaining capacity.

In the New Configuration window, the Add Disk button changes to Add Array when
the remaining drive capacity is on multiple physical drives that have already been used
to create a logical drive. Now that the physical drives have been sliced, they have to be
selected as an array. They cannot be selected separately.

RAID Redundant Array of Independent Disks. An arrangement of two or more disk
drives configured to work together to provide more disk storage space, better
performance, and/or redundant backup of data. Various combinations of these
features are described by defined RAID levels. Sun StorEdge arrays can
support RAID 0, 1, 3, 5, and 6 (also called 1+0).

TABLE G-1 lists the RAID levels.

TABLE G-1 RAID Levels

RAID Level Description

RAID 0 Striping without fault tolerance; provides maximum performance.

RAID 1 Mirrored or duplexed disks; for each disk in the array, a duplicate disk is
maintained for fault tolerance. RAID 1 does not improve performance
over that of a single disk drive. It requires 50% of total disk capacity for
overhead.
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read policy Descriptions of the read policies are as follows:

When you indicate a No Cache read policy, the controller does not store data in
the read cache.

Normal specifies that the current controller does not use Read ahead caching
for the current drive.

Set the read policy to Read Ahead and the controller reads multiple adjacent
blocks of data automatically. This is most effective for applications with
sequential reads.

rebuild Rebuilding a disk is the process of reconstructing the data on a disk before it
failed. Rebuilding can be done only in arrays with data redundancy, such as
RAID levels 1, 3, 5, 6 or 1+0.

See “automatic rebuild” on page 255 for detailed information about rebuilding.
For the Rebuild rate, see “background rate” on page 255.

RAID 3 One drive is dedicated to parity. Data is divided into blocks and
distributed sequentially among the remaining drives. You need at least
three physical drives for a RAID 3 logical drive.

RAID 5 Striping with fault tolerance; this is the best-suited RAID level for
multitasking or transaction processing.

In RAID 5, an entire transfer block is placed on a single drive, but there
are no dedicated data or Error Correction Code (ECC) drives. Rather, the
data and ECC are striped across each drive in the disk array, so that each
drive contains a combination of data and ECC blocks. This enables data
to be reconstructed on a replacement drive in the event of a single disk
drive failure.

The primary advantages of RAID 5 are:
• Provides fault tolerance
• Increases performance through the ability to perform both read and

write seeks in parallel
• Low cost per usable megabyte of disk storage.
• RAID 5 also requires at least 3 drives.

RAID 1+0 Mirrored and striped array; this RAID level provides performance and
fault tolerance with 50% overhead.

TABLE G-1 RAID Levels (Continued)
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spanning Disk spanning makes use of the firmware’s striping capability to stripe data
across two otherwise independent RAID logical drives. The two spanned
logical drives are presented to the operating environment as one logical drive.
The advantages of spanning are:

Supports two simultaneous drive failures in the combined fault tolerant logical
drives (provided there is one drive failure from each logical drive).

Improves performance because the number of spindles is increased.

The disadvantage of spanning is that the RAID overhead for redundant RAID
levels is increased since each logical drive handles fault tolerance separately.

standby drive A drive that is marked as a spare to support automatic data rebuilding after a
physical drive associated with a logical drive fails. For a standby drive to take
the place of another drive, it must be at least equal in size to the failed drive
and all of the logical drives dependent on the failed disk must be
redundant—RAID 1, 3, 5, and 6 or 1+0.

state The current operational status of a disk drive, a logical drive, or redundant
controllers. The storage system stores the states of drives, logical drives, and
redundant controllers in its nonvolatile memory. This information is retained
across system power interruptions.

stripe size This is the amount of data in kilobytes that is striped across each physical drive
in a logical drive. The values are in increments of 8 kilobytes and range from 8
to 64 kilobytes. Generally, large stripe sizes are more effective for systems with
primarily sequential reads.

To change the stripe size on an existing drive, you need to back up your data,
redefine the stripe size, reconfigure the storage, and restore all the data.

striping The storing of sequential blocks of incoming data on all the different SCSI
drives in a logical drive. For example, if there are three SCSI drives in a logical
drive, data is stored as follows:

block 1 on SCSI drive 1

block 2 on SCSI drive 2

block 3 on SCSI drive 3

block 4 on SCSI drive 1

block 5 on SCSI drive 2, etc.

This method of writing data increases the disk system throughput because
multiple drives are working simultaneously, retrieving and storing. RAID 0, 3,
5, 1+ 0 all use striping.

terminator A part used to end a SCSI bus. Terminators prevent energy from reflecting back
into a cable plant by absorbing the radio frequency signals.
Glossary 259



volume Also called a logical unit number or LUN, a volume is one or more drives that
can be grouped into a unit for data storage.

write-back cache A cache-writing strategy in which the array controller receives the data to be
written to disk, stores it in the memory buffer, and immediately sends the host
operating environment a signal that the write operation is complete, without
waiting until the data is actually written to the disk drive. Within a short time,
the controller, when not busy, writes the data to the disk drive.

Write-back caching improves the performance of write operations and the
throughput of the controller card. However, because there is a danger of data
loss in the case of a power failure, storage systems with write-back caching are
equipped with a UPS or battery backup cache. A UPS provides power long
enough to enable any data in the cache memory to be written to the disk drive.
With battery backup cache, the battery provides power to retain the memory
data for up to 48 hours.

write policy A cache-writing strategy used to control system write operations. The write
policy options are write-back and write-through cache.

write-through cache A cache-writing strategy in which the array controller writes the data to the
disk drive before signaling the host operating environment that the process is
complete. Write-through cache has lower write operation and throughput
performance than write-back cache, but it is the safer strategy, with minimum
risk of data loss on power failure.
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A
Add Server Grouping tab, 34
Add Server Properties parameters, 31
Add Server window, 31
adding

host LUN, 66
logical drive, 128
new devices

probe, 81
SCSI drives to logical drive, 135
servers, 30

Administrative Tools group, 49
agent

Agent Options Management window, 40, 185
configurable parameters, 40
Configuration Service

installing on Solaris OEs, 10
operation, 76
options management, 94
platforms, 2
Setting Agent Options window, 42
SNMP agent, 207
starting/stopping on Solaris OEs, 12
starting/stopping on Windows, 21

Agent Options Management command, 94
Alarm State, 92

resetting, 92
Array Admin Progress command, 114, 118, 119, 120
Array Admin Progress window, 94
Array Administration

Array Admin Progress command, 114, 118, 119,
120

menu, 120
viewing progress, 113

Array Administration Controller Assignment, 37,
176

assign controller
through config file, 39
through console, 37

Assign Server to Manage RAID Controller
window, 37

Auto Discovery
button, 32
options, 77
process, 76

automatic rebuild, 118
definition, 255

Available SCSI IDs list box, 147
Available Servers list

editing, 159

B
background rate

definition, 255
beeper

muting, 124, 157
before you begin installing Configuration Service

procedures, 3
browser requirements

managing storage through the web, 109
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C
Cache tab, 149
capacity

expanding, 134
Change Channel Settings window, 147
Change Controller Parameters, 146

Cache tab
Optimization, 149

Change Host LUN Assignments, 66
Change Settings button, 147
Channel Mode list box, 147
Channel tab, 147
Clear button

configuration, 65
cluster configuration

CLUSTER.TXT, 197
IP addresses, 198
Microsoft Cluster Server software, 194
planning, 193
requirements, 194
setup, 194
start Configuration Service, 194, 197

comments
sending to manufacturer, xxi

Commit Changes Now, 49
Community String

checking, 203
configuration

caution, 51
Change Host LUN Assignments window, 66
clear button, 65
clearing, 65
Confirm Configuration Operation window, 54
Custom Configuration, 54
Custom Configure, 55
Custom Configure command, 146, 158
Load Configuration Confirmation window, 123
Load Configuration window, 122
loading, 121
logging out of ssconfig, 66
logical drive

saving, 45
Logical Drive Partitions box, 67
new

overview, 57
New Configuration, 60
New Configuration option, 56

New Configuration warning, 60
NT Cluster option, 53
restoring, 121
Saveset Description tab, 122
saving, 45, 68
saving logical drive configuration, 68
Security Configuration window, 204
Security tab, 204
Select Configuration File window, 121
selecting RAID level, 57
setting traps, 203
Standard Configuration Options, 52
Standard Configuration window, 53
Standard Configure, 53
Use a standby drive check box, 53
verifying, 42

Configuration Service
agent operation, 76
console, 71
feature summary, 1
logging in/logging out, 36
main window, 71
monitoring process, 76
overview, 1
starting, 25
tree view, 74
uninstalling

Solaris OEs, 15
Windows, 24

console
Configuration Service

installing on Solaris OEs, 10
devices not displayed, 216
email setup, 200
platforms, 2
running slowly, 217
Windows installation, 20
Windows requirements, 18

controller
assigning through config file, 39
assigning through the console, 37
bringing back online, 125
event errors, 231
muting, 124
parameters

changing, 146
resetting, 124
selecting server to manage, 37
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Controller Array Progress window, 119, 120
Controller Assignment command, 37, 176
Controller Maintenance Options window, 124, 125,

140, 157
controller parameters

saving changes, 157
copying

member drives, 137
Custom Configuration, 54
Custom Configuration icon, 29

D
deleting, 133

logical drive, 130
partition, 133

devices
detailed view information, 78
not appearing in console, 216
rebuilding, 118
status, 73

DHCP environment, 213
Diagnostic Reporter

Config Tool, 164
Config Tool settings, 169
current Agent status, 175
daemon, 164
installing, 166, 167
Mail Receiver Tool, 164

starting, 176
Mail Receiver Tool start and setup

Windows, 176
operation, 164
Report Tool, 176
setting up, 169
SMTP server setup, 171
starting, 169
status colors, 175
trap events

setting up, 173
troubleshooting, 217
uninstalling

Solaris OEs, 178
Windows, 178

Disk Access Latency field, 152
Disk Administrator, 49

Disk Array tab, 150
disk space

Configuration Service Agent, 8
requirements

Configuration Service Console, 8
documentation

how book is organized, xvii
using UNIX commands, xviii

documentation available, xx
documentation comments, xxi
documentation online, xxi
Drive Check Period (Sec) field, 153
Drive I/F tab, 152
drive rebuild, 117, 118
drives

copying and replacing, 137
make/change standby, 158
Physical Drive Standby State window, 158
rebuilding, 119
scanning in new, 139

E
editing

available servers, 159
email

Add Server, 202
Mail Address entry box, 201
Mail Server Setup window, 201
Mailing Lists, 201
Mailing Lists highlighted, 201
Mailing Lists tab, 32
messages, 200
Severity entry box, 201
SMTP email messages, 199

Enable dynamic IP assignment, 156
Enclosure Info tab, 85
environmental

alarms not reported, 217
state, 91

error codes, 219
administration errors, 229
client parameter errors, 226
close transport errors, 227
command code errors, 228
communications async errors, 229
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communications link error, 228
communications security errors, 229
controller event errors, 231
device state errors, 225
disk state errors, 222
drive side event errors, 232
firmware download errors, 230
host side event errors, 233
initialization state errors, 225
internal state errors, 225
logical drive event errors, 233
main communications errors, 228
memory allocation errors, 227
open transport errors, 226
RDP path change errors, 231
redundancy state errors, 224
SAF-TE state errors, 222
server manage/monitor event error, 233
system drive state, 221
system shutdown errors, 230
tape state errors, 223
timeout errors, 229
transport field errors, 227

error messages, 234
solutions, 234

Event Log, 94
error codes, 219
Event Log file, 95
Event Log icon, 28
Event Log window, 95
event record fields, 97
EVENTLOG.TXT, 95
severity levels, 97

event messages
severity levels, 33

expanding
capacity of logical drive, 134
partition, 134

F
fabric

definition, 255
failed drive rebuild, 117
fault tolerance, 255
fault-tolerant logical drive, 255
FC-AL

definition, 253
fibre channel

definition, 255
firmware

upgrading
controller, 140
hard drives, 143
SAF-TE devices, 145

Format, 49
FRU

definition, 93

G
GBIC

definition, 253
global spare drive

description, 179
glossary, 253
gray device status item, 73
grouping servers, 34
groups

colors, 75
definition, 256
Group Name, 30
status, 75
symbol colors, 75
View Group command, 79
View Group window, 79

H
HBA

dual port
displayed in main Configuration Service

window, 72
main Configuration Service window, 80

Host I/F tab, 154
Host LUN

adding, 66
deleting, 68

Host LUN Assignments box, 68
hot spare

definition, 256
hot-swappable
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definition, 256
HP OpenView, 199, 206

caution, 202
troubleshooting, 215

I
IBM NetView, 202
icons

server with satellite dish attached, 42
toolbar

Custom Configuration, 29
Event Log, 28
Save Report, 29
Server List Setup, 28
Standard Configuration, 29

installing
Configuration Service on Solaris OEs

before you begin procedures, 3
default directory, 12
list of installation packages, 9

Configuration Service on Windows
before you begin procedures, 18
list of executable files, 19

Diagnostic Reporter, 166, 167
default directory, 166
list of installation packages, 165
Solaris OEs, 166
Windows, 167

integrating system storage, 70
international support, xx
IP address

changed in DHCP environment, 213
for traps, 205

IP addresses
cluster configuration, 198

Issue Controller Reset check box, 156, 157

J
Java

version
checking, 212

JBOD
monitoring, 185, 193
replacing a failed drive, 190

single bus configuration, 185
splt bus configuration, 186
support

enabling, 41
upgrading firmware on hard drives, 188
upgrading firmware on SAF-TE devices, 189

K
kill -9 # command, 27, 56

L
label

automatically writing, 59, 64
loading configuration, See restoring logical drive

configuration
logging in, 36
logging out, 36
logical drive

adding, 128
adding SCSI drives, 135
creating a partition, 132
definition, 256
deleting, 130
deleting a partition, 133
description, 179, 180
expanding capacity, 134
Partitions box, 67
restoring configuration, 121
saving configuration, 45
View Logical Drive command, 89
View Logical Drive window, 91

logical drive number, 131
logical volume

caution, 5
description, 181

LUN assignments
maximum, 62

LUN mapping
definition, 256

LUN masking
definition, 256

LUNs, 48
adding, 66
Change Host LUN Assignments, 66
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deleting, 68
description, 180
Host LUN Assignments box, 68
LUN detailed information, 83
multiple

recognizing under same ID, 3
LUNs Per Host field, 154

M
main window, 71
Major field, 220
Managed Servers list setup, 35
Managing storage through the web, 109
mapping partition to LUN description, 183
Max Queued IO Count field, 154
member drives

copying and replacing, 137
memory

requirements
agent, 8
Configuration Service Console, 8
Configuration Service Console on

Windows, 18
menu bar

overview, 28
message terms, 234
message variables, 234
MIB, 207
Microsoft Cluster Server (MSCS), 193
Minor field, 220
mirroring (RAID 1), 256
monitoring process, 76
mountall command, 48

N
N port

definition, 256
navigating, 30
Network tab, 156
New Configuration window

Add Disk button, 257
newfs command, 48

NT Cluster option, 53
NTFS, 196

O
online help, 74
out-of-band

definition, 256
storage management, 104

Out-of-Band Agent preferred over In-Band check
box, 106

P
parameters

controller, 146
parity check, 114, 256

scheduling, 115
partition

definition, 257
deleting, 133
description, 181

partitioning, 67, 133
an existing logical drive, 132
requirements, 52

partner group
definition, 257

passwords
Solaris OEs

creating, 15
Windows

creating, 22
phone support, xx
physical array, 257
physical devices

Physical Drives tab, 84
View Physical Device window, 90
View Physical Drive, 90

Physical Drive Standby State window, 158
pkgrm, 16, 178
polling

status change of devices, 40
Power Up SCSI Reset field, 152
probe, 81
Product ID list box, 144
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purple device status icon
device status state, 73

R
RAID

Enclosure Info tab window, 85
RAID controller parameters, 88
View Controller Configuration command, 82

RAID glossary, 253
RAID levels, 257

assigning to logical drive, 54
definition, 257

Random I/O optimization parameter, 149
Read Ahead policy, 258
read policy types, 258
rebuild

definition, 258
drive manually, 119
failed drive, 117
rate

definition, 258
standby drive (automatic), 118

Rebuild Priority, 151
Rebuild window, 120
rebuilding

drive without standby, 118
red device status item, 73
Redundancy tab, 155
Redundant Deassert Reset field, 155
Redundant Force Pri Fail field, 155
Redundant Force Sec Fail field, 155
replacing member drives, 137
Report icon, 29
report option, 98, 104
requirements

installation
Configuration Service Agent on Solaris OEs, 8
Configuration Service Agent on Windows, 18
Configuration Service Console on Solaris

OEs, 8
Configuration Service Console on

Windows, 18
memory

Configuration Service Agent on Solaris

OEs, 8, 18
Configuration Service Agent on Windows, 18

Reset button, 217
alarm state box, 92

resetting
controller, 124

restoring
logical drive configuration, 121

restoring a logical drive configuration, 121
RS 232 Settings tab, 148
RSAGENT.DLL, 215
RST_OID.MIB, 206
RST_OID.MIB file, 215

S
SAF-TE devices

upgrading, 145
SAF-TE Polling Period (Sec) field, 152
Save Configuration function, 46, 69
Save Configuration window, 47
save controller parameter changes, 157
save logical drive configuration, 68
Save Report command, 98
Save Report File window, 98
Saveset Description tab, 122
saving logical drive configuration, 45
scanning

drives, 139
scheduling

parity check, 115
SCSI channel description, 179
SCSI drives

adding to logical drive, 135
SCSI I/O Timeout (Sec) field, 153
SCSI Motor Spin Up field, 152
sd.conf file

editing, 3
Select Configuration File window, 46, 69
Select Controller Progress window, 119
sending documentation comments, xxi
Server List Setup window, 160
server not responding, 211
Server Setup window, 161
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servers
Add Server Properties, 31
Add Server window, 31, 161, 200, 201
add to Managed Servers list, 30
assign to controller through config file, 39
assign to controller through console, 37
Available Servers list, 160, 200
Edit Server window, 160, 161, 200, 213
editing, 159
inventory, 77
Managed Servers list, 161, 214
managing, 35
organize into groups, 34
Server List Setup command, 159
Server List Setup function, 198, 200
Server List Setup icon, 28
Server List Setup procedure, 30
Server List Setup window, 214
Server Login window, 36
Server Name field, 31
Server Setup, 213
Server Setup window, 159, 200, 214
setup to send traps, 202
TCP/IP address for server, 32
View Server command, 80
View Server window, 80

Service Configuration window, 203
SES

definition, 254
Set Controller Config field, 155
Severity field, 219
severity levels (events), 97
Simple Mail Transport Protocol (SMTP), 202
SMART Drive field, 91
SMART monitoring

enabling, 41
SMTP e-mail messages, 199
SN#, 72
SNMP

agents and managers, 207
how it works, 206
identifying objects, 207
Management Information Base, 207
objectIdentifier of MIB variable, 209
protocol data unit (PDU), 208
request types, 208
security, 208

service option, 8, 18
software model, 207
V1, 208

SNMP traps
messages description, 206
setup, 202

Solaris
Configuration Service

installing on, 10
ssserver, 13

Solaris OEs
/etc/rc2.d/S81ssagent start/stop, 12
/kernel/drv/sd.conf, 12
/opt/SUNWsscs/ssconsole directory, 15
browser.default, 12
configuration note, 56
creating users/passwords, 13
kill -9 # command, 27
LG not present, 216
passwd command, 15
pkgrm to uninstall, 16, 178
ps -e | grep ss for process number, 13
ps -el | grep jre for process number, 26
ps-el | grep jre for process number, 27, 56
rstrapd, 214
SNMP traps, 205
sstrapd, 13
starting/stopping agent, 12
system requirements, 7
uninstalling, 15
users/passwords, 13
versions supported, 2

spanning, 259
sscontlr.txt (server/controller assignment), 39
ssmon password bypassed, 32
ssserver, 13
sstrapd, 13
sstrapd daemon, 205
Standard Configuration icon, 29
standby drive, 259

making/changing, 158
starting

Configuration Service, 25
Diagnostic Reporter, 169
Diagnostic Reporter Mail Receiver Tool, 176

status
device, 73
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Diagnostic Reporter, 175
groups, 75

storage
managing through the web, 109

browser requirements, 109
stripe size

definition, 259
striping

definition, 259
SUNWscsd, 10, 205
SUNWscsu, 10
SuperFlex storage array, 195
system user password usage, 32

T
tabs

described, 29
Tag Count Per drive field, 152
TCP/IP, 17

establishing connection, 76
network interface

requirements, 7
technical support, xx
toolbar icons, 28
trap daemon

troubleshooting, 215
trap messages, 206
traps

Card Name, 206
Community Name box, 204
Event Date, 206
Event Severity, 206
Event Time, 206
Internet Protocol (IP), 206
IP address format, 205
Microsoft SNMP Properties window, 204
not received from server, 214
OID (object identifier), 206
on Solaris, 205
Server Address and Name, 206
Service Configuration window, 204
SNMP trap messages, 206
Transmission Control Protocol (TCP), 206
Trap Destinations list, 204
trap recipient setup, 204

Traps tab, 204
traps setup, 202
tree view, 74
troubleshooting, 211

Java version, 212
See also error codes
See also error messages

troubleshooting support, xx

U
uninstalling

Configuration Service, 15
Solaris OEs, 15
Windows, 24

Diagnostic Reporter
Solaris OEs, 178
Windows, 178

unmapping
LUNs, 68

upgrading
firmware

controller, 140
hard drives, 143
SAFT-TE devices, 145

UPS
using write-back caching, 260

Use a standby drive checkbox, 53

V
verifying configuration, 42
View CD-ROM window, 90, 91
View Enclosure command, 91
View Enclosure window, 91, 92
View FRU, 93
View FRU window, 93
View HBA Card command, 81
View HBA Card window, 81
View menu, detailed information, 78
View Report command, 104
View Tape window, 91
volume

definition, 260
Index 269



W
warning

New Configuration, 60
white device status item, 73
Windows

agent requirements, 18
agent starting/stopping, 21
console install, 20
console requirements, 18
creating NT users, 23
creating system users/passwords, 22
creating Win2000 users, 24
NT partitions, 49
system requirements, 17
uninstalling

Configuration Service, 24
Diagnostic Reporter, 178

users/passwords, 22
Windows NT, 193

world wide name
definition, 254

Write a new label to the new LD check box, 64
write policy

definition, 260
write-back cache

definition, 260
write-through cache

definition, 260
WWN

definition, 254

Y
yellow device status item, 73
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